Question about Audio Players & Recorders

Open Question

Hi I have a Yamaha C-70 pre-amp and a M-70 amp. The M-70 wont turn on. The manual troubleshooting guide lists a blown fuse as a likely cause. Could it be this? I read on a forum that the M-70 takes (1)15A 250V in the PS and (2)x 2.5A 250V in the rails... Anyone out there know if this sounds about right and If so...anyone know where I can get these fuses?

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: pioneer m-770 will not turn on

you probably have a short in the circuit some where. you need to replace the transistor and look at all the solder joints to make sure there not damaged or cracked. i have the same amplifier and i replaced the fuse several times and it blew every time up until the last time when the 4 of the power output transistors blew. what ever you do do not try and power it on till you do all the things i told you or you will have sparks and fire. my mistake cost me my amplifier. but might help you get yours repaired

Posted on Dec 24, 2007

Ad
  • 236 Answers

SOURCE: Yamaha P4500 service manual

one thing for sure Yamaha will not turn their back on their customers for support. What they normally say is that you contact your nearest service center for assistance. But you know you have a very good chance of getting a copy of the service manual since this is a very old model. i have the same amp being used in our church and yamaha service Japan has sent me by postal mail. technology nowadays is much different so maybe they can even send you in pdf format.

Write them by postal mail :
Yamaha Corporation
A/V PA Service Department
10-1, Nakazawa-cho, Hamamatsu, 430-8650 Japan.

simply tell them you need the manual and you are doing the servicing on your own. No one in your area can help you with it.

anyway, what is wrong with your P4500, it's a good amp but sensitive. very good design, hard to troubleshoot if you're not familiar with Yamaha amps. The main parts you can not replace buying from a local store though you may get the same part numbers specially power/driver transistors. it always comes in complementary pair critically matched by tthe factory. i tell you don't get the replacement anywere but Yamaha only. Yamaha have made to order power transistors tailor made for this Amp. you'll find the same transistor number outside but when you plug the unit, it wont last and worst it bursts !!! be carefull. Very hard to scan a copy of manual for you, but if you dont get a reply from Japan you can email me and we'll try to find a way to send you a soft copy.

Reden (redrivera0314@yahoo.com)
Yamaha service from Saudi Arabia 1996-2001

Posted on Mar 19, 2008

  • 4234 Answers

SOURCE: I have a phonic powerpod 7. the speaker

In bridge mode, the left and right amplifiers are in essence connected together. Typically, the speaker connections are to the positive connectors for each channel for this mode. WIth the speakers still connected, you essentially shorted the outputs to ground and smoked the output section. The unit will detect this now and not turn on the output section. Your unit is in what is usually called "protect" mode. This unit will require repair. Expect to have the output transistors replaced at the very least. I would estimate around $16-$40 for parts.

Dan

Posted on Jul 03, 2009

  • 4234 Answers

SOURCE: ps output +29.9v, -8v = no sounds. any ideas ?

Can you post the model number please. I have some Yamaha service info, but each model is different.

Thanks,
Dan

Posted on Jan 16, 2010

  • 102366 Answers

SOURCE: I have blown a fuse in my aiwa amp what fuse do i need to replace

I would replace the blown one.

Posted on Jan 06, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Stater does not turn over


Hi, Anonymous and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
5. Tip over sensor needs a reset.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
Yamaha XS 650 starter
Troubleshooting bike that wont crank
Yamaha XS650SE Shop Manual
http://mybikemanuals.com/yamaha/yamaha-xs-owners-manuals
Tips Tricks

Jul 04, 2014 | 1979 Yamaha XS 650 SF

1 Answer

Why my yamaha morphous wont turn over 2005


Hi, Anonymous and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
5. Tip over sensor needs a reset.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
www MajestyUSA com
Scooter Troubleshooting Scooter won start All about Scooters
Yamaha CP 250 06 Service Manual
OEM parts for Yamaha
Yamaha MORPHOUS CP250V Owner Manual

Jun 20, 2014 | Yamaha V Star Classic 650 Motorcycles

1 Answer

Wr125will not start


Hi, Anonymous and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
5. Tip over sensor needs a reset.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
YAMAHA WR125R Owner Manual Troubleshooting Charts
WR125X Wont Start
YAMAHA WR125R Owner Manual
OEM parts for Yamaha
Yamaha Wr125 Service Manual

May 26, 2014 | 2010 Yamaha WR 125R

1 Answer

1985 fz400r wont turn starter engine


Hi, Anonymous and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
5. Tip over sensor needs a reset.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
Troubleshooting bike that wont crank
http://www.r6-forum.com/forums/57-garage-mechanical-help/162715-will-not-start-good-battery-no-clicking-but-no-turn-over.html
Yamaha FZR400 1988 1989 Service Manual
OEM parts for Yamaha
http://mybikemanuals.com/yamaha/yamaha-fz-owners-manuals

Apr 23, 2014 | Yamaha Motorcycles

1 Answer

I have a Yamaha Raptor 700r battery powered atv, I have a new charged battery and when it is installed the battery power indicator lights doesn't light up at all. I know the battery works because I use it...


Assuming the Raptor does not start:
The main fuse and the fuse box are located under
the seat. There should be a spare fuse there also. Turn the key to
OFF and turn off all electrical circuits. Replace any blown fuses.Turn the key to ON and turn on the electrical circuits to check if the devices operates. If the fuse immediately blows again, have a Yamaha dealer check the electrical system.
I found this in the online owners manual at this site:
http://www.yamaha-motor.com/assets/service/manuals/2008/LIT-11626-21-12_Raptor700_SE_1516.pdf
Maybe the manual will help troubleshoot your problem.

Jan 05, 2014 | Toys

1 Answer

Horn and rear lights dont work on 2012 yamaha r6


Hi, Anonymous for this scenario you will need your service/owners manual if you can't find the first and best tool you ever bought for your Yamaha, despair not, for a mere $10 you can download another one. For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have a nice day.
http://www.r6-forum.com/forums/57-garage-mechanical-help/82066-turn-signals-brake-light-not-working.html
http://www.r6messagenet.com/forums/r6-how-guides/155217-blown-fuse-2009-r6.html
2009 2013 YAMAHA R6 YZF R6 Service Manual Repair Manuals AND Owners Manual...
OEM parts for Yamaha
http://mybikemanuals.com/yamaha/yamaha-yz-owners-manuals

Nov 19, 2013 | 2012 Yamaha YZF R6

1 Answer

Speedometer and cruise control not working


Look in your owner's manual for the fuse layout and see where the cruise system fuse is and check it for a blown fuse. If it is replace with the rating listed in the guide. If not then you may have to have an automotive electric shop troubleshoot the cause such as a bad ground, blown inline fusible link or other. If it is a fuse and you replace it and all is working then it blows again you should have a shop troubleshoot the cause. Blown fuses generally are due to a short in the circuit. On some vehicles the "clockspring" in the steering column can cause lack of operation in the horn and cruise control but since you mentioned speedometer and cruise it is likely a fuse.

Dec 08, 2011 | Cars & Trucks

2 Answers

2010 yamaha r1 shows fault codes 66 & 70. what do these codes represent. thanks.


CODE 66: "Open or short circuit of steering damper solenoid lead."
Check the ESD fuse has not blown first befoe checking the wiring itself.
CODE 70: This model is equipped with an engine auto-stop system. The engine stops automatically if left idling for 20 minutes. In this case, the multi-function meter indicates error code 70, but this is not a malfunction. Push the start switch to clear the error code and to restart the engine.
Hope this helps

Apr 19, 2010 | 2008 Yamaha YZF-R1

1 Answer

Hi! ALL How do I connect my Yamaha eq-70 to pre amp and power amp my Yamaha thanks


Pre-amp out to input of EQ

Output of EQ to poweramp.

If that doesn't help post all your model numbers and I will look it up.

Cheers,

Jan 06, 2010 | Yamaha EQ-70 Home Equalizer

1 Answer

My old yamaha wont stop buzzing


HI SIR .THAT IS NOT BIG PROBLEM.ALL YOU HAVE TO DO MAKE SURE THAT YOUR PRE HAVE THE FLL.1 PROPERLLY EARTHED(THE GROUND FROM YOUR AMP ALSO GOES TO THE PRE )2 ASK YOUR ELECTRONIC MECHENIC TO CHECK IF THER'S NO BROKEN GROUND ON THE BOARD INSIDE.

Aug 17, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5126 Answers

The Knight
The Knight

Level 3 Expert

74251 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...