Question about Kicker ZX550.3 Car Amp

1 Answer

Mty zx550.3 amp isnt working correctly my bass cut in and out two or 3 times one day and never came back on i have power to the amp on power wire and remote wire, the front door speakers still work and they run through the amp. Could i have problems with the sub output part or is there something i can do to fix it.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 47 Answers

You blew the sub woofer audio outputs, and the amp is going to need to be repaired.

Posted on Jun 04, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Amp is on, but sub wont produce any bass


Make sure the subwoofer is set to low frequency, make sure subwoofer and bass are enabled on the headdeck. Make sure the gain is turned up on the amp, make sure the rcas haven't come out of the back of the head deck.

Aug 04, 2009 | JBL GTO14001 Car Amp

1 Answer

Speakers cut off when bass goes up


probably the amp going to safe or protect mode judging by the fact that you have 3 subs wired to it i would say it is not 1 ohm stable try disconnecting 1 sub and see if it still happens this will be running a 2 ohm load rather than 1 if it stops happening then you need to figure out a better wiring configuration that will work with your amp.

Jul 03, 2009 | Kicker ZX400.1 Car Audio Amplifier

2 Answers

Noise in my car amp.


sounds like you have a bad ground going to your rca's. try running a wire from ground to the shield of your rcas and see if the noise goes away.

Apr 19, 2009 | Rockford Fosgate Power 1050S Car Audio...

2 Answers

Why does my KAC-8404 cut off at high volume bass?


amp 101

1/0 wire to the amp or the amps will loose power

check the connections mainly the negative

wiggle the wires see if you get a cut out or not

a cap will help you give constant power to the amp and not allow them to drain on long bass notes

hope this helps

Dec 26, 2008 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

Speakers cut off when bass goes up...


sounds like you hava a load problem.if your'e running your woofers at 1ohm,make shure your amp is 1ohm stable.....

Jul 03, 2008 | Car Audio & Video

1 Answer

AMP FOR SUB SHUTS OFF SOMETIMES


your amp may be overheating, or you have it up too loud and the surge protector is shutting it of in fear of damage to your amp.

Apr 24, 2008 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

No bass thru cd player


it seems like you connected the wrong remote wire to the amp.
Alpine has two remote wires.
BLUE (only) This is the pwr antenna remote wire,every time you insert a cd this remote wire,the pwr cut out.
BLUE/WHITE STRIPE This is the AMP REMOTE WIRE,THIS IS THE REMOTE WIRE THAT YOU NEED TO CONNECT TO THE AMP
LET ME KNOW IF IT WORKS
thank's

Dec 25, 2007 | Alpine CDA-9807 CD Player

1 Answer

My subwoofers cut out


You are most likey running too much power from the amp to the speakers.. you might want to try just notching the bass down a notch or 2.. just enough that the bass will hit

Nov 16, 2007 | Car Audio & Video

2 Answers

Amp cuts off


You may have a problem with the power source feeding the amp. You need to check the voltage across the amplifier's B+ and ground terminals when the amp is playing/cutting off. If it's dropping below ~11 volts, you need to determine why it's dropping so low.

Sep 18, 2007 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

3 Answers

Amp stopped working...


Has the amp been overheating lately? It's quite possible that the amp could have just blown. Smell around the outside of the amp for an electrical burnt smell. If available, see if a friend also has an amp hookup and try removing your amp and copnnecting to the friend's cables. That will tell you if it's a wiring problem or an amp problem.

Sep 13, 2006 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Kicker ZX550.3 Car Amp Logo

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...