Question about Hitachi 50V500 50 in. HD-Ready LCD Television

1 Answer

60v500 Hi Big Irish...I see that you have helped tons of people, and I am hoping that you might find time to help me!! When I plug in my 60v500, both fans power on, and the bulb lights up also. The screen will "flicker" for just a moment also. When this happens, all of the LEDs on the Power P.W.B. light up, and on the front panel, the LEDs indicate normal boot up sequence. In about 3-5 seconds, both fans, and the bulb power off. When this happens, all of the LEDs on the Power P.W.B. turn off EXCEPT (green) D913...It will stay on until the TV is unplugged. I have already replaced both fans AND the Power P.W.B. board, and the bulb is almost brand new. Oh, and when it shuts off, on the front panel, the TEMP link will blink, but the others stay off. What should I look at now? Thank you...and feel free to email me at egear00@yahoo.com!!!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 927 Answers

Good Day, eger00;
Try this:

First, some clarification related to this Flowchart is necessary. The block which states * PSL #4 pin Voltage sequence is like below? a) high (3s) b) low (3s) c) high (15s) d) low (3s). This indicates seconds in which the ballast is attempting to light the Lamp. The Connector PSL is a very small connector that actually faces down with the ballast is installed. It is also very difficult to access. It's much easier to use the Spark Gap process for determining if the Ballast is attempting to fire up the Lamp. Take a look at the bottom of the flow chart below. If the Spark Gap sparks when trying to turn on the set, it's almost a guarantee that the ballast is working OK and it's the Lamp that's defective. Also, the LEDs on the front of the LCD will flash in sequence Left to right as this process is attempting to light the Lamp. The front LEDs doesn't guarantee that the ballast is functioning correctly, but it does indicate the System Control process for lighting the Lamp is working.
60v500 - 30_lam1.gif
Good Luck, big IRISH.

Posted on Aug 17, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Big screen got wet in back.


Hi Check the power cord that is properly plugged in on the TV and in the wall. Check that breaker pannel that all are on. Unplug TV for half hour and try again. Hope that helps.

May 30, 2012 | Panasonic TCP42U2 4 in. TV

Tip

Lamp vs Ballast


This is to help explain the short lives of Lamps.

WARRANTY: If a lamp fails within the first year replace Lamp and Ballast.
If Lamp explodes do not replace Ballast only lamp, but if lamp didn’t explode replace both.

If you experience more than one Lamp failure within one year of use replace the Ballast.

The Panasonic Brand offers a Ballast repair kit (LSUC0022), it only works about 20% of the time.

I would not recommend this replacement kit. It will get you past the 30-45 day warranty period in most cases but it will not be the proper FIX to the customer’s unit and they will only call you back or (most important) call another Service Center.

I have experienced maybe 100 customers that had other Service Companies come out and only replace the Lamp. When the Lamp and Ballast should have been replaced.

I hope this helps the Customers and the Technicians in their judgment.

If I was redundant I apologize, just trying to help.

Good Day, big IRISH

on Dec 09, 2009 | Televison & Video

1 Answer

Want to install new lamp in hitachi 60v500. Need to know how


Lamp replacement procedure in Hitachi 60v500 is written in its user manual in details and its easy.
Click HERE to download user manual free copy, if you need it.

Jun 28, 2010 | Televison & Video

1 Answer

Samsung LCD 40 inch LNT4061


Howdy,
It sounds like you have a Power Supply Board problem. The PSB is the center Board (towards left) after you remove the back off the TV. Remove Board from TV with the 6-7 screws. Replace capacitors CM852 & CM853; 2200ufd 25volts.

Thanks for using FIXYA, big IRISH.

Dec 31, 2008 | Samsung LN-T4061F 40 in. LCD HDTV

1 Answer

Dead set


Good Day;

99% of the time it's best to replace the board. Good Luck, big IRISH.

Oct 02, 2008 | Televison & Video

1 Answer

Great...Thanks


Good Day, egear00;
This chart shows were voltages are on the ballast. If you the voltages then suspect the ballast, if no voltage suspect the the power source.
Good Luck, big IRISH.

Aug 17, 2008 | Hitachi 50V500 50 in. HD-Ready LCD...

2 Answers

Yellow spot


Good Day, dv28;
No, the lamp will not correct this. The TV has a bad light engine, it's very common for this TV and very expensive. Call the manufacture and try to get a concession for the part. They normally give it about 75% of the time.
Good Luck, big IRISH.

Aug 14, 2008 | Hitachi 50V500 50 in. HD-Ready LCD...

2 Answers

Light engine replacement


Good Day, tech;

Let's suspect poor cable connections or pinched, BUT I have received bad light engines. Make sure you ordered the correct Part Number. There are two (models) of them; check Model Number, some are 50V500 and 50V500A.

What's your input to indicate red or green???

Let me know if this helpful, big IRISH.

Aug 10, 2008 | Hitachi 50V500 50 in. HD-Ready LCD...

1 Answer

Hitachi 60v500 tv has split screen with white vertical stripe down side


Good Day, poandflo;
After removing the power from TV remove the back of the TV (bottom only): Repair: Re-insert PDM connector on both Main Digital module and Drive PWB.
Good Luck, big IRISH. ps. remove cables one at a time and plug back in ensuring that they are seat properly.

Aug 08, 2008 | Hitachi 50V500 50 in. HD-Ready LCD...

1 Answer

Will not turn on blue light comes on but then goes off and red lamp light stays on


Good Day, ebfmays;
Check the lamp and (reboot) reset the TV by unplugging A?C cord from source wait 3 to 4 minutes then plug cord back in.
Good luck, big IRISH.

Aug 05, 2008 | Hitachi 50V500 50 in. HD-Ready LCD...

Not finding what you are looking for?
Hitachi 50V500 50 in. HD-Ready LCD Television Logo

140 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Televison & Video Experts

The Knight
The Knight

Level 3 Expert

69878 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

matt martin
matt martin

Level 3 Expert

1198 Answers

Are you a Hitachi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...