Question about Little Giant Plumbing

1 Answer

The pump was working fine, then approx. a day later it started popping the main breaker. I checked for debris cleaned the pump and then tried plugging it in again. It still keeps blowing the breaker. Can this be repaired? I have model # 9S-CIA-RFS witha 2" opening.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 29 Answers

Most likely have a short. replace the pump.

Posted on Jul 15, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Was working fine. Tried a few days later to dry a load and the starter wouldn't turn load on.


First. Check voltage if its a electric type flip breaker all the way off than back on sometimes breaker flips halfway. Then check for a thermal overload near blower housing usually long and white if it fails motor won't run

Jun 12, 2015 | Dryers

1 Answer

Pump wont turn on


make sure heat maintain is off if ok new pump

Apr 04, 2014 | Pentair Pool & Spa

1 Answer

I got the bike rode for a while it sat for a couple of weeks and when I tried to start it it was dead. I tried getting the battery charged and it didn't work. I got a new battery and that worked for about...


If the bike is losing ALL power, I'm talking about dash lights, headlight, tail light, ALL lights, it's probably something tripping the main breaker. The breaker should be located either under the seat or behind the trianglular panel on the right side of the bike. I'd look for a frayed wire near the starter or around the rear cylinder due to the head in that area.

Good Luck
Steve

Nov 12, 2010 | 2005 Harley Davidson XL 1200 C Sportster...

2 Answers

My unit was working fine until 3 days ago when the breaker tripped, I reset the breaker and worked fine for a day then tripped again when it tripped both the ac breaker andthe main in the trailer as well...


High amp draw can be caused by a few different things, so first check that incoming voltage to trailer is sufficient. (115 volts) Not unusual for some parks to install more hydro hook-ups on a feed line, and when all are up and running, your incoming voltage could be decreased. If your o.k. that way, then I'd start looking at the compressor circuit of your ac, in particular, the compressor start-up capacitor. The capacitor basically stores electricity and boosts it to higher voltage for compressor and fan start-ups to reduce current draw that will trip the breaker. Please have a knowledgeable electrician, or RV tech check this for you, as a capacitor can give a real good high voltage (possible fatal) shock, even when power is off to unit. I also suspect that the start relay has shorted (welded) itself due to high amp draw situation, and that is reason it comes on by itself.

Jun 21, 2010 | Dometic Rooftop RV Air Conditioner

1 Answer

Refrigerator trips circuit breaker


try standing it upside down for a day it will work

May 28, 2010 | Amana ATB2135HR Top Freezer Refrigerator

1 Answer

Pump was working fine yesterday popped the breaker


Hi Mohn,

Don't know your geographic location, but where I am we've been in the single digit temperatures for three days. Everything that can freeze has frozen.

If you are in a similar area, even though the water in the spa (I'm assuming the spa pump is being used on a spa) is heated, the pump housing isn't. If it iced up, it could very well cause the problems you describe.

Comment back with some more detail before I continue down what might be the wrong path.

Best regards
Mike

Dec 11, 2009 | Aqua Flo 2 HP Aqua-Flo Pump: 2" in/out,...

3 Answers

2000 Crown Vic cranks but won't start.


Check the fuel pump reset switch again, if it is popped back out then replace that little switch in the trunk, any ford one will do. it works off a magnet and a bearing to close the circuit for the fuel pump. easy fix.

Oct 05, 2009 | 2000 Ford Crown Victoria

Not finding what you are looking for?
Plumbing Logo

Related Topics:

256 people viewed this question

Ask a Question

Usually answered in minutes!

Top Little Giant Plumbing Experts

Mack Baxter

Level 3 Expert

383 Answers

JOHN LAPIER

Level 3 Expert

2428 Answers

Gary Nitowski

Level 2 Expert

298 Answers

Are you a Little Giant Plumbing Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...