Question about Kirby Shampooer Shampoo Hose G3 Ultimate Diamond Vacuum

1 Answer

How do i replace the band - Kirby Shampooer Shampoo Hose G3 Ultimate Diamond Vacuum

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Kirby Expert
  • 324 Answers

Hello,

Please see the instructional video here

Good Luck,

Rocky

Posted on Dec 17, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I read the post about the Silver Moon continualy shutting off and requiring the new hose part SES 125. However, what i have noticed with my Silver Moon is that it only shuts off when using the floor brush....


Hi.
My wife has the same vacumn, and has already replaced the hose, and again it was shutting off continously with the power head.
Rather then spring another $150.00 plus for a new hose, I decided to take it apart to see if it had a shorted wire..
There are several small screws along the length of the control portion, as well as two small screws that hold the end cap (where the hose goes into the heavy plastic control part),

When I got it apart I did not see any shorted wires...however what I discvovered was where the hose "swivels" are 3 metal contact bands, and some electrical lubricant.
On the other side was a small circuit board with three paper thin copper contacts which lined up with the metal bands.
The bands looked a bit worn.
So I ever so gently bent the copper contacts out just a tiny amount further, and gently cleaned (with a bit of alcohol) the metal bands to take justy a tiny bit of what looked like an excessive amount of electrical grease.

I reassembled the unit...and so far so good.

Jan 15, 2011 | Miele s558 Silver Moon Vacuum

1 Answer

The brush does not go around. The rubber band on the brush also does not revolve.


That means that you need to replace the the belt. You can get replacement belts here:

Replacement Vacuum Belts

Mar 09, 2010 | Vacuums

1 Answer

How do I change the bag on a dirt devil model 103?


On the open end of the bag that slips onto the vacume, there is a cloth "tab" sticking up from the band. Take hold of this tab and lift up while easily pulling back until you see the band about half way off the vacume. Now, you can take hold of the band and pull the bag the rest of the way off. You will notice that there is a "rib" in the middle of the band on the side that faces the vacume. That rib fits into the groove where the band goes on the vacume. When you install the bag put the band on this groove and work the band on around the housing. You can center the "tab" anywhere, just place it where you can get to it easy. The other parts you need are on the internet, I found them all including that rubber plug called the "attachment port" plug. The p/n for the replacement part is 3-201744-601. The original p/n is 3-501744-601 but you'll be better looking for the replacement part number. Good luck!

Dec 30, 2009 | Dirt Devil Vacuums

2 Answers

Rubber band slipping to edge of the silver spoke


Hi thanks so much - the vacuum is an upright morphy richards model number 73360.

We kept re-alligning the band into the middle and rolling the brush round several times with our hands to make sure it wouldn't spin off. The roller that the band fits on is very wide so you just put the band in what you think looks like the middle.

It was unbelievably sensitive and had to have it "exactly perfect" to the millimetre otherwise the band would just continue to slip off. It appears to be working for now so lets see how long it lasts before the smell of burning again! Many thanks for advice.

Aug 15, 2009 | Vacuums

1 Answer

Hoover Elite Rewind - powerhead brushes are not turning


most likely band is broken. Usually there is a spare in the box or on the unit when new. Unscrew 2-3 screws by beater bar (brushes) pull off cover and replace band.

Jul 09, 2009 | Hoover U5507900 Elite Rewind Bagless...

1 Answer

I checked the belt and it has not broken, but when I start to vaccum the spinning head stops, and I start to smell a rubber smell...Do you think I need to replace the belt, I did get some string caught in...


Yes you do need to replace the belt they stretch out. Think of a belt like a big rubber band if you were to stretch it out and hold a lighter to it the rubber band would stay stretched out. That is the same thing that happens when you get it caught on string or an area rug the brush stops but the little metal shaft keeps spinning creating heat and stretching the belt. Visit www.stevessewandvac.com for belts, bags or any other vacuum need.

Aug 13, 2008 | Bissell Vacuums

1 Answer

The rubber band that turns the roller on the vacuum keeps breaking. I just bought a new rubber band, put it on, and it broke immediately. Can it be fixed?


Generic problem for all Vacuums
The rubber band that turns

The rubber band that turns the roller on the vacuum keeps breaking. I just bought a new rubber band, put it on, and it broke immediately. Can it be fixed?

I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
I see there could be 2 problems – either your revolving brush has hair or thread buildup in the ends of the brushroll of which is causing the belt to break and would need to be cleaned out, or check the bearings on each end – they could be **** as well, or the motor shaft or motor assm is not tuning freely and in that case the motor should be replaced and it is not the belt – one other thing is to make sure the motor is in there securely. Once you get the belt on then roll the pulley and the belt together to make sure the belt is on correctly if the brushroll spins freely.

Apr 18, 2008 | Vacuums

1 Answer

Wand won't release


Quoting from page 6 of the manual:

"Select the radio band and tune in a desired radio station you wish to store in the preset memory.
Press and hold, for at least 2 seconds, any one of the preset buttons (1 through 6) that you want to store the station on. The selected station is stored. The display shows the band, preset number and station frequency memorized. A total of 18 stations can be stored in the preset memory (6 stations for each band; FM1, FM2 and AM). If you store a station in a preset memory which already has a station, the current station will be cleared and replaced with the new station."

http://www.retrevo.com/search/v2/jsp/downloadPage.jsp?doc=934dc6a1672f80b9d320c470df81f04d&q=Alpine+CDE-9842

Feb 25, 2008 | Dyson DC14 Animal Bagless Upright Cyclonic...

Not finding what you are looking for?
Kirby Shampooer Shampoo Hose G3 Ultimate Diamond Vacuum Logo

Related Topics:

26 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kirby Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18408 Answers

JoeVacs

Level 2 Expert

357 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Kirby Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...