Question about Cameras

1 Answer

I snap a shot on my Pentax zx-7 and the flash will go off but the film doesn't advance, the number on the roll indicator stays that same, and there are no negative being transferred onto the film itself. What's wrong? Even when I change setting to "auto pict" the same thing happens?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 214 Answers

Hi I need more information. After pushing release button, you will hear motor running sound---like mirror goes up and down and takeup spool running sound. I want to try more. First remove lens and set M mode. Push release button. You will see mirror up/down and motor running sound. If you can see these thing, then you have defective camera. Let me know more detail. thanks and best regard!

Posted on May 26, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a pentax zx-60 that is showing an error message o_ _ _ _ with an E on top of that. I'm not sure what it means or how to fix it. I tried reloading the film and it doesn't seem to advance.


I think the 'o____' is intended as a pictorial representation of a roll of 35mm film, the 'E' signifying an error in loading it. Not used this particular Pentax model myself, but some of them have a slot in the take-up spool where the 'tongue' of the film should be inserted - is that the case with yours ?

Nov 27, 2015 | Pentax Photography

1 Answer

My Pentax ZX-7 (MX-7) mirror is stuck


This camera can be notorious for these types of film advance issues. The bad news is that a ZX-7 is probably not repairable. Good news is that there are many used Pentax bodies out there that will work with you lenses.

Dec 11, 2013 | Photography

1 Answer

Pentax ME super advance film doesn't get caught


This is a known fault with this retro model, I'm afraid - over time, the plastic gears get worn, and eventually fail. Solutions are mentioned on the Pentax Forums.

Aug 19, 2017 | Pentax ME Super 35mm SLR Camera

1 Answer

I recently shot three rolls of color film with my ZX-7 in auto pict mode and all the negatives turned out blank (underexposed). What happened?


lens cap ? ;-]

Did you have the asa film speed set correctly? Thats usually the cause unless your battery isn;t quite right.

Mar 23, 2010 | Pentax ZX-7 35mm SLR Camera

1 Answer

My film won't load


Jammed Advance Motor Assembly.

Feb 27, 2009 | Pentax ZX-60 35mm SLR Camera

1 Answer

Film advance


throw it away, its already old, buy new ones a pentax g40, its a computer compatible.

Feb 28, 2008 | Canon Sure Shot 80U 35mm Point and Shoot...

1 Answer

Pentax zx 50 35mm slr


Others here have suggested the problem lays with the plastic gear on the advancing motor beside the mirror.

This might cost $100 or so...?

Oct 22, 2007 | Pentax ZX-50 35mm SLR Camera

2 Answers

Pentax zx-50 Shutter Problems?


I really think this is the classic zx - 50 shutter motor problem : small motor on the side of the mirror box is not cocking the shutter . This is very repairable but unfortunately it requires fair amount stripping down of the camera to get to the fault and so you will have to take it in for repairs.

Sep 03, 2007 | Pentax ZX-50 35mm SLR Camera

1 Answer

Pentax MZ 50 film winding problem


Well, I'm not a camera repairman, but it sounds to me (and probably to you too) that the electronics are damaged or perhaps there's dust in the contacts inside. I also have an MZ-50. There's so many electronics involved and they don't age so gracefully. I would consider buying another one off eBay or you can get a ZX-30 (same as MZ-30) for $75 from Blue Moon Camera & Machine with a 1 year warranty (parts and labor). The best way would be, in my opinion, to get a manual, mechanical camera from the 1970s and put a good lens on it. Those seem to last forever. No electronics to worry about. Advance and rewind the film manually. You can use a digital camera as a light meter to set the aperture and shutter speed. I'm thinking of going this route when my MZ-50 finally conks out.

Apr 25, 2007 | Pentax MZ-50 35mm SLR Camera

Not finding what you are looking for?
Cameras Logo

Related Topics:

50 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cameras Experts

kakima

Level 3 Expert

102366 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...