Question about Garden

1 Answer

We have a purex triton metior 26" 8 position sand pool filte that leaks at the top of the tank. We have changed the "O" ring but it still leaks alot. What else can we check? Thanx

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 927 Answers

Try lubricating the o-ring with vaseline before installing. Make sure there is no sand on either of the surfaces that the o-ring touches.
Gary

Posted on May 25, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a purex triton sand dollar 60 filter I replaced the sand and when I go to put the top back on the filter it will not go down in all the way if the o ring is bad could that cause it not to go down...


First, try a RUBBER mallet and GENTLY tap the perimeter of the Valve Head Flange to seat the Valve Head into the canister tank. If that does not work, you either need a new O-ring or your canisters center tube is off center or there is too much sand UNDER the canisters internal Filter Fingers at the bottom of the tank.

Hope this helps,

Dan Osko
Osko Pool n Spa
http://www.oskopoolnspa.com

May 11, 2014 | Pool & Spa

Tip

Triton 2 tr60 sand filter tank


My tank on a tr60 with only 20psi is the max I get on pressure well guess what the bottom is cracked, no problem get a new one. Not at almost 900.00 so I thought about it and came up with this, wet vac sand out disconnect the tank from lines, unscrew in side line on the top, remove fingers from the bottom assembly, in screw that pipe now all you have is a tank with 2 fittings and a drain. Go buy same fiberglass repair kit and start sanding inside and outside (outside is very important to get the gel coat off) and apply your glass I used a sheet then on top of that I used a mat and another sheet that is inside, on outside I used mat then four sheets first pict is the crack before doing anything second is the finished product that cost me 8 hrs of time and 34.00 kit for fiberglass from Home Depot. (NOTE WARNING I WOULD NOT ATTEMPT THIS ON HIGHER PRESSURE TANKS)
http://i.fixya.netwrite_tip-rrbdisodbu3ix3ptcrwcvqfl-4-0.jpg

25787646-rrbdisodbu3ix3ptcrwcvqfl-4-0.jpg

on Jul 18, 2015 | Pentair 140315 Swimming Pool/spa Sand...

2 Answers

Purex 4000 filter leaks at bottom


there is a drain plug on bottom see if tight

Feb 07, 2013 | Pentair FILTER TANK BOTTOM, 48 SQFT

1 Answer

Triton Purex minimax 400


dan i belive you have a faulty thermastat switch

Apr 01, 2012 | Pentair MiniMax CH Natural Gas Pool...

1 Answer

Can't get my creepy crawler to work in my pool, i have a purex triton filter system, i can't get any suction on from the crawler


It sounds like your automatic pool cleaner might have a leak that is causing the pump to lose its prime. Check the hose to make sure that there are no leaks or cracks. Check the vacuum connection. It should be submerged so no air enters the system. Look and check the pump basket lid for looseness, cracks, and worn or missing O-rings.

Feb 26, 2011 | Universal Kreepy Krauly In-Ground Pool...

1 Answer

How do i change the sand in the filter? I am getting sand in my pool.


You will simply remove the old sand from your pool filter and follow the instructions from your users manual like you are adding sand for the first time. In case you don't have it, I am going to paraphrase it for you below.

1. Be sure correct amount of filter sand media is in tank and
that all connections have been made and are secure.
IMPORTANT: To prevent unnecessary strain on piping system and valving, always shut off pump before switching Filter Control Valve positions.
The correct amout of sand can be determined with this link: http://www.backyardcitypools.com/pool-filters/Filter-Sand-Requirements.htm

2. Set your controls to the backwash position.

3. Prime and start pump according to pump instructions. (be sure all suction and return lines are open), allowing the filter tank to fill with water.

4. Once water flow is steady out the waste line, run the pump
for at least 2 minutes. This initial backwashing of the filter is recommended to remove any impurities or fine sand particles in the sand media.

5. Turn pump off and set valve to RINSE position. Start pump and operate until water in sight glass is clear—about 1/2 to 1 minute. Turn pump off, set valve to FILTER position and restart pump. Your filter is now operating in the normal filter mode, filtering particles from the pool water.

6. Adjust pool suction and return valves to achieve desired
flow. Check system and filter for water leaks and tighten connections, bolts, nuts, as required.

7. Set your filter to the "filter" position.

May 22, 2010 | Hayward SAND FILTER, PRO SERIES

1 Answer

Pentair sm2-pp3 valve, triton II filter. Upon


Lots of sand? You may have a broken lateral in your filter.

To repair, you will have to remove all the sand from the tank to physically inspect.

Might you have changed the sand this year? (top 1/3 needed to be changed every 3 to 5 years normally) If you changed the sand ... did you put water in the filter tank first? If not ... there is a good possibility you broke a lateral (a small pipe with slits in it) when you put the sand into the filter.

It could be that you have too much sand in the filter. Check the owners manual for the clearance - top of sand to top of filter.

Thanks for your interest in FixYa.com

May 14, 2010 | Pool & Spa

1 Answer

My husband changed the sand in our Hayward Sand filter for our pool and now it leakes sand into the pool. What's wrong?


Thank you for posting your question here on Fixya.com.

He broke the lateral assembly in the process and it will need to be replaced. You'll need to know the model number of the filter to get one. Then remove the sand, replace the assembly, fill the tank ~1/2 way with water, slowly add the sand back into the tank and replace the valve.

If this answer does not fix your problem, please comment with additional details prior to rating the answer. Positive feedback is appreciated once your problem is solved!

John

May 05, 2010 | Plumbing

1 Answer

Purex Triton Minimax 400 pool/spa heater not igniting


This sounds like you have a problem with your pilot. You can check this with a small mirror to see if their is a spark when you turn it on. If you have any soot build up on the pilot that will stop the spark and keep it from lighting also. If you have a short on your pilot wire this could be the problem also. I hope this helps, good luck.

Jun 05, 2009 | Pentair PUREX MINIMAX HEATER; THERMOSTAT,...

Not finding what you are looking for?
Garden Logo

Related Topics:

48 people viewed this question

Ask a Question

Usually answered in minutes!

Top Garden Experts

Dennis Key
Dennis Key

Level 3 Expert

2478 Answers

john h

Level 3 Expert

12104 Answers

yadayada
yadayada

Level 3 Expert

76070 Answers

Are you a Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...