Question about Electrical Supplies

1 Answer

I have a Professional Power Station PS1000 that has worked fine for several years. However, today the reversed clamps led came on along with the buzzer. I pluged it in and it indicates charged but the reversed clamps led stayed on. Meter shows no charge. Is it time to get a new one? Thanks for your help. Steve

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

My professional power station ps1000 will not charge in the house but will in the car why

Posted on Dec 11, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a Professional Power station PS1000 chharger. Light indicates charged but voltage meter when pressed does not move. emergency light comes on but weak.


I have the same problem with my ps1000. I turned on the light and plugged the charger. it lit up the charging led. after 2min the reverser clamp led with a light buzzing came on. I am going to keep charging it but keep checking it for over heating. dont want it blowing up in my face. lol

Aug 08, 2010 | Measuring Tools & Sensors

1 Answer

My receiver has been working fine for years. Today I started hearing feedback. I checked my wiring and I'm getting feedback across every channel. What do you suggest?


I'm assuming you mean RF/EMI noise. This can be due to one or several factors.
Have you recently installed something new into the same circuit that the unit is plugged into, such as a refrigerator, microwave, air conditioner, other appliance or fluorescent lighting? The sun is also a factor, and also the aurora borealis.
Try plugging it into a an a/c line conditioner and or tyr ferrite clamps on the power cord to the unit.

Dec 16, 2009 | Harman Kardon AVR 125 Receiver

1 Answer

I have an 8710 workstation and it has worked fine for many months. Recently I've been having problems powering it on. I use a docking station and when I try to power it on in the morning -- the power LED...


Flashing orange light generally indicates battery low charge could be your battery at fault
the next time you try and power on and it doesnt work, take the battery out (unplug AC) and try to run just on AC power
hope helps, let me know if can help further

Nov 04, 2009 | HP Compaq 8510w Notebook

1 Answer

No reverse all of a sudden


check power to the reverse shift solinoid

Sep 30, 2009 | 2002 Chevrolet Impala

1 Answer

Won't shift into reverse.


I agree. Find a transmission. There is really no easy fix. Sorry.

Mar 19, 2017 | 1994 Volvo 850

1 Answer

Router stopped working altogether


You can try doing a master reset. (must refer to owners manual on how to) or replace the entire unit. Most likely the unit has failed.

Thanks, Frank
@Tech
http://www.attechcomputers.co.cc

Apr 02, 2009 | Microsoft Broadband Networking MN-500...

2 Answers

BassCube 12 Startup Problem


same here. happened after moving residences

Jun 30, 2008 | Cambridge Soundworks BassCube 12 Speaker

1 Answer

A bank of blinking leds??


The blinking LEDs means it need to have it's ID reprogrammed. Press the Program button and then the station number (Station 1 or 2 or 3 etc) to store the setting.

Nov 14, 2007 | Panasonic KX T3281W Corded Phone...

2 Answers

Sangean ATS 606 A Portable Radio


Remove the battery compartment door and the batteries. There should be a small hole marked "reset" under the upper battery cradle. Press (gently...until it clicks) and hold for 5 seconds. Replace batteries and try again.

Aug 15, 2007 | Sangean ATS 606 AM/FM/SW Radio

Not finding what you are looking for?
Electrical Supplies Logo

Related Topics:

335 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrical Supplies Experts

Steve

Level 3 Expert

3287 Answers

Gene Haynes

Level 3 Expert

5089 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you an Electrical Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...