Question about Kenmore Progressive Upright Vacuum with InteliClean System Slate Blue

1 Answer

I vacumned up a cat toy and now there's no suction and i don't have manual. do i need to unscrew all those screws on the bottom to find toy?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,301 Answers

Yes you need to remove the bottom to get access to the flow of the air section, while doing this be sure to clear any debris collected in the roller brush section , if you can't find a manual,, an easy method is just check the sections of the unit where the debris travels and unclog any clogs, be sure and clean the hose section too as the item may be lodged in the hose too

Posted on May 24, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I thought I was buying a manual. I put a new belt on my vacumn but it makes a funny noise and does not leave vacumn lines on the carpet like it used. I don't know if it takes two belts or one.Wish I...


Hi Frrank: The Owner's Manual for the Euro-Pro Infinity NV31N Vacuum can be downloaded in PDF from the following site:

http://dl.owneriq.net/d/df6c4a72-cf05-7934-2963-ee752eb0e124.pdf

See pages 15 and 16 of the PDF for instruction on replacing the single belt.

If this is not the manual for your model, please reply and will try again.

Thank you for using FixYa!

Feb 17, 2012 | Euro-Pro NV31 Infinity Vacuum

1 Answer

Vacuum smells and is not picking up well. Took the pole apart and I don't know hao to open the bottom.


To get into to the bottom of the vacuum, flip it to where you can see the bottom of the baseplate. Only unscrew the recessed screws...4 to 5 screws. Once you have removed those, the basepalte will pop off. It is probably just clogged at the bottom.

Sep 05, 2011 | Oreck XL Ultra Bagged Upright Vacuum

1 Answer

I bought a Kenmore 30012 Quick Clean Vacuum on 7/5/2011 it was working fine till just recently. Its not picking up anything off my rug, I've cleaned the filters, the belt is fine. It was blowing dust...


A clogged inlet. Something is likely clogging the opening where the dirt goes in. Paper, cellophane, or anything else light enough to get sucked in but too large to pass through.

Aug 18, 2011 | Kenmore Quick Clean 30012 Vacuum

1 Answer

Why does my filter collect so much dog hair and decreases the suction of the machine. I clean and change (alternate) filters everytime I vacumn, that isn't normal, is it? It seems like I have a seal or...


You obviously have a pet and it's good to see your machine is doing it's job. The only reason you could lose suction while collecting pet hair is due to the pet hair being a solid mass and air not been able to flow through the filters.( must be a lot of hair). Suction loss is only when the particles passing through your machine are dense therefore it will reduce suction and airflow . Very common on vacuum cleaners. Do not worry too much . Also check to see if you have Amy cracks in the seal between the drum and the vacuum cleaner itself

Jul 15, 2011 | Dyson Vacuums

2 Answers

We have a Miele Silver Moon vacuum that isn't


Hi dear.There are two type of attachments for this vacuum cleaners to pick up the pets hair,fluff & so on.They call it"Turbo & Power Brush".Turbo brush operates with machines suction & Power one operates with small electric motor which is built in the unit.They work with the same prenciple.There is a belt drives the rotary brush.OK.there are two small yellow screw underneath the unit.Please undo them,take of the cover & clean the rotary brush,check for the belts tension.It should be enough tight to drive the brush.If not ask for spare part from Miele in your country.After cleaning please put it back in order.To test it,attached to the vacuum.Turn the power on for Turbo brush,as long as suction starts,brush should start turning too.For the Power one,there should be power button on the handle to turn it on & off.Press it.It should work.On both of the unit,brush should spin good & strong enough to do the job when it's attached the surface you are vacuuming.Check the brush after each use,cleaned if neccesary. I hope that helps.Thanks.

Aug 01, 2010 | Miele s558 Silver Moon Vacuum

1 Answer

Vacuum is whistling and there is no suction through the hose.


Sometimes mine "wand" has no suction too. . . Make sure the vacumn column is clicked into the "standing" position, don't have it at an angle. Also you may have to play with the settings on the bottom part AND the power button together. I think this vacumn sucks (pardon the pun) mine turns off after 10 minutes of use, then I let it sit for an hour and then it'll start again. POS!

Apr 22, 2009 | Fantom Vacums XT450K Upright Vacuum

1 Answer

No suction or very little


Make sure you have a good bag installed in the vacuum and the door is properly in place. Remove the attachment hose from the bag chamber and turn the machine on. You should have good suction coming from the hose inlet. If you don't you have a problem in the bag chamber. Bad bag, door is not on correct, door is defective, dirty secondary filter.

Connect the hose back to the machine and pull the other end out from the bottom, and turn the machine on. You should have good suction there. If you don't you have a clog or hole in the attachment hose and it needs to be unclogged or relplaced.

Reconnect the to the bottom. Flip the mahine upside down. Take the screws out of the bottom plate and remove. Remove the brushroller and belt. Turn the machine on and you should have suction at the inlet coming off the brushhousing. It you don't, then you have a clog in the nozzle hose and it needs to be removed. It will probably be more accessable from the bottom side since that is the way that it entered.

Sometimes a suction problem can be confused with an brush problem. The belts on that machine should be replaced every 6 to 8 months because they will strentch and wear. This is an inexpensive maitainance that will dramatically improve its function. Part Numbers are 38528-035 and 38528-034

Nov 21, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

No wand suction


  1. i cleaned out my fanton and no suction in wand and still whistles

Aug 17, 2008 | Fantom Vacums XT450K Upright Vacuum

9 Answers

Hoover Agility, No Suction!!!


I had the same problem. Lower the handle to the floor and check the black spiral suction hose at the neck of the machine. The lower hose in my Hoover split. Check and see if yours has done the same thing. If so, the lower suction hose will have to be replaced. Hope this helps.

Oct 04, 2007 | Hoover F6212-900 / F6215-900 SteamVac...

Not finding what you are looking for?
Kenmore Progressive Upright Vacuum with InteliClean System Slate Blue Logo

Related Topics:

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...