Question about Balboa Instruments Duplex Digital Panel 2 Pump

1 Answer

I have a Balboa R574 control and heater on a Jacuzzi Spa. The motor starts and runs fine on low speed, but trips the exterior GFI after about three minutes running on high pump. The pump and motor were replaced this season. The heater and pressure switch are brand new. The red wire going to the J terminal looks like it over heated and is scorched. The fuse does not blow. What else should we look at? Thanks, Susan

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 46 Answers

Understand that this information isbeing provided as-is and without warranty or guarantee. As with allelectrical components and devices, all work should be performed by a licensedspa or pool technician. Serious injury or death can occur if a component isimproperly repaired or installed. This islikely an issue with the GFCI breaker not being able to handle the load or aproblem with the high speed of the pump.

You can find answers to common spa orbath problems online at http://www.balboadirect.com/support.aspx Hope that helps!

Posted on Sep 12, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Jacuzzi spa with a Balboa R576 (522205) control box. The control panel constantly shows "OH" (overheating) even when the water temp is 50-100 degrees F. When I reset the system by flipping the...


Hi,

There are some things to check.
Make sure the vents on your cabinet are not obstructed.
Make sure your filter cycle is not too long
Make sure you are not running high speed for more then 30 mins.

Have you looked through the Balboa error message site. I have attached a link follow your error through and you may find your answer. Diagnostic Messages

Mar 02, 2015 | Balboa BB58048 Jacuzzi R574 R576, 4.0KW,...

1 Answer

Leisurebay spa with Balboa controls.Just wired it up 240v.as soon as i flip the breaker it trips.disconnected wires from pump relay and connected them together,now the breaker stays and the pumps will


make sure the spas control panel is set for 230v next check the GFIC it might be faulty. AS A TEST ONLY you can bypass the gfi af all works, try another GFI. but this doesn't rule out.. shorted motor,heater or even a light ..
give me a vote if'n I was of help.I love praise, it's the fuel that keeps me fix'n yer stuff.. Jay

Nov 12, 2014 | Pool & Spa

1 Answer

No temperature display cant set temperature


Located behind the access panel there is a grey box that is the spa pack. Open that up with the 2 screws on the top of the pack. There is a small glass fuse on the circuit board. One of those fuses is most likely blown. If that is not the culprit you need a new topside control. More than likely it's the fuse.

Mar 04, 2013 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

Balboa hot tub m7 wont power on at all


Either the spa is incorrectly wired or one of the fuses is blown in the spa pack. Typically this is due to your electrician wiring the spa incorrectly and blowing the fuse on accident.

Aug 06, 2012 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

Hot tub keeps running all night keeping me awake. How do you shut it off? It's a Great Lakes.


If the system is the Jacuzzi 52221-05 system mentioned in the subject header, there could be a stuck relay causing the problem and you might need to get a spa technician out to assist you in repairing the problem. However...

If it is a Great Lakes system as mentioned in your message body, then there could be a programming issue allowing the filter cycle to run continuously. Provide a model number off of the Balboa control. Then we can provide you an instruction manual or reference card to assist you in resolving this problem. you can also search our online manuals at our website. You can find them online at:

BALBOA WATER GROUP INSTRUCTION MANUALS

Sep 18, 2011 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

Colman Spa trips GFI what is most common problem? GFI test good. Pump disconnected still trips, is heater most likely? Can you replace only heater? thanks


this should be simple ...
1.shut off the power
2.disconnect wires to heating element
3. turn power back on and see if it works if so replace heating element 45-95 dollars

if it still trips unplug all the cables from the pumps blower ozonators and see if it runs now,,,, if so plug each cable back (one at a time) until it trips again.if it trips that the problem pump etc.

99 percent of the the time its not the gfi its a device that is wet or shorted out ..Try everything else before replacing the gfi

Dec 31, 2010 | Balboa Instruments BALBOA 30kW HEATER ASSY...

1 Answer

Our hot tub screen is not on is there a reset button? the jets are still turning on but there is no way to adjust the temperature control


No there is no reset button for the keypad display. The only way to reset it to switch off the power for a short while and then turn it on again.

Your fault will either be with the keypad connection on the PCB within the spa pack. Or more likely a problem with either the PCB or keypad.

Your best option is to get a spa tech/engineer out to investigate the problem.

Regards,
Ian Kime.
http://hottub.synthasite.com

Dec 05, 2009 | Jacuzzi Balboa R574 System for 1 2 Speed...

2 Answers

When i turn jacuzzi on it primes and one of the pumps/jets turns on, then when i try to turn the other jet/pump on it makes a funny sound and blows a fuse i checked to see if any air is in the line but...


This is probally a bad motor, the sound you hear is the motor trying to start but when it can't the breaker trips. If it takes a start capacitor it may be this rather than a motor but you will have to pull the motor to see. It may also be a clog in the pump but the motor sounds like the problem.

Sep 29, 2009 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

WHAT IS THE MODE BUTTON FOR?


EC stands for Economy. Change the mode until you reach ST and then it will stop flashing and function as normal.

Economy mode only allows the heater to function when the hot tub is on its filtration cycle.

Regards,
Ian.
http://hottub.synthasite.com

Jan 04, 2009 | Jacuzzi Balboa R574 System for 1 2 Speed...

Not finding what you are looking for?
Balboa Instruments Duplex Digital Panel 2 Pump Logo

305 people viewed this question

Ask a Question

Usually answered in minutes!

Top Balboa Instruments Garden Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Paul Stonecypher
Paul Stonecypher

Level 1 Expert

28 Answers

Mister Danger

Level 3 Expert

5631 Answers

Are you a Balboa Instruments Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...