Question about Hoover Vacuums

1 Answer

My Hoover nanolite bagless vacuum has no suction.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

12/14/2013 ... just fixed my loss of suction on my Nano Lite by making sure the hose was in the locked position (top of unit where hose does not come off for attachments, look for locked and unlocked symbols - make sure in locked position.

Posted on Dec 14, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: bad suction on bissell powerforce bagless vacuum

I took the bottom apart and it needed a new belt and that was the problem so it's fixed.

Posted on Jan 17, 2009

juststinks
  • 98 Answers

SOURCE: Hoover Bagless WindTunnel vacuum cleaner.

very easy. you have clog. take the brush off look where the hole is thats where the clog is. it might be in there you might have to take the housing off of the motor

Posted on May 08, 2009

  • 199 Answers

SOURCE: My hoover U5720950 windtunnel bagless vacuum loses

when you lower the handel it is pinching the vaccume line constricting suction

Posted on Jun 11, 2009

  • 7 Answers

SOURCE: hoover wind tunnel 2 bagless vacuum not working

Place handle in low position and turn cleaner over so bottom side is up.
Remove the 4 screws in bottom plate and lift off.
Look on the left side of the agitator brush. You should see the belt there. Remove agitator brush roll and used belt.
Discard belt.
With lettering on outside of belt, slide new belt over motor pulley.
Insert agitator though belt and place belt in belt guide on agitator.
Grasp agitator firmly and fit it onto position by first sliding end opposite the belt into the rectangular slot on side of cleaner.Pull other side of agitator into place
Turn agitator making sure belt is not pinched between agitator and agitator shield.
If this does not take care of your problem, then check your filters for dirt and your entire vacuum for blockages. Both filters do come out. If you can't get a new filter right away you can gently clean the paper filter and remove a lot of dirt. (I recommend outside)! The other filter is washable.
Make sure it is well dried before replacing.
Good luck.

Posted on Aug 06, 2009

  • 18 Answers

SOURCE: Problems with Dyson DC14 Animal Bagless Vacuum

Two possible solutions come to mind. First off, there is a clog in your hose. If you have another vacuum, try using the hose on that one to **** it out.
If that doesn't work, you may need to have the clutch replaced. Check your warranty. The clog wont be covered, but the clutch will be,

Posted on Oct 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Attachment of vacuum base to handle


yes friction and the air suction presure keep the head and the handle together.

Jul 25, 2008 | Hoover S2220 Flair Bagless Upright Vacuum

1 Answer

My Hoover Bagless Windtunnel vacuum has no suction on the bottom, although the hose works. Everything else seems to be working properly.


Check the belt, look like we have the same problem, I just unscrew the bottom part where he brush roller is located and found a broken belt
Easy to replace just follow this instrctions
">

Jan 31, 2011 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Suction not working on vaccuum.


Check for a blockage in the hose, or a tear / hole in the hose between the "pleats"

Jun 13, 2010 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hello,We have an Hoover Mach 5 Cyclonic vacuum that has no suction. We have cleaned and checked all hoses, belts & filters. Please help us.


With this model, remove the dust tank, and turn it on, check for suction at the lower intake. If you have suction, install the tank and remove hose, and check for suction there. keep following until youn lose it. Then you problem will be between those 2 areas

Mar 27, 2010 | Hoover U5194-900 Mach5 Multi-Chamber...

1 Answer

Hoover Bagless WindTunnel vacuum cleaner.


very easy. you have clog. take the brush off look where the hole is thats where the clog is. it might be in there you might have to take the housing off of the motor

May 08, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover tc5238 bagless cylinder vacuum cleaner - no suction


You have a clogged hose. Sometimes a Q-tip or something like that gets sucked up and then stuff jams up against it. You can use a long stiff wire with a hook bent in the end to reach the jam and work it loose. Just be very careful not to poke the wire through the hose! Work slowly and get the clog out a bit at a time.

The clogged hose would also account for the red light.

Apr 08, 2009 | Vacuums

1 Answer

No suction


have u checked all of the filters. I know that when not all the filters r clean the machine will turn on but then it will sound louder and still have no suction. Most times there is a filter under dirt container thats sits above motor and if this filter is not clean the motor cannot breath. Thus no suction

Sep 29, 2008 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

No suction on Hoover Wind Tunnel.


Greetings from GoVacuum.com,

First this is a common problem on ALL bagless vacuum cleaners. Usually it takes longer then 1 day however.

Is there no suction in the suction hose, or is it not suctioning from the floor?

Most people buy a bagless vacuum once, then return to a bagged one after their bad experience, you are not alone!

Please give me the model number to your Hoover, (found on the bottom or the back of the vacuum on a foil label).

Thanks,

Chris Jones
GoVacuum.com
1-866-468-2288
chris.jones@govacuum.com

Aug 18, 2008 | Vacuums

1 Answer

Wind tunnel hoover


Do you have suction at the hose end, if you do then it may be clogged at the inlet by the brush roll. Is the filter cartridge clean? If it is clogged and air can't pass thru it, then you will have no or low suction. Might also check the belt to make sure it is turning.

Nov 30, 2007 | Hoover U5753-900 WindTunnel Bagless...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

376 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

Brad Brown

Level 3 Expert

15478 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...