Question about Jacuzzi MAGNUM FORCE POOL PUMP 2 HP 115230V 94027120

Open Question

The pool company sold me a union for my pump. (Both Jacuzzi and seem to be right part for the pump) When I tighten it, it tightens to a point then jumps and it is loose again. If th pump moves in any way it loosens. It leaks when it is tighten to the point before it jumps and loosens. What can I do to fix this? This there a different oring other then the one in the other part of union I can use or a washer?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

daves944
  • 1050 Answers

SOURCE: 1985 Nissan 300zx power steering hard

I'd love to help, but none of my service manuals show your car having variable assist power steering. Even '86 and '87 don't have it. The electrical connection you see at the pump, is a power steering pressure switch. All it does is tell the ecm that the engine is under load at idle when you crank the wheel hard and it bumps the idle up a bit so you don't stall the engine, but that's all it does. If you like, I can send you two wiring diagrams depicting the all underhood electronics, but I think you probably have a bad rack and pinion. Seems like a common problem from the small amount of checking I did.

Posted on Mar 14, 2009

rick_amick
  • 69 Answers

SOURCE: Changing V belts on Nissan Frontier 2002 4cyl

That should be right if it is an idler pulley. On belts that do not have idler pulley you will have to loosen lock bolt on adjuster. Like alternator

Posted on Mar 24, 2009

  • 17 Answers

SOURCE: jacuzzi pump not pumping

I would probably say that the pump is clogged up or frozen. The motor humms until the heat sensor clicks it off. Try taking apart the front of pump and see if it turns and you should see the problem. Parts are available at most pool stores. Pumps are usually cheaper online.

Posted on Jun 25, 2009

  • 17 Answers

SOURCE: Jacuzzi Magnum Force Pump not working

The number one problem is air leaks.......check all connections to see that they are tight, and rubber seals. The intake side would give you trouble with air leaks. If you dont find any leaks then I would pull the pump cover and check the impellor. Pool stores have parts and lots of knowledge.

Posted on Jun 25, 2009

SOURCE: 2005 Nissan Sentra 1.8S, with AC - how to replace belts?

first of all you don't have to loosen the pulley,this will no solve the problem,well you already loosen the adjuster,good,bot thing you have not done i will tell you now,on the power steering pump where the belt pass there is also a bolt that hold it ,you must loosen that also,then after you will see the pump moving on the two position that means you will see the belt loosen on 1 position an d the position it will tight the belt,try that man.............

Posted on Aug 23, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What is the solution for a knob that won't tighten on Hayward Super Pump?


Sounds like it is stripped out. This does happen overtime. You need a new Hand Knob Kit. You can find one here:
http://www.oskopoolnspa.com/Pool-Spa_Uncategorized/Hand_Knob_Kit_1_Knob_1_Swivel_SPX1600PN

Hope this helps.

May 14, 2014 | Hayward Pool & Spa

1 Answer

Water does not fill to top of dome


sounds like clogged impeller clean out and should work also make sure union at intake is tight

Aug 28, 2013 | Jacuzzi Cyget In Ground Pool Pumps

1 Answer

Mounting Nut Ratchet Question


The yellow latch found on the nut on Jacuzzi brand pumps is to prevent the nut from vibrating loose while the pump is operational.

Rod
US Parts Center

Aug 06, 2012 | Jacuzzi Pool & Spa

1 Answer

I have an above ground pool with a jacuzzi pump. (1.5 hp). I just replaced the sand in the sand filter. I also put on a new o-ring on the jacuzzi pump cover. When I turn on the filter, the pump fills up...


I think you have a air leak. A 1.5 hp motor is very strong and should vacuum well. Be careful to not over tighten the top of your pump housing.

Is your impeller in good shape? It may be worth your while to remove the pump motor from the pump. While you have it apart, replace all the seals (there is a kit for this). Inspect the impeller and all parts of the housing - any junk inside? Remove it. After you complete the rebuild, reinstall the motor, fill the pump housing with water, secure the top and start the pump.

Let me know what happens ...

thanks for your interest in FixYa.com

Jul 03, 2011 | Jacuzzi Pool & Spa

1 Answer

I have a jacuzzi magnum force pump I am trying to plumb the pvc into the pump I lost the screw down union what size do I need to buy and where do I buy a union to fit this pump


Go to your local pool supply get a union to match the sise of your pipe ... or ... just glue it together today and add the uniion next time you have to take that part out.

Jun 05, 2010 | Jacuzzi Cyget In Ground Pool Pumps

1 Answer

We do not know where the air filter valves are


Air filter?

Remove the strainer basket cover ... fill with water ... check the gasket ... replace if questionable ... close the cover and SNUG the top down. Start the pump ... it should run just fine.

If you are sucking air, tighten the strainer basket cover a little.

Still sucking air? You will have to find the air leak. You might plug the leak with plumbers putty.

May 29, 2010 | Jacuzzi Cyget In Ground Pool Pumps

1 Answer

After I drained and cleaned my "Jacuzzi 220" I filled it and got a FL2 code and now only half my jets work. Is it as simple to fix as disconnecting the pressure switch and reattaching? Thanks, Richard


You probably need to run water into the skimmer to force air out of the suction line. sounds like one of the pumps is not priming due to air lock. When you drain the spa, get into the habit of running water into the skimmer when you start refilling it.
You can get it to prime by loosening the discharge side pump union until the air is out, then re-tighten. The FL2 code is a "flow" error for the circ pump.

Oct 25, 2009 | Pool & Spa

1 Answer

I have a Jacuzzi pool filter and it leaks like a beer tap when the pool is on from under the nut. We recently (within the past year replaced the nut). Pressure is fine, just lots of water all around the...


when you replace the oring make sure to get some o ring lube and liberally apply it it helps a lot to keep it from kinking or bunching up when being tightened

Jul 10, 2009 | Jacuzzi Cyget In Ground Pool Pumps

Not finding what you are looking for?
Jacuzzi MAGNUM FORCE POOL PUMP  2 HP 115230V  94027120 Logo

Related Topics:

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jacuzzi Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

Mike

Level 3 Expert

4336 Answers

john h

Level 3 Expert

12104 Answers

Are you a Jacuzzi Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...