Question about Audio Players & Recorders

Open Question

No sound out of my crate BT100 bass amp. It gets power. All wires and cables are properly attached. I have yet to check the fuse, but want to know what else it could be. The amp is clearly getting the feed from the guitar, but won't send it out to produce a sound.

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 4234 Answers

SOURCE: my bass guitar amp is blowing fuses

This sounds like the main rectifier diode/bridge is shorted. If you can rpovide the make and model, I may be able to give you more details.

Thanks,
Dan

Posted on Nov 25, 2008

  • 1 Answer

SOURCE: guitar/amplifier 'buzz'

I have two amps .i need to know how to set the knobs on them. to get the best sound out of them .i have a crate and a drive elite.i am a beginner. they are both bass amps. so PLEASE HELP ME

Posted on Dec 27, 2007

SOURCE: Bass amp for guitar?

not sure, i'm in the same boat tho and i'm gonna give it a shot.

Posted on Jun 08, 2008

  • 16 Answers

SOURCE: my bass guitar amp is blowing fuses

Hi ! I have a soluution and it is about to be published on http://www.howtodothings.com/electronics/how-to-fix-your-guitar-amplifier

Please check in a few days time

Posted on Dec 04, 2008

marsrover
  • 682 Answers

SOURCE: Crate BX 160 bass amp. Has intermittent problems and shuts down

check your speakers cables for good condition-no touching between inner wires of each other- after you confirm from good cables condition- try the speakers one by one-make good ventilation around the amp and clean it with air blower-after that if the problem still found contact near service center for help.

Posted on Jan 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Crate bx-100 bass amp powers up but no sound


I recommend to check your speaker with something else before anything else. Sometimes they rattle when the voice coil gets hot and warps but, sometimes the blow out completely and make no sound at all.

Mar 19, 2013 | Music

1 Answer

I have a Kenwood KAC-9104D that will power on but not produce any sound??


Be sure the RCA cables are attached and in good condition.
Be sure the remote wire from the deck is hooked up and good.
Be sure the GAIN control is turned up.
Volume on head unit is up. Make sure BASS options are not turned off on deck.
Be sure wires are going the right way. + to + & - to -
Loose wires in the box. Make sure subs are hooked to the terminals inside box.
Check all fuses on amp to determine if 1 or more i blown.

Feb 18, 2011 | Kenwood KAC-9104D Car Audio Amplifier

1 Answer

I got a ppi d1000/1 amp cant get any sound out of it?


Make sure your remote wire is hooked up in the right spot, also check your rca plugs and consider replacing them, check all fuses to make sure their not blown, a loose or not good ground wire or power supply wire will also cause this problem. If a power wire has a cut in it, that will also cause fuses to blow, as well as with a ground wire cut, ur amp will not be properly grounded.

Sep 26, 2010 | PPI PrecisionPower D1000/1 Subwoofer Mono...

2 Answers

Dean edge bass quits


The wiring in the back is so very thin and the circuit board isn't attached to anything but the wires that are attached to it. I found two weak solder joints there and one in the battery compartment (you'll have to remove it to get to the solder joints). I don't know which repair did the job, but it's working for now, anyway. I'd like to replace the tiny wires but there's not enough room in that compartment. I, also, had to replace the 4 bridge screws with larger diameter SS screws months ago as ALL 4 were stripped. Thread too fine for wood that soft. Come on Dean, step it up a notch! The bass plays and sounds great.

Feb 24, 2010 | Dean Edge 4 Bass Guitar

1 Answer

Crate Bass Amp B100 - No sound.


Do you happen to have another speaker that you could hook up to speaker output? This would bypass the amps internal speaker and lf you get sound from that setup, it would mean either a jack failure or possible internal speaker problems. Please let me know.

Jan 24, 2010 | Crate Music

1 Answer

No sound out of the Amplifier.


hello if you not even heard a low buzz en the speakers with all volume up is probably burned take it to rapier shop for a estimated saludos

Jan 08, 2009 | Audio Players & Recorders

1 Answer

My Crate blue voodo amp head


Hi...

1st off , check the connections from the head output jack to the speaker cab. If you can get hold of a meter , check the continuity on the cable (center wire to center wire , ground wire to ground wire) both should be about 0 ohms.
Do you have another speaker cab you can try>?

You might have a speaker fuse internal on the amp too OR a secondary fuse on one of the power supply lines

Dec 21, 2008 | Audio Players & Recorders

1 Answer

Vrx Bass Tube Built in amplifier


hi there mate, is the sub earthed? sometimes this might be the problem, also check that all the cables are correct in the amp, there should also be a switch on the amp to lower or increase the output, this maybe turned all the way off, the remote lead generaly is usualy the thin blue wire behind the head unit the best way to connect this to your amp remote wire is to simply go to your local halfords etc and get a little wire joining clip. then you can conect them. any other problems please ask

cheers
adam

Nov 07, 2007 | Bazooka MBTA8200 Marine BT Series 200-watt...

1 Answer

PLEASE HELP!!!


The Amp stays on because you have a constant 12V to the Remote.
If your stereo remote is no longer working then run a wire from a 12 volt source that turns on and off with your ignition something like your radio fuse in the vehicle fuse box.
As far as the Bass Knob if it is connected properly and still not working check the line for wire kinks or cuts that may have happened during installation if you cant find any problems you can get a universal bass knob that plugs via your RCA cables for under 20 bucks.
Hope this gives u some ideas.

May 05, 2007 | Pyle PLA2480 Car Audio Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

400 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5047 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...