Question about Arctic Pool & Spa

Open Question

Arctic spa running all the time, the topside buttons won't shut off the air blower and all 3 motors, it seems to be stuck in clean mode.

Posted by on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 5 Answers

SOURCE: I have Jandy RS4 system with 4-button poolside

Pull the cover off the control panel. You will probably find a button which would be accessible from outside the panel with a paper clip or pencil but is unlabeled. On the board itself by the button, in small letters it should say "reset". Push the button and see what happens.

Posted on Oct 09, 2009

  • 368 Answers

SOURCE: Spa won't heat unless in spa mode, and if it is in

On the automated valves there are tiny switches on one end or under the valve actuator. When you switch to the spa mode the suction valve should should move to fully block pool drains. The return valve should fully block the pipes to the pool returns and spa fountain. If one or both of these valves is not fully blocking the pipes to the pool then the tiny switch on that valve is in the wrong position or an operator is defective. The middle position of either of these switches turns the operator completely off so it cannot move. That is the position to avoid unless you want to operate it manually. One of the other switch positions caused the valve to move in one direction and the other switch positions causes the valve to move in the other direction. If you set the switches so when in the spa mode water is circulating only in the spa then you have the valves in the right position. Next, place the system into the pool mode. Both valves should move to the other position. If not then the valve operator that doesn't move has a problem. It could be the operator, the wiring, the control panel or a stuck valve in that order. All of this sounds complicated but once you know how the operators should act when you flip those tiny switches and how the valves should act when in the spa and the pool mode then getting the switches set right is simple. I hope this helps.

Posted on Aug 08, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Something seems to be wrong with my pump in my spa.


A loud, grinding, screaming, or screeching pump motor, will not show up on your Pumps Control Panel, with a fault code. Your bearings in the motor, are shot. And you will need to replace them, or the motor.
2nd possible problem - sorry : (
if nothing is displaying on your topside control panel, then your topside Control Panel appears to be bad, or the fuse that operates it has been blown. If there is a display in the readable part of the panel, but you have no access to make anything work, then you have some dead buttons, and once again you have a bad topside control panel.

Apr 11, 2015 | Intex Pool & Spa

2 Answers

Sparform hot tub blower won't turn off


When an appliance will not turn off, no matter what you press on the control panel, you have either a non responding (dead button) topside control panel, or your topside panel did receive the message to turn it off and the circuit board is not responding.
  • If you have some kind of indicator light when you press your Jet/pump button, if the topside panel is operational and does actually receive your request to either turn on or off an appliance, an indicator will appear - either a light or icon.
    • If one does appear when button pressed, then dis-appears when pressed, that means your panel is good - as it is responding to the pressing of the associated button.
      • Bad circuit board
    • If nothing appears when you press the button, no lights or icons - indication of topside receiving your request, then you you have a dead button.
      • Bad Topside Control Panel

May 18, 2014 | Dream Maker Spas Dream Maker Ez Spa Hot...

1 Answer

Balboa VL700S control panel jets 1 not working


Your problem is going to be in the circuit board in the spa control box under the skirt.
You have a bad relay.
Rod
US Parts Center

Jun 25, 2013 | Pool & Spa

1 Answer

Pool filter pump won't shut off.


I'm assuming it continues to run when you switch the system to "service" mode. You probably have a relay stuck shut. Unless you are very comfortable with working with high voltage it's best to get a tech out to verify the problem and switch out the relay. If you are okay with it the replacement isn't very difficult. You'll have 4 or 6 wires to move from the old relay to the new one, and switch out the small black and red paired wires that go from the relay to the control board. Make certain that your breaker is off while changing it out.

Apr 12, 2013 | Water Pik Aqualink Rs4 Package - Pool and...

1 Answer

Heil furnace blower motor stays on won't shut off at thermostat blows cold air continuously


Do you have t sat fan switch in on position??? If so blower will run continously set it to auto and it will cycle with heat call

Nov 12, 2012 | Heating & Cooling

1 Answer

Rear blower motor won't shut off, runs all the time on high when ventilation system is on


Check rear blower control switch for operation and for fault. You may need a multimeter to check electrical outputs.

Nov 03, 2012 | 2005 Lincoln Navigator

1 Answer

Dreammaker x-400 clicking sound and pump surge


This might be a problem with the topside control. When the spa is clicking, try unplugging the topside control and see whether or not the problem stops. If the jet button is stuck on the topside, the pump will turn on-off-on-off-on-off until the topside is unplugged.

If unplugging the topside worked, replace it.

Apr 11, 2017 | Pool & Spa

1 Answer

Topside control issues


Topside control is in "Locked" mode.
If you accidentally locked your control

Hold temperature UP & DOWN together for 6 seconds.
or
Balboa 7 button controls, both buttons to the left of the display screen & down temperature.
or
One of the buttons might be stuck in the down position

If these do not help let us know your control make and model & we'll see what we can do to find out more for you.

Dec 31, 2011 | Dream Maker Spas Pool & Spa

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

297 people viewed this question

Ask a Question

Usually answered in minutes!

Top Arctic Pool & Spa Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Mike Raino

Level 1 Expert

16 Answers

Bill Jordan

Level 2 Expert

372 Answers

Are you an Arctic Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...