Question about Vacuums

Open Question

Hoover z700 was the best ever but has been progressivly loosing suction. I replaced the 70$ filter. didnt change much

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad
  • 3 Answers

SOURCE: No suction

I had a a low suction problem. Mine was easily fixed. Stand in front of the machine. When you remove the recovery tank there are the notches on the front of the tank that fit down into the machine. In the right hole in which the right notch fits, there should be a black rubber washer on the machine. Mine somehow came off and feel into the machine therefore there was practically no suction as the seal was not airtight. I only discovered this when I took apart the machine and found it floating around. Just something to check.

Posted on Aug 04, 2007

Ad
reddevil6
  • 1673 Answers

SOURCE: Hoover Windtunnel

Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is a filter at the bottom where the dirt cup (and bag) is, check it also.

Posted on Jan 29, 2008

  • 2 Answers

SOURCE: Hoover Windtunnel

Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door manually throught the opening under the light.

Posted on Mar 18, 2008

  • 71 Answers

SOURCE: poor suction (new bag, clean filter, clear hose)

check the impeller on the moter it may be missing a fin or two (question does it make any unusual noise or vibration ?)

Posted on May 02, 2009

  • 294 Answers

SOURCE: No Suction

The water channel hose could be torn. you can check by removing the lower tank and tilting it backwards, it is located in the lower section. could also be the filter cover. it is needed for full suction control.

Posted on Oct 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Top filter keeps clogging up??


Just make sure the rubber gasket is secure at the bottom of the dirt cup if it rides up the dirt will go straight up to the filters

here is the hepa that should be change when it is dirty


Hepa Filter Hoover U5780 WindTunnel Bagless 93002360

Dec 07, 2015 | Hoover U5780900 Bagless Upright Cyclonic...

2 Answers

Vacuum not clogged but has low suction


Check all the pipes, there could be something stuck in them which hasn't come out.
Also check the base of the vacuum if there is something stuck in the base.
Lastly check if there are any leaks in the pipes.
Also check the suction without using the handle, by pulling the pipe in your hand and see if it has more suction.

Apr 28, 2014 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

How often is it necessary to change the filter one on a Filter Queen Majestic?


The best thing to do to both, keep your Majestic suction and air flow strongest, and keep from pulling dirt & dust from being pulled past the filters which can cause damage to the motor, and charcoal filter, replace the filter once a month. If you use it longer than that it will both loose suction and will cause your Medipure or Enviropure "charcoal" filters to wear out prematurely. Mark the change date right on the filter or on your calendar to help keep track.

Dec 20, 2010 | Filter Queen Majestic Canister Vacuum

1 Answer

Bag was not on good, resulted in dust,dirt, dog hair everywhere...have cleaned pretty thoroughly but vacuum does not have any suction. After taking apart did find that the larger wide belt is broke but I...


Greetings from GoVacuum,

There are two things that you should check on this vacuum after running it without a bag inside. The first thing you should check is the filter that is underneath of the vacuum bag. This filter is underneath of a bracket, and the bracket can be removed by pulling straight up on the bracket. The bracket and filter are directly below the vacuum bag inside the vacuum bag housing. If the machine was run without a bag (or the bag fell off) then this filter is most likely going to be extremely clogged. You can simly remove the filter, and run it under hot water until clean. Make sure the filter is 100% completely dry before putting it back in the vacuum and using it. Running the vacuum with a wet filter will destroy your motor.

Now in terms of the belts. Where as the belts don't directly control the suction of the vacuum cleaner, they certainly facilitate the pick up of dirt and debris on the floor. Many people assume that since the vacuum is not picking up from the floor, then the vacuum doesn't have suction. You can test this by pulling out the attachment hose and feeling for suction, is there suction at the end of the hose? If yes, then the reason the vacuum is not picking up on the floor is because of the belts. If you don't have suction at the end of the hose, then you have a clog, some where or a dirty filter.

The belts actually are what spin the brush, and the brush basically sweeps the carpet, and throws the dirt and debris into the suction port, and when the dirt and debris are near the suction port, the suction then takes over and takes it to the bag.

There are two belts on this model, it's best to replace both of these belts at the same time. If you replace just one, then the other belt will wear out quicker. It's always best to replace these two belts in conjunction.

The two belts that are used on this vacuum are:

Hoover Windtunnel V-Belt Part 38528034

Hoover Windtunnel Flat Belt, Hoover Part 38528035

Once you have the belts, and you're ready to replace them, here's a great video that we shot here at Govacuum.com that shows you exactly how to replace these belts, as well as some basic maintenance on your roller brush;





I really hope that my repair solution was helpful to you in fixing your vacuum cleaner. If you have any further questions about this repair, or any repair, feel free to contact me at chris.jones@govacuum.com, or request a clarification here on Fixya.

If you did find this repair solution helpful, please kindly rate this repair helpful by clicking the 4 Thumbs Up Icons in the top right hand corner of this solution.

Thank you very much,

Chris Jones
GoVacuum.com

Mar 19, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

No Suction


The water channel hose could be torn. you can check by removing the lower tank and tilting it backwards, it is located in the lower section. could also be the filter cover. it is needed for full suction control.

Oct 24, 2009 | Hoover Floormate H3000 Upright Wet/Dry...

1 Answer

The hoover keeps switching on and off automatically.


Sounds to me like there is either a loose wiring in the pedal or mains power cord. Check that the plug is secure. Check both filters though - one behind the bag (usually square and slides out) as well as the main exhaust filter at the back between the power on and cord rewind button. I used to own many Telios models but they are known to have cheap shearing cords which can only be replaced by a Hoover repairer. Sometimes the On pedal can be affected as well particularly if it has been stamped on heavily.
Dont forget to rate, ty.

Mar 28, 2009 | Hoover S3330 / S3332 Straight Suction...

1 Answer

Suction


absolutely all the air in a vacuum would pass through the filter and if its clogged badly you could loose all your suction and if the belt is more than a year old then replace it even if it isnt broken ( they stretch out over time )

Sep 17, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover Windtunnel


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is a filter at the bottom where the dirt cup (and bag) is, check it also.

Dec 28, 2007 | Vacuums

1 Answer

Hoover z700 removable basket


On page 11 of your manual it talsk about the pre-filter which I think is the one you are talking about, it isn't to come out, so either is pressed in or glued. But if this is less then 1 year old it is under warranty. If it is then take it in and have it repaired,
http://www.hoover.com/pdfs/manuals/U9145900.pdf

Oct 19, 2007 | Hoover U9145-900 Z Bagless Upright Vacuum

1 Answer

Hoover Windtunnel


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door manually throught the opening under the light.

Oct 15, 2006 | Hoover U6630-900 WindTunnel Bagless...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

64 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...