Question about Sony STR-DE598 Receiver

1 Answer

My reciever keep saying protect and i cant hear nothing

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Sony Master
  • 6,694 Answers

Hi,
First of all remove all the speaker connections from the amplifier. After that power the amplifier and check the protect show or not . if not, then any of the speaker is damaged. If then also it shows protect you have to check the amplifiers hardware.

AV receivers shows protect mode , when there is a hardware fault in side it. Its a warning that some thing is wrong.
Normally AV receivers show this when any of the output amplifier have some problem. there are six amplifiers in this AV receiver. May occur when the output diver transistors of any of the amplifier become shorted. if the output transistor get shorted this will lead to flow of current through the speakers. To prevent this there is a protection circuit for each channels. One combined output of this protection circuit is connected to the system control. when the any of the output amplifier fails, the protection circuit detects it and switch of the speaker and sent data to the system control. when the system control get this data it will give a warning to the customer through display that PROTECT.
You have to check the amplifier.
For that you need digital multimeter,soledring iron screwdrivers etc
Open the amplifier , then power it on. connect the negative terminal of the multimeter any where in the chase( metal body of the amplifer). then connect the positive terminal to all the output transistors emitter pin one by one . the voltage should be bellow 0.5V. If any of the emitter of the transistor shows voltage more than 0.5V., then that amplifier stage is faulty. Remove the transistors and check it. if it is shot then replace with a new one.
after replacing the transistors do not power up the amplifier directly from the main. You have to put a bulb of 60 watts in serial.
You can do this easily remove the mains fuse. put the bulb in a holder. now you have to wire from the holder. connect one of it to the one end of the fuse holder and the other wire to the other end of the fuse holder. Why using a bulb is, if there is any further problem in the amplifier stage on which the transistors replaced, there is a possibility of the new transistor get damage. if we use a bulb in serial with its mains supply ,when any overload in the amplifier occur the bulb will drop the current, by lighting itself.
After connecting the bulb in serious power on the amplifier. watch the bulb. It should light for one or two second and go dim . if so check the display, is there is protect mode is on or not . if not and come back to normal operation ,then remove the power , remove the bulb insert fuse and check
connect the power and check.
If the bulb shows bright light then there is some component also faulty in the same amplifier. after removing the power you have to check again the amplifier stage of which the transistor is replaced, for any other faulty components.
ok

Posted on May 19, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Protect subwoofer showing on power amplifier


Check your owner's manual for a Factory Reset, or Return to Default. Try that first. If it still doesn't work, try disconnecting the sub completely, and see it that resolves the issue.

Feb 03, 2014 | Sony MUTEKI HTDDW1600 Theater System

1 Answer

Rx-v795a reciever shuts off after 5 min or more can not hear fan in reciever for cooling.


This is a common question on this site. Amps of all types have protection circuits to keep them from doing a self meltdown. Testing follows this logic. 1. Remove all speaker wires. 2. Keep the volume down - all the way. 3. Turn the unit on. 4. If it does not trip off, then there is a problem either in a speaker or the wiring. a. Reconnect one at a time until/unless it trips off b. That will tell you where to look further.
If it does trip off, then there is an internal circuit issue in the amp and probably requires professional help to fix.

Nov 15, 2010 | Yamaha RX-V795 Receiver

1 Answer

My GPS keeps saying cant unlock maps after i already loaded maps on it


The Garmin Maps require a map unlock code in order for the GPS to be able to open/access it. Since the maps are copyright protected by Garmin you should of recieved the unlock code from Garmin when you purchased the new map update.

Mar 07, 2010 | Garmin GPS

1 Answer

My stereo keeps saying ''protect''. how can i fix it? ive tried to unplug it for 4 hours and it still dont work


Check the speaker wire connections and make sure that none of them are crossed. Shorted wires will cause the reciever to turn on the protect mode to keep the amplifier from shorting out. Try disconnecting the speaker wires from the reciever. if you turn it on and it still says "protect" then the short is possibly in the reciever itself.

Nov 08, 2009 | Cars & Trucks

1 Answer

Sony DE-445 reciever flashes PROTECT


Sounds like a grounding problem. If the ground plug isn't missing or loose try plugging it into a different outlet.

Jun 13, 2009 | Sony STR-DE445 Receiver

1 Answer

I have a new pr097 scanner and programed it fine but i get nothing recieved not even weather channel thay scan all fine but it dont stop on anything i cant figure it out also on my old scanner when you...


im just going to radio shack and return it for the only other one they have in stock which only goes to 512mhz whics stinks but at least i will recieve something wwhich is better than nothing

Dec 27, 2008 | Radio Shack Pro-97 Handheld Scanner

1 Answer

Lavasoft adaware problem


Hi,

Are all you icons at the desktop also gone and are now links but will not open?

If yes pls post back that we can provide you with the solution.

Kind regards.

Feb 13, 2008 | Computers & Internet

1 Answer

Cell phone self-echo


Hmm, I'm not sure... If you can I'd try to go to California and see if you still get the echoes. For me, heading back to the place where I said I would be using my phone more frequently stopped the echoes. Or you might just want to get a Ohio cellphone number... Like I said, I'm not too sure... well Good Luck.

Jan 10, 2008 | LG CHOCOLATE VX8500 Cellular Phone

1 Answer

Stuck in protect mode


Speakers shorted out, blew a fuse. Replace the unit or (cross your fingers and) open up the box and find the blown fuse.

Nov 23, 2007 | Sony STR-DE425 Receiver

1 Answer

"Car Kit"


this model do that when it get wet if that the case there is nothing to do but chage the board, go to the celu store they have jonk to fix these for about $25.00 more or less..good luck

Aug 06, 2006 | LG VX6000

Not finding what you are looking for?
Sony STR-DE598 Receiver Logo

347 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

The Knight
The Knight

Level 3 Expert

73635 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...