Question about Audio Players & Recorders

1 Answer

Peavey 1200 Amplifier

I have a Peavey 1200 amplifier that keeps blowing both main fuses as soon as I plug it in. The cooling fan stays on even though fuses are blown.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Some of the outputs transistors is bad hence causing a bridge in circuit,thats why the fuse is blowing.Check all the outputs transistors on both channels,rectifiers and zena diodes these are the possible causes of circuit bridge when they are faulty.The fan works on AC thats why it is not affected even when the fuse is blown.Please if you have anymore challenge please send me a mail on mikewee4wee@yahoo.com

Posted on Feb 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does the fuse blow Instantly?


Link for the service manual: http://elektrotanya.com/pioneer_vsx-305_405.pdf/download.html On page 50 of the manual (36 of the pdf) it says for the "Sub woofer pre-out jack (Not available on the VSX-305 model) If you want to boost the low frequencies, connect to a subwoofer power amplifier" Your model will not drive a sub-woofer with out another amp. His sub may be a powered sub?

Aug 31, 2014 | Pioneer VSX-305 Receiver

1 Answer

I have a panasonic SA-HE70 amplifier and all it keeps doing is scrolling OVERLOAD.... why??


hi,.

First of all remove all the speaker connections from the amplifier. After that power the amplifier and check that it gose Over load ( protection ) show or not . if not, then any of the speakers or its wiring have some problem. If so the reconnect the speakers one by one and switch ON the amplifer and check.find out on wchi speaker it shows lover load.


if the amplifer shows overload even after removing the speakers then you have to check the amplifiers hardware.

Also added the procedure how to check the amplifier satge. You should have a good knowledge in electronics to do the following. Also need testing instuments.


AV receivers shows protect mode , when there is a hardware fault in side it. Its a warning that some thing is wrong.
Normally AV receivers show this when any of the output amplifier have some problem. there are five amplifiers in this AV receiver. This problem occur when the output diver transistors of any of the amplifier become shorted. if the output transistor get shorted this will lead to flow of current through the speakers. To prevent this there is a protection circuit for each channels. One combined output of this protection circuit is connected to the system control. when the any of the output amplifier fails, the protection circuit detects it and switch of the speaker and sent data to the system control. when the system control get this data it will give a warning to the customer through display that PROTECT.
You have to check the amplifier.

For that you need digital multimeter,soledring iron screwdrivers etc

Open the amplifier , then power it on. connect the negative terminal of the multimeter any where in the chase( metal body of the amplifer). then connect the positive terminal to all the output transistors emitter pin one by one . the voltage should be bellow 0.5V. If any of the emitter of the transistor shows voltage more than 0.5V., then that amplifier stage is faulty. Remove the transistors and check it. if it is shot then replace with a new one.
after replacing the transistors do not power up the amplifier directly from the main. You have to put a bulb of 60 watts in serial.
You can do this easily remove the mains fuse. put the bulb in a holder. now you have to wire from the holder. connect one of it to the one end of the fuse holder and the other wire to the other end of the fuse holder. Why using a bulb is, if there is any further problem in the amplifier stage on which the transistors replaced, there is a possibility of the new transistor get damage. if we use a bulb in serial with its mains supply ,when any overload in the amplifier occur the bulb will drop the current, by lighting itself.
After connecting the bulb in serious power on the amplifier. watch the bulb. It should light for one or two second and go dim . if so check the display, is there is protect mode is on or not . if not and come back to normal operation ,then remove the power , remove the bulb insert fuse and check
connect the power and check.
If the bulb shows bright light then there is some component also faulty in the same amplifier. after removing the power you have to check again the amplifier stage of which the transistor is replaced, for any other faulty components

OK

Sep 19, 2011 | Panasonic SA-HE70 Receiver

1 Answer

My reciever keep saying protect and i cant hear nothing


hi,
First of all remove all the speaker connections from the amplifier. After that power the amplifier and check the protect show or not . if not, then any of the speaker is damaged. If then also it shows protect you have to check the amplifiers hardware.

AV receivers shows protect mode , when there is a hardware fault in side it. Its a warning that some thing is wrong.
Normally AV receivers show this when any of the output amplifier have some problem. there are six amplifiers in this AV receiver. May occur when the output diver transistors of any of the amplifier become shorted. if the output transistor get shorted this will lead to flow of current through the speakers. To prevent this there is a protection circuit for each channels. One combined output of this protection circuit is connected to the system control. when the any of the output amplifier fails, the protection circuit detects it and switch of the speaker and sent data to the system control. when the system control get this data it will give a warning to the customer through display that PROTECT.
You have to check the amplifier.
For that you need digital multimeter,soledring iron screwdrivers etc
Open the amplifier , then power it on. connect the negative terminal of the multimeter any where in the chase( metal body of the amplifer). then connect the positive terminal to all the output transistors emitter pin one by one . the voltage should be bellow 0.5V. If any of the emitter of the transistor shows voltage more than 0.5V., then that amplifier stage is faulty. Remove the transistors and check it. if it is shot then replace with a new one.
after replacing the transistors do not power up the amplifier directly from the main. You have to put a bulb of 60 watts in serial.
You can do this easily remove the mains fuse. put the bulb in a holder. now you have to wire from the holder. connect one of it to the one end of the fuse holder and the other wire to the other end of the fuse holder. Why using a bulb is, if there is any further problem in the amplifier stage on which the transistors replaced, there is a possibility of the new transistor get damage. if we use a bulb in serial with its mains supply ,when any overload in the amplifier occur the bulb will drop the current, by lighting itself.
After connecting the bulb in serious power on the amplifier. watch the bulb. It should light for one or two second and go dim . if so check the display, is there is protect mode is on or not . if not and come back to normal operation ,then remove the power , remove the bulb insert fuse and check
connect the power and check.
If the bulb shows bright light then there is some component also faulty in the same amplifier. after removing the power you have to check again the amplifier stage of which the transistor is replaced, for any other faulty components.
ok

May 19, 2011 | Sony STR-DE598 Receiver

2 Answers

I have a "peavey ultra 410" guitar amplifier. it has been sitting in the garage for several years, and there is no power when plugged in. The amplifier is all tube (preamp and amp). My question is this; if...


Even though I don't have a schematic, if you have a VOM, (Volt-Ohm, Milli-Ammeter) we can start. Just because tubes are old doesn't mean they are used up. If a tube doesn't light up that would be a bad one, but they are in parallel off a winding of the power transformer. 1.) Check the on/off switch with the ohmmeter and the line cord for conductivity. 2.) Check the primary winding of the transformer for a low ohms reading. (less than ten ohms). 3.) Some where between the power switch and the pwr. trans. should be a fuse. After these three you should be able to put 120vac. to the unit and bring it back on. Get back with us, Dale

Aug 04, 2009 | Audio Players & Recorders

1 Answer

No right channel output after fuse blow out


Sounds like the power transistor(s) on that channel burned out. Needs service.

May 04, 2009 | Audio Players & Recorders

2 Answers

Su-g91


Have you checked the fuse in the unit?

Aug 31, 2008 | Technics SA-AX540 Receiver

1 Answer

Samsung 5-Disc 1200-Watt Home Theater Surround Sound System My Home Theatre System is keeps shutting down by its self. before it shuts down the screen says protection mode and then shuts down. i have...


If the unit shuts down almost immediately without sound, you have an electronic failure of the audio amplifier.

However if you must play the unit up above quiet background levels, you likely have a shorted speaker wire. With home theater systems, you have the luxury of trying different surround modes and speaker level settings. It's not unusual, for example, to have a loose wire strand going to the center speaker. In stereo, the system works fine. As soon as you switch to a surround mode, the amplifier senses the short and shuts down to protect itself.

Check those wires really close - I bet you'll find it there.

May 15, 2008 | Audio Players & Recorders

2 Answers

A HUMMING Peavey Classic 30


I repaired a classic 50 recently and the problem was a bad solder connection on the main input jack. You may also want to have the tubes tested.

If the unit is over 20+ years have it recapped.

I do this stuff but Vermont might be to far.

Scott

Mar 17, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

669 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

98608 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69570 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...