Question about Sony STR-DE595 5-Channel Amplifier

1 Answer

Sony STR-DE595 Sound not balanced

The right front channel is barely audible. I have to turn the balance all the way to the right to get any significant sound out of the right front speaker. Even then, the left channel is still much louder. (btw - the speaker is NOT the problem. All connections are secure and I have checked with other speakers, as well as headphones and still have the same issue). This happens whether it is in Stereo mode or if there is a digital signal (DD, DTS). I also tried changing the speakers from connection A to B, but the problem persists. I have done both of the resets mentioned in the manual, with no change.

Posted by on

  • soonerjohn Mar 27, 2009

    I got a new, better model on craigslist for half the cost of service on the old one and put the old one out on the curb

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 85 Answers

Preamplifier or power amp internally but check your signal cables for shorts or breaks,if amp then is internal and needs to be serviced

Posted on Jan 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I can't get sound out of my amplifier and I haven't changed anything. What could be the problem?


Start by choosing FM on a known frequency with a station broadcasting and volume is turned down to a NORMAL listening level. Next, make sure speaker selector isn't the wrong position (make sure "SPEAKERS OFF/A/B/A+B is set to A [or B to match the speaker terminal connections]), check to be sure "Mute" function is not activated by pressing the MUTE button on the remote to toggle it between on & off, Make sure headphones are disconnected. Make sure "PROTECT" is not displayed on the front as this indicates a shorted speaker wire - shut off and repair the shorted wire(s).

If you get sound on FM, but have an issue with another external component (CD, DVD, Phono, etc.) check the cables between the component and the input panel on the rear of the STR-DE595.

I hope this helps & good luck!

Sep 13, 2011 | Sony STR-DE595 5-Channel Amplifier

2 Answers

The sound on my sony amplifier sounds too low inside the speaker.


Try getting the suround sound modes off and using straight stereo ,with no delays,or echos,

Jan 12, 2009 | Sony STR-DE595 5-Channel Amplifier

1 Answer

Playing ipod on sony str-de595 receiver


You need a 3.5mm mini jack coupler lead with phono plugs on end plug one end into your headphone output on ipod and phonos into your amp lead must be stereo

Dec 22, 2008 | Sony STR-DE595 5-Channel Amplifier

1 Answer

Composite video


According to its service manual, Component Video (STR-DE595 only, except for
models of area code AEP, UK):
Is it is UK region, it support composite video.
Regards,

Sep 07, 2008 | Sony STR-DE595 5-Channel Amplifier

2 Answers

Sony STR-DE595 Sound not balanced


HI...
It will need tech service.
Check the Sony consumer site for who can do it.

Aug 15, 2008 | Sony STR-DE595 5-Channel Amplifier

2 Answers

Technics SUV500 Amplifier


check volume balance between right and left-then change inter connection between sound source and amplifier with new cabel(i prefer gold plated type connectors)(see radio shack).
after that if the problem excit your fault in output transistors or output stereo ic depend on circuit design.

Feb 17, 2008 | Technics SUV500 2-Channel Amplifier

1 Answer

SONY STR-DE305 FUSES


are these the speaker output fuses...if yes, they should be on back panel. if no, then are you also looking for board mounted fuses on the pc board?

Jun 01, 2007 | Sony STR-DE595 5-Channel Amplifier

1 Answer

Surround Sound


You must find on your setup menu the word `Surround', it may be `5.1 Surround'. Not `Stereo'(S ?).

Oct 22, 2006 | Sony STR-DE595 5-Channel Amplifier

1 Answer

Sony amplifier/vcr problem


The Dog must have not liked the program? No what you need to do first is check the things that you overlooked as obvious? Such as mute switch, Balance control, Not in the right mode, speakers turned off, Audio cables pulled out of the unit. In tape monitor mode. Thats the most common thing if you have no sound after a bump from the rump of a dog,person playfull partner. Good Luck

Jun 17, 2006 | Sony STR-DE595 5-Channel Amplifier

Not finding what you are looking for?
Sony STR-DE595 5-Channel Amplifier Logo

Related Topics:

216 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4576 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68157 Answers

Are you a Sony Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...