Question about Car Audio & Video

1 Answer

Power Acoustik 1600 trouble

I hooked up my amp today and was stupid enough to turn the key and check to make sure everything was on and the + and - on the speaker wire for the left out were touching and popped now that side wont put out any power ? Is there an internal fuse that i blew or something ? Thanks
[email protected] is my email

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

All fuses would be external. Check all of them.

If all of the fuses are OK, you probably blew the power supply for that channel (and possibly the output transistors). You'd need an ohm meter to check them.

Let me know if you have any other questions.

Posted on Aug 16, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...
Car Audio & Video Logo

Related Topics:

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Marvin
Marvin

Level 3 Expert

85178 Answers

The Knight
The Knight

Level 3 Expert

76140 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...