Question about Jensen Car Speakers & Subwoofers

1 Answer

Jenson touch screen head unit is all hooked up properly in a 2001 honda civic if i turn it up to around 25 with loud off and bass down it will shut off for a few seconds and then turn back on and repeat till i turn it down if loud and bass are turned up it will do this at lower volumes i know i have some sort of power issue any help will be greatly appreciated

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 53 Answers

The onboard amp in the deck can't keep up and overheats inturn shutting off the speakers , this is common in jensen touchscreens esp the 9412 9512 and the uv 8 best thing to do is buy a 4 channel amp and the problem will be solved sometimes running a bigger constant power wire to the deck will help a little but not much better off buying a 4 ch amp

Posted on Aug 12, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can I hook two 12in. Subs up with a 1100w amp. Sony explode, pioneer subs


Yes....hook one up to the left channel and one up to the right.....once everything is wired up.....keep gain down on amp and turn stereo on.....turn up stereo with amp gain down to right before high end speakers start to distort......then while its playing, turn amp gain up about 1/2 way. close your trunk and hop in drivers seat....sound gd????? You might have to adjust level on amp and bass on head unit to taste.....Be careful though....pioneer subs are only rated around 300 watts continuous.....dont want to blow them...gd luck....

Mar 20, 2012 | Pioneer Car Speakers & Subwoofers

2 Answers

I have brought these speakers, when i turn the headunit up above about 3 quaters of the way they distort, they are running off a 4 channel 4ohm amp with 400watt rms but they do it with the gain on the amp...


If you run the power amp at a very low setting it makes the amp subject to noise and distortion. You want around a 60% setting.

Speakers also need to have proper loading, that is in a cabinet or enclosure that is kind of matched to them. If the amp is rated at a true 400 Watts RMS then the speakers should be at least 800 Watts as they "cheat" on those SPEAKER ratings and MANY A SPEAKER IS BLOWN AS A RESULT.

Mar 21, 2011 | Cdt Audio HD-53ST Car Component System

1 Answer

I've connected a powered sub (bazooka BTA10250D) to my factory system (09 altima coupe 2.5s). I want to be able to control bass on the component speakers and the subwoofer separately. There is no sub out...


We used to use what we call bass blocker capacitors on the component speakers to block the bass coming from the head unit and to allow the bass to only come from the subs...there is several values of these capacitors that you can use(different values correlate to different frequencies). These type of capacitors are available at Radio Shack. You will need to request a NON-POLARIZED Electrolytic capacitor at a voltage rating of not less than 25 Volts...As for the value of the microfarad rating..you may need to experiment with different microfarad values to get the sound you desire...standard microfarad values are 1uF, 2.2uF, 3.3uF, 4.7uF, 10uF, 22 uF, 33uF, 47uF.
You probably won't need to go any higher on the value than those listed....in my experience, I have found the 4.7uF and 10uF to be good for most speakers...to install these...you need to put one inline with the positive lead to each component speaker.

Jan 14, 2011 | Bazooka BTA10250D Car Subwoofer

1 Answer

Cant get the bass i want.


Try checking the specs on the amp. It might not be able to drive a 2ohm load. just a suggestion.

Mar 31, 2010 | Kicker Solo-Baric L7 S15L72 Car Subwoofer

2 Answers

Car subwoofer makes deep bass when i hit the gas.


there could be 2 reasons why, first make sure your power and remote wire is ran down one side of the car, second make sure the rca jacks is on the opposite side of your alternator, make sure they are that way, this will work, if noise is still there, then you may need and inline noise suppressor. but you shouldn't

Feb 20, 2010 | Kicker 05C104 Car Subwoofer

1 Answer

I have an Infinty Bass Link hooked up to my 2002 Honda Accord sedan for extended bass response on the standard stereo. I hook it up with premium power cables, etc...according to manual. I then hooked it up...


Hi,

Does the servo led stay on? If so, you might have a fractured solder joint. Inspect the switch control PCB for fractured solder joints and check the Positive and Negative 15v outputs on the same board.

Jan 14, 2010 | Infinity BASSLINK Car Subwoofer

1 Answer

Bass sounds muggy it rattles alot when volume is turned up. It just started to happen. What is happening? The bass from the head unit is at -8 while the subwoofer level is a +15.


Have you had it checked out, if it rattles when bass hits hard, it could be busted, have you had it up extremely loud before? If so, that is probably what done it, otherwise, I would call whoever you bought it from, and ask them if they know anyone who has had similar problems to yours.

Sep 03, 2009 | Eclipse SW8102.4 Car Subwoofer

1 Answer

What duz level adjustment do


Hello,

The level control controls the input level coming from your head unit (receiver) to the amp.

Your Sony users manual is a little vague on how to best adjust the level and other controls.

Here is one method that some installers use and works well with most amps.

Most 10" subs sound best between about 80-100hz and below, so start out by setting the LPF at about 80hz. The HPF will not be used. Next turn the bass boost and gain all the way down. Turn on the radio and set all tone controls, bass, midrange, treble to flat, usually "0" on most head units. Turn the volume up to approximately 3/4 volume level or just until you begin to hear distortion. Now, back the volume down until the distortion is gone. Next turn up the gain control on the amp until you hear the subs start to distort then back the gain down until the distortion disappears. Next turn the bass boost up again until the subs begin to distort, then either back the bass boost down or back the gain down until the distortion is gone. You may need to play around with the bass boost and gain controls to get exactly the sound you prefer.

Hope this helps.

Mar 28, 2009 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

1 Answer

I have an Alpine CDA-9815 head unit installed in a 2002 Dodge Dakota. I currently have a 12" DVC sub bridged at 4 Ohms. My head unit's volume goes up to 35. When i turn in past 24-25, the head unit...


It sounds like the sub woofer amplifier is pulling down the voltage level in the truck when it starts to get really loud. It may be the voltage regulator which is probably part of the alternator, or the alternator is not capable of supplying the needed current for the amplifier. If the voltage level drops below a certain level, the radio will see it as if the battery is disconnected. It requires a voltage level of around at least 10 volts to stay turned on. When an amplifier is playing loud, it draws a lot of current. If the current supply does not increase, it lowers the voltage level to compensate and get the current it needs to play at the level the head unit is pushing it to. As the voltage level goes down, the current increases when the voltage is dropping due to increased demand. You could check this with a voltage meter and monitor the level right at the battery and have somebody turn the volume up on the head unit slowly as you monitor the voltage level. The normal operating voltage of a car while the engine is running is about 14.4 volts. It should not drop much at all, no matter how loud the amplifier is playing. if it does drop, you have a problem with the trucks regulator or alternator.

I hope this helps, if you need more assistance let me know.

Dave

Jul 08, 2008 | Alpine Car Speakers & Subwoofers

1 Answer

12 w 3 v3 2 cut off


Again as I have stated in my other answer to you. You can not wire two SVC 2 ohm subs to acheive a 2 ohm load. more than likely you are running your amp at 1 ohm mono and this is why it is clipping and shutting off.

Jun 19, 2008 | Jl Audio 12W3 Car Subwoofer

Not finding what you are looking for?
Car Speakers & Subwoofers Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jensen Car Speakers & Subwoofers Experts

Iron
Iron

Level 3 Expert

3018 Answers

Sudeep Chatterjee
Sudeep Chatterjee

Level 3 Expert

3267 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Are you a Jensen Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...