Question about Olympus EVOLT E-300 Digital Camera

1 Answer

Olympus E300 Hi, I´ve just arrived in nicaragua without my manual. My camera won´t let me take a picture on any setting, on the right corner of the viewfinder there is a flashing dot underneath which says white balance. Is this normal? Would hate to be without a working camera for the next 6 weeks of my holiday. Thanks, Kate

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 103 Answers

Hello Kate, See if you can find an internet cafe. I was reading the white balance section of your manual and there is nothing that stops your camera from taking pictures if the white balance is off. Turn your camera off, remove your batteries for about 30 seconds and let it reset to default. Then try inserting the batteries and see if this helps. I wouldn't mind sending you this manual if you can provide an email address. Or a link to go to is: www.olympus.com, then select americas, then select support, then select your camera, then download your manual in PDF format. I wouldn't want your vacation ruined either.

Posted on Jan 06, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

When i take pictures they show with a pink color? i reset the camera to factory settings but still same pink pics advise?


This FE-340 Olympus is a great camera. Lots of features and usually great results
  • Indoor pictures with flash set on auto WB (white balance) should not be a problem
  • Indoor pictures without flash requires setting the WB to match the light source in the room (incandescent, florescent etc) Outdoor pictures WB on auto generally not a problem
For more help Include a photo with the metadata of the photo from the image data file

Dec 02, 2015 | Olympus FE-340 Digital Camera

1 Answer

My Nikon Coolpix s230 flash won't work. It just blinks red in the lower right hand corner. I've tried all the settings and they all won't flash.


If there is a problem with the flash itself or the mainboard connection to the flash it will not charge. If the flash won't charge then it won't go off when you take a picture. The only way to fix the problem is to replace the flash with a good used one and see if that fixes it. If not, then you need to replace the mainboard. Good used parts can usually be found online for cheap; that auction website doesn't pay me to type their name, so I don't, sorry. Hope this helps!

Thomas Drayton
Owner, www.darntoothysam.com
Affordable Digital Camera Repair

Jul 24, 2011 | Nikon COOLPIX S230 Digital Camera

1 Answer

I want to return my Olympus E300 camera to its factory settings as the set up has been changed beyond recognition. How do I go about this?


Here is a PDF link to a manual for your camera if you don't have one.

http://www.google.ca/#hl=en&source=hp&biw=1385&bih=836&q=Olympus+E300+PDF+manual&aq=f&aqi=g-v1&aql=&oq=&fp=cc0ca0f632636127

Here is a diagram showing you much better the answer to your question then me attempting to type it out.

Diagram here
tri3mast_176.jpg
I made that as large as possible and still remain withing FixYa's guidelines, it should be large enough to read if not this was on page 128 of the PDF manual or message me back and I'll see if I can make it bigger.

Jan 17, 2011 | Olympus EVOLT E-300 Digital Camera

1 Answer

How to use infrared remote with olympus digital slr evolt e300


  • Page 72 on the advanced manual - see below - explains how to use remote control
  • Page 74 show full details on using the remote control - setting needed on the camera
Advanced Manual http://www.olympusamerica.com/files/oima_cckb/EVOLT_E-300_Advanced_Manual_EN.pdf
Heres the support site for that camera http://www.olympusamerica.com/cpg_section/cpg_archived_product_details.asp?fl=2&id=1140

Apr 07, 2010 | Olympus EVOLT 7.9-Megapixel Digital SLR...

1 Answer

I have no LCD screen when my E300 is turned on, it stays blank until I take a shot, the LCD screen shows this shot for a couple of seconds and then blanks again.I can't seem to find the problem in the...


Have you tried pressing the 'INFO' button? This little button will toggle between camera info on display/no info on display (when the display isn't in use to display pictures).

Oct 19, 2009 | Olympus EVOLT E-300 (Double Lens Kit)...

1 Answer

When I plug the USB going from my laptop to my Rebel, the camera flashes the word "busy" continuosly and my laptop cannot find the image info.


When I hook my e300 to the computer it won’t show on the desktop. The cameras on but it’s stuck on “one moment please. All 8 of my other digitals from Olympus work fine. What’s going on here? It’s all turned on but it won’t show up. Thank you.
Alsphotography@earthlink.net

Apr 29, 2008 | Digital Cameras

1 Answer

SSWF ON MY E300 WONT GO OFF


Try updating the firmware on your camera to the latest version using the Olympus master software. There have been several revisions since the camera came out.

Apr 21, 2008 | Olympus EVOLT E-300 Digital Camera

2 Answers

The pictures go blank/black


Could be the mirror is sticking - can you hear it go up?

Sep 04, 2007 | Olympus EVOLT E-300 Digital Camera

Not finding what you are looking for?
Olympus EVOLT E-300 Digital Camera Logo

Related Topics:

222 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Digital Cameras Experts

kakima

Level 3 Expert

96576 Answers

Willem.
Willem.

Level 2 Expert

345 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Olympus Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...