Question about Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My kenwood amp wont turn on

I have this kenwood amp hooked up to two boston aoustics g2's and it was slammin but i unhooked it to put clips on the ground and power wires and then i did that and then hooked them back up and it wouldnt turn on when u take the power wire off the light turns on but when u take them both off the light turns on then fades away right away. I checked the ground and thats fine everything has power. i just dont know maby someone knows?????????????

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Vice President:

    An expert whose answer gotĀ voted for 100 times.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

  • Expert
  • 108 Answers

What kind of "Clips" did you put on? They may be causing too much resistance and preventing the amp from getting the current it needs. Double-check with a voltmeter that you are getting at least 12 volts at the amp power connections and make sure your ground lead is as short as possible and connected to solid metal of the vehicle's chassis.

Posted on Aug 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Amp Turns off after 30 seconds of song play.


Check your ground and make sure it is grounded to metal in your car with no paint. Also, make sure you are running 4 gauge power wire. Another possible cause could be that the ohm load is too low on the amp. Also, if your car battery drops below 10v it will send the amp into protection.

Apr 15, 2009 | Kenwood KAC-8103D Car Audio Amplifier

1 Answer

Amp won't turn back on, all fuses fine, all connections good


that sounds like the amp might have a bad ground.

Mar 15, 2009 | Kenwood Car Amplifiers

1 Answer

Kenwood 9102d wont power on


YOu might have burned out the inner fuse. Better yet the source connect...

Nov 06, 2008 | Kenwood KAC-9102D Car Audio Amplifier

2 Answers

System not playing


Sounds like the output transistors on the amp are blown. Were you slammin when it stopped or how did you find out it stopped working. It could be the sub failed then caused the ap to go which is why you get a little something from the JL.

Feb 11, 2008 | Car Amplifiers

3 Answers

Won't Turn On--- Positive, Negative touched


gell...it sounds to me like you may have fried the capacitor...try hooking it up without the capacitor in line,and check to make sure the in line fuse on your power lead is ok( usually in theengine bay) and also that the fuse on the amp is ok too.

Sep 04, 2007 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Kenwood kac7202


Unhook the Speaker leads from the amp and check for resistance between the two on the amp... it should be 0... now reattach the speaker wires to the amp and check the resistance...depending on the load at which the amp is stable it should be more than 1 ohm at the least...2 ohms on most amps. If all that checks out, check your pre amp inputs. Maybe something came loose behind the deck.

Mar 19, 2007 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

Related Topics:

169 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pieter Vleeshouwers

Level 3 Expert

1410 Answers

Are you a Kenwood Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...