Question about Canon Cameras

4 Answers

I have a canon S-3 which was unused for about 8 months. When I put charged batteries in, everything works except no image. Menu item appear in bith the viewfinder and the LCD - but no image - Help

Posted by on

  • fjoest Aug 10, 2008

    Perhaps I was not clear in my problem description - the image does not appear in either the viewfinder nor the LCD. All of the menu info appears in either the viewfinder or LCD as commanded by pressing the DISP button.

×

4 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 6,966 Answers

Hi,

Based on your description, am afraid you have a CCD problem. This is the actual camera eye. In most instances repairs of this nature require the services of a qualified professional. Additionally, price factor has to be considered since the price of a similar if not better/newer model might not be that far of.

Hope this be of initial help/idea. Pls post back how things turned up or should you need additional information.

Good luck and kind regards. Thank you for using FixYa.

Posted on Aug 10, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,472 Answers

Http://www.usa.canon.com/consumer/controller?act=SupportIndexAct
Follow this link for support to find your local authorized service center. If you need any further assistance let me know.
Thanks,
Lee

Posted on Aug 10, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Canon Master
  • 19,396 Answers

If the problem just happened try removing battery and card and putting them back.
If this happens when you are in shoot mode check that the shutter is opening, it is probably a lens problem.
If it happens when you are viewing pictures in memory card, check that memory card is not faulty using a different one.
If this always happens camera control board is faulty.
If the shutter is stuck you can try opening it gently with your fingernails to see if it unlocks.
I all both last cases the camera must be taken to a repair shop, in this case you can check the number at the end of your owner manual to get assistance.

Posted on Aug 10, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,689 Answers

Press the "DISP" twice and it will show you the image on the LCD.

the DISP button is located on the lower right hand part of the LCD.

Posted on Aug 10, 2008

  • marlon john madrid
    marlon john madrid Aug 10, 2008

    have you tried placing new batteries, like litium ion batteries to be exact, also do make sure that the lens cover is removed. if it still did not do, please go to the menu, then on the lowest part you have "Reset All", press that then let the camera reboot, or reinitialize.

  • marlon john madrid
    marlon john madrid Aug 10, 2008

    as per PoolsMan This is a common problem that we ( in the camera repair game ) see a lot . The cause is faulty CCD sensor ( see enclosed pic from a Canon camera ) to see what I mean . Canon will repair this ( or replace the camera if they cannot repair it inside 4 weeks ) free of charge. Why does this happen ? Badly manufactured ( produced in 2002-2004 run ) sensor goes in the camera and starts outputting noise after 1 or 2 years instead of working properly for +- 10 years.



×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

HTC Vivid won't turn on


1.Check the device's battery level for at least two bars of strength.
2.If the battery level is low, charge the battery.
3.If the issue is not resolved, remove the back cover.
4.Remove the battery.
5.Wait 10 seconds.
6.Press and hold the W key.
7.While pressing down the W key, re-insert the battery.
•The device restarts and after approximately 15 seconds, the 'Recovery' screen appears
•Release the power button but *continue holding the home button*, for another 30 seconds.
Step
Thanks

Aug 04, 2012 | HTC Vivid

1 Answer

.HAVEN'T USED 10D FOR A LONG LONG TIME AND


Here are a few things to try:


1. Remove the main battery and the small backup battery (CR2025) from the battery compartment. Charge your main battery and put both batteries back in once your main battery has been charged. Sitting without batteries will give the camera a chance to reset itself.

2. You may have a bad CF card. Try starting your camera without a CF card or use another.

3. Try reloading the firmware (camera's operating system) using this link Canon. http://web.canon.jp/imaging/EOS10D/10D_firmware-e.html
Be careful to follow instructions exactly as restarting the camera in the middle of a firmware update will brick it and you will need to send it back to Canon for repair.

Hope that helps,
Bax

Oct 11, 2011 | Canon EOS 10D 35mm SLR Camera

2 Answers

Canon XSi not powering up


if it has a view finder make sure in the settings that the image is set to show up on the LCD screen also make sure the batteries have a FULL charge which means at least 8 hours of uninterrupted charging before use.

My guess is that with most nice digi cams it is set to not show the image in the LCD viewfinder but rather the actual real time with your eye view finder. look around the menu if you can and see what you can change as far as view finding and if i didn't help please specify the problem a little more and i will be glad to do whatever i can to help.

Jun 01, 2009 | Canon EOS Rebel XSi Digital Camera

1 Answer

No image


Sony is fixing this through Sept. 2008!

http://esupport.sony.com/perl/news-item.pl?news_id=161&mdl=DSCF717

Apr 17, 2008 | Sony Cyber-Shot DSC-F717 Digital Camera

4 Answers

Canon ntsc zr 65 mc


Hey guys...did you know that Canon actually put out a recall on this and will fix it for free if you contact them? They put it out several years ago but just fixed my this past month. (laziness on my part). They literally had it back to me within one week of me first contacting them.

Feb 07, 2008 | Video Cameras

2 Answers

Canon ZR 85 has gone blind. Blank Screen. Will not record; will play back and shows menu items, however.


I had a similar thing happen to me...the video would not come one when I turned it on, but the audio would work, and it would play back tape fine. I happened upon the following solution (though I don't know how long it will last). I charged the camera, and then noticed it worked fine when the charger was plugged in. As soon as I unplugged it, the video would go black. So...I plugged it in, turned it to record, and unplugged it, and it worked! Almost like something got reset. I have no idea how long this will last, or if it means the battery is going...but, give it a try!

Apr 26, 2007 | Canon ZR85 Mini DV Digital Camcorder

4 Answers

Just stopped working!


I don't have a solution -- but I'm having the same problem. I even purchased a new battery. Nothing still.

Apr 04, 2007 | Canon PowerShot S500 IXUS 500 Digital...

1 Answer

Viewfinder Blank but shows information


From your description it would seem that the shutter component in your lens has failed. Although it is a little strange because the two symptoms you describe are not usually seen at the same time. The fuzzy pictures with streaks on them is a result of a shutter that doesn't close properly, the black screen with just the camera system text on it is a symptom of a shutter that is not opening properly. As for what caused the problem - possibly corrosion or contamination. Was the camera exposed to excessive humidity in the time it was unused? The shutter components are extremely delicate and can easily become stuck or sticky. This is what I believe has happened to your camera. It may not have failed completely but it may be sticking open or closed such that it is not performing its intended function. This will require full disassembly by a professional. David Millier Advance Camera Repair

Feb 23, 2007 | Nikon Coolpix 5700 Digital Camera

Not finding what you are looking for?
Cameras Logo

Related Topics:

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Cameras Experts

kakima

Level 3 Expert

102366 Answers

TC CAMERA REPAIR.Com...

Level 2 Expert

165 Answers

old marine
old marine

Level 3 Expert

1814 Answers

Are you a Canon Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...