Question about Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Help me i have to boss 1400 wt speakers and a sony xplod 1000 amp i put in my car like 4 mouths ago and it suoned realy goo 2 weeks ago it stared to ****

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,139 Answers

Please complete your post, without profanity, because the will edit you, and this does not make for a good diagnosis. so what did your amp start to do?

Thank you,

Shuttle83

Posted on Aug 09, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i bridge a 1000 watt amp to two 1200 watt subs


a sony 1000 watt rating is an exagerration. you will blow your 1200 watt speakers far before reaching sonys claim of 1000 watts

Jul 10, 2014 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

I have two sony xplod 12" speakers wich can hold


You only gave us the model of the amp so I will make an assumption that your 12" subs are the Sony XS-GTX120LW. First, they cannot hold 1200 watts a piece. They are meant to be powered with 350 watts RMS. They will hold 1200 watts peak. That means that 1200 watts for a few seconds will be ok. Past that and kiss them goodbye!

Next you indicated that bridged the amp. Since the subs are both 4 ohm single voice coils did you wire them in series or parallel?

It sounds to me like you wired them in parallel resulting in the amp seeing a 2 ohm load. The amp you referenced is only stable when bridged at 4 ohms.

Has the amp begun working again once it cooled down? If not you could have fried the outputs by having the resistance too low.

Dec 21, 2010 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

I have a sony xplod 1652z 1000 watt amp and want to hook up 2 subs and the speakers that are already installed in the truck is that possible?


thats not a good idea because you are running too many speakers off that amp it it could possibly blow a channel or the whole amp. trust me i've done it

Jun 10, 2010 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

My car is a 92 ford falcon when u play bassie music u can only just here it out side the car but when u pop the bot u can realy here it wat can i do to make it louder out side the car


crack the windows and drop the sony bull **** and get your self a nice mono block class d amp 1000 rms should be loud enough btw bild your stereo based on rms power not max power rms is the true power you got so like 2 500 watt rms 12s on a 1000 watt rms amp or just a 1000 watt woofer it will be jsut as loud as the 2 12s

Mar 30, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

2 Answers

I have 1000 watt sony XPLOD amp and i just installed it today. with new monster cable&ground. the green light turns on& thumping goes for a little. i try to raise up just a little bit& after 2...


it isnt getting enough power and its tripping the internal switch on the amp and putting it in safe mode. either your wire isnt a high enough gauge. you might need a capacitor or you need bigger wire.

Jun 13, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Sony Xplod 2-Channel 1000 Watt Amplifier trouble shooting


What's the model number of the amp?

What speakers do you have on the amp?

Are the speakers moving significantly at high volume?

Sep 13, 2008 | Car Amplifiers

1 Answer

What size capacitor do i need?


you dont a cap is like a band aid it helps but not much look for a 600cca to a 1000cca car audio battery like a kinetiks 800

Jan 01, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

3 Answers

1000 watt amp sony xplod


That's not a 1000w amp. It's a 400 watt amp when loaded to it's lowest rated load. If you have one speaker per channel (the only safe load if you have single 4 ohm coil speakers), you're only getting 165 watts/speaker. It's probably distorted because you're driving it to clipping.

Jan 01, 2008 | Car Amplifiers

2 Answers

Sony Xplod 1000 watt car amp quit working.


Almost all after market amps use 12v at very very low amperage to trigger the amp on. A temporary jumper from the battery plus terminal on the amp AFTER the battery and ground wires are attached should cause the amp to turn on. I would check to see if you have attached your speaker load correctly ESPECIALLY if you are bridging. Most of the blown amps that come into my shop are due to incorrect bridging loads from the speakers. Note that a 4ohm load bridged across both outputs of an amp will deliver a 2ohm load to each of the channels. When you parallel wire two 4ohm speakers together and then attached them to a bridged amp you will be putting a 1 (one) ohm load to each channel of the amp. Please don't make this mistake. It will fry your amp in about a month. Hope this helps. Good luck.

Feb 03, 2007 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

1000 watt amp sony xplod


how do you have your system hooked? What speakers do you have? There is a lot more too it then just wattage.

Jan 23, 2007 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

Related Topics:

43 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

yadayada
yadayada

Level 3 Expert

60769 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...