Question about Kenmore 54501 Dehumidifier

Open Question

My Kenmore 580.54501500 dehumidifier wont turn on. Power at plug. I plug it in and it just beeps once. No lights on display or anything. Makes no difference if bucket is in or not. I have tried to replace both circuit boards in it. Still no luck. Need help. Thanks

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
22yooper
  • 828 Answers

SOURCE: Dehumidifier Error?

Your bucket full switch may be defective. If you are capable, bypass it since you are draining to another place other than the bucket.

Posted on May 09, 2008

Ad
  • 1 Answer

SOURCE: Kenmore 580-51650000 dehumidifier

It is more than likely the compressor is not running, only the fan.
It seams that the humidity sensor is flaky on these units. You can,
operate the unit, by opening up the dehumidifier and unplug the sensor from the main board. The unit will cycle on and off and remove the water from the air.....good luck

Posted on Apr 21, 2008

  • 11 Answers

SOURCE: Kenmore 54501

Normal 0 When you push the power button, the blower fan comes on. In a few minutes you should hear a second "click"--that is your compressor starting. Do you hear that second click?

Posted on May 29, 2009

  • 52 Answers

SOURCE: Kenmore Dehumidifier Isn't Running

It sounds like you have power to the unit but a component is failing to start the system get an AC tech to check it.

Posted on Jun 09, 2009

  • 51 Answers

SOURCE: Kenmore 54501 Dehumidifier no water in bucket

may have lost ref charge check name plate for type of ref with 12 and 22 cost of gas cost proh. check tubing in rear should be ice cold to gather condensate if not probably lost gas

Posted on Aug 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does it beep when plugged in?


as there are two control boards in ac units ( split systems) and one in a window unit
it could be the inside board ( they do not suffer power surges to well or vermin infestations at all )
before you waste more money I suggest that you get a technician in to determine the fault and if parts are readily available.

Jun 24, 2015 | LG LW1012ER 10,000 BTU Medium Window Air...

1 Answer

My Kenmore Dehumidifier wont turn on. There is power to it ,all the indicator lights are on, it just wont start. What's wrong?


Check the over fill switch in the tank. If this is stuck it thinks the tank is full and won't come on. After that your compressor may be bad or the starter for the compressor. The Dehumidifier is basically a small air conditioner that condenses moisture in the air then it drains into the tank.

Jul 13, 2011 | Kenmore Dehumidifiers

1 Answer

I have a 580.54501801 dehumidifier and it shows a code of 01 on the display and doesn't do anything after that but beep 2 times. What does that code mean and is it worth sending it to a shop to be...


Its not worth sending it to the shop! Dehumidifiers are made extremely cheap dont waste your money you will regret it later trust me. Sounds like circuit board issue costs almost what a new one runs.

Jun 23, 2011 | Kenmore Dehumidifiers

1 Answer

Makes a loud beep every minute or so. Doesn't seem like basket is filling with water either.


Turn the Master ON/Off Switch to OFF and unplug the unit. Remove the air intake filter and clean it. Allow it to thoroughly dry, before reinstalling it. Once the filter is thoroughly dry, reinstall it, plug the unit back in and turn the Master ON/OFF Switch to ON. Set the humidity level at 35% and allow the unit to run as you normally would. The beating should have stopped, since you cleaned the filter. Be sure to maintain at least 2 feet of clear air space around the dehumidifier.

Hope this helped you to solve the problem. Please let me know. Thanks.

May 24, 2011 | Kenmore 54501 Dehumidifier

1 Answer

The humidifier makes a beep when turned on,


The water tray is probably not installed correctly. Take it out and reinsert it. It has to close a switch when it is in place.Mine at home is really touchy it has to be put in just right to work.

Nov 12, 2009 | Kenmore 54701 Dehumidifier

2 Answers

Kenmore 54701 (70 pt) dehumidifier will not power on.


This unit has had a lot of problems. It has come up in other forums. The fan motor is thermally protected. Could be the printed circuit board is bad. Check out this forum:

http://forum.doityourself.com/humidifiers-dehumidifiers/177549-kenmore-dehumidifier-fan-stopped.html

May 04, 2009 | Kenmore 54701 Dehumidifier

1 Answer

Slight beep but no action/can't get the back off


I had the same problem (minus the cover issue) . To get the cover off, take off all visible screws. Slide a small screwdriver into the space between the back and the side cover. You will see a slight opening where the tabs fit in, you will need to carefully pry the tabs out. However, most likely your problem is with the front panel. You take the front panel off much the same way. 2 screws are concealed by the bucket. I had the same beep no display, thought it was the main pcb, which I ordered and installed. That did not fix it. I cleaned the display pcb, and jiggled the buttons, that seemed to fix it. I think the button to increase the humidity was stuck closed, as I could replicate the problem by holding that button down and then plugging in the dehumidifier. I would start by cleaning or replacing the front panel pcb, which is about $14.

Jul 28, 2008 | Kenmore 54701 Dehumidifier

2 Answers

No lights, won't turn on


I suggest checking the fuse on the circuit board.

Oct 19, 2007 | Kenmore 54701 Dehumidifier

2 Answers

1 yr old and Stopped working


the beep sound means that there are ac voltage in the unit but you gona need a tech there is no removal parts in that board and sound as a bad ic is there..good luck

Aug 05, 2006 | Kenmore 54701 Dehumidifier

Not finding what you are looking for?
Kenmore 54501 Dehumidifier Logo

Related Topics:

209 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Dehumidifiers Experts

Bill Long

Level 3 Expert

587 Answers

Mike Squire

Level 2 Expert

420 Answers

Cindy Wells

Level 3 Expert

5165 Answers

Are you a Kenmore Dehumidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...