Question about Microwave Ovens

Open Question

The Saffron range was in this house of 4 years when we moved in just over a year ago. This is the second time an element on the top has stayed on high and burnt my sauspans. I am furious. I have always had F & P and Panasonic appliances over many years and have always enjoyed them and found them reliable. Is this Saffron cooker a dud? I note by the letters written that many people are having trouble with them. Do you replace it? Thank you for your attention to this matter. Margaret Laurenson

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
MicrowaveSvc
  • 9085 Answers

SOURCE: need replacement bulbs for over-range hood

These are 20W 120V bulbs with what's called the intermediate base. The new Panasonic part number is ANE6030540AP and you can get them at Tritronics at http://www.wehaveparts.com or Vance Baldwin at http://www.vancebaldwin.com You should also be able to get them at local appliance parts stores, Lowe's (or similar) or even a large grocery store. You can also use Sharp part # RLMPT0003YBE0 from either of the above sites.

Posted on Dec 13, 2006

Ad
MicrowaveSvc
  • 9085 Answers

SOURCE: My microwave died

A microwave can be dead for many reasons.

If it goes dead for a while during or after cooking then comes back on, the magnetron is probably overheating and causing the thermostat to open. When it cools, it closes the circuit and allows power through again.

If it's random, it may be a bad connection, usually on the control board or fuse holder.

If it went dead almost immediately after pressing the Start pad, that's usually a shorted high-voltage capacitor.

If it went dead a few seconds after pressing the Start pad, that's usually a failing high-voltage transformer.

If the fuse is good, it may be an open thermostat or thermal cutout on or near the magnetron or on top of the cavity / body of the oven.

At our site, we have critical safety information, info on door switch diagnosis and replacement, and disassembly information.

See our listing here on FixYa: http://tinyurl.com/yzjozk

Posted on Oct 22, 2007

RadarRon
  • 398 Answers

SOURCE: model # NN-T793/T993

My first guess would be to checvk the venealation fan

Posted on Mar 31, 2008

MicrowaveSvc
  • 9085 Answers

SOURCE: burnt hole in microwave

Is the hole actually bigger than it originally was or is it just empty because the rack support got burned up & discarded?

The rack supports / rack holders can be ordered. The part number is WB06X10140 (or WB6X10140) and they're less than $5.00 each. You can find them in stock here.

If you install a new rack support in the hole, then any gap or hole around it can allow grease to accumulate, and that can lead to arcing. But you can seal it safely & easily.

Once the support is installed and everything is squeaky clean and dry, you can apply a small amount of silicone caulk into the gap or hole.

Let it dry it overnight with the door open, then use a razor blade or X-acto knife to gently trim away any excess caulk.

That would be a really good fix.

We're happy to help and we appreciate your thoughtful rating of our answer.

Posted on Jun 08, 2008

  • 1 Answer

SOURCE: I have a nine year old Goldstar over the Range

I'm just a typical homeowner who just replaced one for an MV-1310W.
Here's the info on the bag sticker:

3301W2A017A
Desc: Cover Assembly, Stirrer Fan
Spec: AL 1.3Cu.Ft MV-1350M

Hope it helps...

-Bob.

Posted on Apr 13, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Powers off immediately after starting


My immediate reaction would be to cut your losses and buy a new unit as sooner or later you will run into a part that is no longer available.

Nov 03, 2012 | Whirlpool Microwave Ovens

1 Answer

PLEASE HELP!!!!!! I had a house built 6 years ago and had an over the range microwave installed. The first one that came with the house was a GE. after like 6 months it would run for a few seconds and...


It may be that the exhaust duct is blocked or the filter is dirty.

That can cause the oven to run chronically hot, which damages the microwave.

The whole duct needs to be checked for any blockage.

You will need to remove the oven from the wall.

To remove it from the wall, the installation instructions are very handy, and it's best to have two people since the microwave can be heavy and awkward.

Whirlpool customer service is here and you can also enter your model number on that page to download your owner's manual, installation instructions, etc..

You can find links to helpful exploded view diagrams and order parts here.

I'd recommend that your bookmark this link to your favorites.


We're happy to help you with free advice and we'd appreciate your thoughtful rating of our answer.

Oct 10, 2011 | Whirlpool MH2175XS Microwave Oven

1 Answer

I have a Whirlpool Gold top-mount fridge (GR2SH/GR2SHM). It's about 6 years old. About a year ago the freezer started to have ice build up and water would over flow into the fridge. I defrost the...


The defrost cycle is not working. After a predetermined number of hours of compressor running time, a timer actuates the defrost cycle, which stops the compressor and turns on a heating element to melt the ice. Either the timer or heating element is not working. Also, make sure the melted ice water is actually draining and not re-freezing.

Aug 31, 2017 | Whirlpool Microwave Ovens

1 Answer

I have just moved into a 10 year old house. It has Blanco gas cook top and a Blanco wall oven. My problem is the electric starter for the gas top does not work. and the Oven indicators eg. top element,...


#1 You may have a blown fuse which sets all these issues together

#2 Your sparker may need to be tested, try a voltmeter to it and see what it reads. If voltmeter reads voltage, then it's a simple adjustment of distance to contact. If no voltage, then you'll need to replace sparker.

#3 as far as your indicators, that has to be an internal fuse.

I agree with you for not replacing these appliances, I love to cook with gas

Dec 16, 2010 | Microwave Ovens

1 Answer

Hello I just bought a Kenmore Electric Range and I am now installing it in my kitchen. I am attempting to connect the power to the range. I have a large romex looking wire coming from the house wall....


Are you trying to connect your range to a 3-wire source, using a 4-wire cord? I'm a little confused on your symptoms. Normally you have a 2 HOT leads and a NEUTRAL/GROUND (3-wire) in older homes. In newer homes you have 2 HOT leads, a separate NEUTRAL and a separate GROUND (4-wire).

The following link explains the difference between the two configurations and how they should be correctly wired:

http://www.fixya.com/support/r3575913-installing_a_220_vac_appliance_cord

New construction homes built after the year 2000 REQUIRE the use of a 4-wire plug and are usually readily wired at the receptacle to accommodate. If your existing receptacle already has a 3-wire configuration you do not need to re-wire it, however. The easiest solution would be to purchase a 3-wire power cord that matches the receptacle you have.

Read through the link provided and post back and let me know if you have any questions. I hope this helps you solve your problem.

May 22, 2010 | Microwave Ovens

1 Answer

My refrigerator stopped working and will not come back on. It is a Jenn-Air Side by side purchased 4 years ago.


you might have a defrost problem. Frost free models have a heating element that is controlled by a timer to automatically defrost ice, defrost timer turns on defrost heating element every 12 hours to melt ice in freezer and allow good air flow.
You can test defrost element with an ohm meter(located inside freezer coils-will have two wires going to a plug connection), if OK replace defrost timer (located in various places depending on make and model

Aug 24, 2009 | Microwave Ovens

1 Answer

Grill element stopped working.


I had the same. Dismantle the oven and see at the back side the connection wires for the heat element. Mostly one of the connectors is faulty. I fixed it that way.

Jul 29, 2009 | AEG MCC663 Microwave Oven

1 Answer

Vent motor turns on, but does not draw air in as it should...


the vent tube in back may not have been changed over they can be vented or ventless but you must switch the flap in back you had the answer in your question ... good job,,..lol

Jan 13, 2009 | GE Spacemaker JVM1640SJ Microwave Oven

1 Answer

Whirlpool microwave mh6150xls makes noise while running


The oven may not be seated properly. check the bushes at the bottom.

Apr 07, 2008 | Whirlpool MH6150XMS Microwave Oven

3 Answers

Model # NN-T793/T993


My first guess would be to checvk the venealation fan

Mar 31, 2008 | Panasonic NN-T993SF Microwave Oven

Not finding what you are looking for?
Microwave Ovens Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Microwave Ovens Experts

William Miller
William Miller

Level 3 Expert

9085 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76848 Answers

Are you a Microwave Oven Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...