Question about Televison & Video

1 Answer

I have a acoustic solutions CTVL32W3HD television,It has no picture but sound is working fine It has a red flashing led on the power board, I changed the 2 10uf 450v caps that were bloated , no difference

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 60 Answers

The two caps you changed are the typical solution for this problem. Maybe there's a problem with the inverter board.
Check to see if there are any smd fuses near those two caps that you replaced. Then resolder the transformers on the inverter board. You'll probably find some more smd fuses on the inverter board. Check them and tell us the result.

Posted on Apr 08, 2011

  • 4 more comments 
  • knowlesrobbi Apr 08, 2011

    I didnt see any fuses on the power board, are they class type fuses ?.
    Excuse my ignorance but im unsure where the inverter board is, i know where the control board is.
    Do i need to strip the screen to get to the inverter board?
    Thanks in advance

  • knowlesrobbi Apr 08, 2011

    Ok after finding and replacing a fuse i mistook for a resister, It has blown the fuse next to the power socket , and no power at all

  • blanqui2000 Apr 08, 2011

    The fuses I'm talking about are smd, surface mount devices.
    Some lcd panels have the inverter built in on them, it's not a good idea to repair those ones.
    Can you see the cables that feed the lamps on the screen?

  • knowlesrobbi Apr 08, 2011

    yes a plug with a white cable that goes to the top of the screen, the plug plugs into the power board

  • blanqui2000 Apr 08, 2011

    Check the components near the area on the powerboard where this cable is plugged.
    Transformers, caps and i'm sure there has to be a fuse there.

  • knowlesrobbi Apr 08, 2011

    Ok more testing has found both FQPF9N50CF Transistors next to the caps are shorted
    Has anyone any ideas where i can get them from or equivelant

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No picture or sound with a red flashing power light. Have replaced the convergence IC's but no change (do not have the chirpint sound). Removed main power board & green LED does not light up


On that model the conv IC is usually not the solution. I believe its the blown capacitor problem with is an easy fix. Check the site www.TvRepairKits.com for a repair kit.

Apr 11, 2012 | Hitachi 53UWX10B 53" Rear Projection...

1 Answer

Red power light flashing..no picture


Count the blinks of the led. The number of blinks gives an idea of which board has failed let me know

May 01, 2010 | Panasonic Viera TH-50PX80U Plasma TV

1 Answer

60SDX88B. No video, No sound. DP06 Protection


not a solution but i have a 50gx30b doing something similar, no picture no sound, 3 green leds are lit up on the main board and then one red led lit up also on main board, front panel red led stays on for about 30 -50 seconds and then it all shuts off, I then have to unplug and replug to get the same results.

Mar 03, 2010 | Hitachi 60SDX88B 60" Rear Projection...

1 Answer

Sony bravia KDF-E50A12U rear projecion tv wont turn on


Hi it sounds like it could be an issue with board that powers the lamp ,it's called the ballast.When you put a new lamp in the ballast has to provide more power ,when it starts to go weak it will not light up.Sometimes you can put your old lamp in and will work fine.Try partstore.com they might have it right there.Hvae a blessed one!

Mar 02, 2010 | Televison & Video

1 Answer

Have a Hitachi 53sdx89BA Rear Projection TV. Turn on TV and red power light illuminates. No picture, but have sound. Check PC board in back and red led is flashing and green leds are lit. It was working...


Discharged Flyback Transformer. Removed main pc board from bottom of TV and flipped over, no apparent damaged components or blown board traces were found. Noticed a lot of flux in various areas on the board that seemed unusual (maybe TV was worked on before as I bought a showroom demo at Circuit City). Used a plastic screwdriver to remove all flux between connections on ICs, Transformers, Flyback Transformer, and various other components. Cleaned all debris, dust and crud accumulation (TV is over 10 years old and there was alot around the Flyback Transformer) from both sides of board using a lightweight paint brush.
Used a magnifying glass to check all solder joints for possible cold solders and found none. Did the same for Power Supply Board. Checked various ICs and Power Transistors for opens or shorts (in machine) and they seemed fine. Reinstalled boards, said a few Hail Mary's and fired it up.

The protector Led no longer flashed under power and lo and behold I got picture and sound!

I cleaned the lens on the projectors (again 10 years of dust accumulation) did a magic focus adjustment and it works fine!

After reading other fixes, I fully expected it to die after 10 minutes so I left it on all day and against all odds it still works.

What was the fix......Dirt buildup on and around Flyback and other components,,,,,,Flux conducting electricity between contacts on Flyback and other components.....or oxidation on connectors between Power Supply and Main Board.....I don't know.... all I know is that for the moment I saved around $ 300 - 400 in repair bills by doing it myself.

Feb 01, 2010 | Hitachi 53SDX89B 53" Rear Projection...

1 Answer

Bush lcd tv has sound but no picture when switch on tv screen is blue then goes black and you can hear the proggramme that is on


acoustic solutions lcd tv when i switch it on the screen flashes blue, green then red no picture??? it was working ok last night any ideas?

Jan 23, 2010 | Polaroid FLM-2632 Television

1 Answer

LCD TV, No Power, No Standby LED, Buzzing sound from Power supply


sounds like either way your power board is bad- do you intend on replacing a component? I would look for Puffy caps- you know- leaking from the top-

Aug 19, 2009 | Televison & Video

2 Answers

Acoustic solutions ctvl32w3hd


the sky remote code for acoustic solutions ctvl32w3hd 1239 (its a goodmans code ) works fine on mine

Jul 17, 2008 | Acoustic Research UltimateRemote Remote...

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

659 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74459 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...