Question about NAD T752 Receiver

1 Answer

NAD T752 Hi, When powering up, about 4 second after, the amp turn in protection mode. Nothing is connected to the anp and it is clean from any metal dust. I found one transistor to be very hot. It's one of the ones cooled by a high and slim silver color heat radiator (they are 4 or five of these grouped togheter) Thanks, I can give more details or photo if possible or needed Francois

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 151 Answers

It could be entering protect mode because it has no speakers wired to it, have you tried connecting to all 6 speaker - out connections. Often, if an amp can't detect a load on all 6 channels it won't work. Also, have you checked the thermal fuses? a blown fuse could cause this problem.

Posted on Apr 07, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

NAD M3 power light turns red immediately and PROTECT message displays. Amp keeps functioning but volume control doesn't work up or down.


Hello
Check the connection to speaker with this amp, for any short or any other fault. disconnect the outputs, ie, speakers from the amp, and switch it On, and see the protect display comes or not. If it comes, the fault is internal and the set need service.
Your M3 dual Mono integrated amp, is of high output power and its outputs are protected against any overload or short circuit. If the system detect any among this condition specified above, it will show protect mode display.
Never load this amp, as protection display is there, as it may damage the speaker or its internal power amplifier section circuits, may cause more money to get it repaired. OK.

Jan 23, 2012 | NAD M3 Master Series Integrated...

1 Answer

Powers on in standby mode but shuts off when anything is pressed remote or manually? t-752 reciever


Generally speaking, an amp attempts to protect itself from heat, shorts, overloads and operator exuberance by refusing to turn on or stay on.

Overloads can be from excessive periods of high output or marginally low impedance loading by the speakers; and shorts would be wiring issues or a speaker blowing up.

You should be able to feel if it's hot. WHY is it overheating? Make sure it has sufficient ventilation on all sides and that vent holes are not blocked by dust balls. Ensure the fan (if equipped) is running as designed (some only operate on demand). Clean dust and debris from it.

If the amp comes back on after cooling, you're lucky. They only have so many self-protection cycles in their lives so continuously resetting or cycling their power without addressing the cause can do more harm than good.

If it protects immediately on a cool power up you should disconnect the speaker connections and try it 'naked'. If it comes up then diagnose which lead(s) are shorted. If it does not come up the problem is internal and should be left to an experienced and competent hands-on tech.

Jul 05, 2011 | NAD T752 Receiver

1 Answer

Hi there .. i have a nad t752 amplifier , i have just got it back from the nad repair shop , they have just reinstalled it , but now the front right speaker is much softer than the left front speaker ,,...


I hate to say this but the repair was not complete. If the sound levels are different with the balance in the middle, then either they missed a problem in one of the pre-amp stages, or they used an incorrect substitution for transistors in one or more stages. This unit should be brought back to complete the repair.

Any additional detail would require that I see the actual unit and poke around inside with test equipment.

Dan

Aug 08, 2010 | NAD T752 Receiver

1 Answer

Short Pin/Headphone jack issue with NAD CBE 720 Receiver


It's logical since the headphones jack is connected at the main amplifier. Does your new main amp has headphones out?

Feb 20, 2010 | NAD T752 Receiver

2 Answers

HELP PLEASE. NAD 370 JUST DIED...


This could be as simple as a bad connection at the voltage regulator IC or blown output transistors. If you have a multimeter and some experience with electronics repair, this should be fairly straightforward.

Let me know and I'll try to walk you throught the repair.
Dan

Sep 07, 2008 | NAD C370 2-Channel Amplifier

3 Answers

Right Channel Not Working


I have had the front, left and right channels go out over time. I have fixed all of them, and each time it has turned out to be a cold solder joint. While I love NAD and will continue to purchase there equipment, this generation is plagued with poor workmanship.

To fix the channel going out, I removed the top cover. Back cover and 2nd card from the left (looking at the receiver from the back side). This card handles all of the audio processing. I have found cold solder joints all over this board which has caused channels to suddenly go quite. I have never found a bad component. Also, I have cleaned the interconnect to be backplane (board that the audio processing board connects to) in the case of the center channel going quite.

If you have poor FM reception, the first board from the left (looking at the receiver from the back side) may have a cold solder joint on the coaxial connection for the FM antenna.

Apr 26, 2008 | NAD T752 Receiver

1 Answer

OSD for NAD T752


The blue screen indicates a proper connection (signal received by the monitor). Try selecting "amp" on your HTR 2 remote then use any directional button at the center of the remote, the keys which circle the "Enter" button. Hopefully you will then see the menu appear. Use the same directional keys to navigate the menus.

Mar 28, 2008 | NAD T752 Receiver

1 Answer

Nad 752


i would suspect a missing supply or speaker protect relay shorted? or staying closed too long. I'm not familiar with this model but a common failure is bad connections. Inspect all heat sinked parts and small value resisters used as fuses. Look for cracked solder joints on all parts, tighten pcb grounding screws. Memory is most likely powered by a high value cap or stack cap that maybe bad. Or the diode used to charge during usage maybe leaky , other part in ckt leaky, or the memory device itself is drawing excessive current off the memory cap. I have seen small 0.1uf disk caps turn into 1k resistors.

Nov 05, 2007 | NAD T752 Receiver

2 Answers

Receiver wont turn on


It sounds like You have a Bad output Some where and its going in to protect mode disconnect spkrs and make sure volume is Down all the way and power up,Ck your wireing for Freyed wires and shorts at the inputs and outputs good Luck ttech

Jul 09, 2007 | NAD T752 Receiver

Not finding what you are looking for?
NAD T752 Receiver Logo

429 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5047 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...