Question about Kenmore Vacuums

Open Question

I have a kenmore vaccuum, model # 216.37030700...the roller doesnt turn. there is suction. i turned the vacuum to check if it turns, and it doesnt...the belt is in good condition.

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: suction

Check the handle tube for a collection of hair, paper, dirt.

Posted on Oct 23, 2007

  • 48 Answers

SOURCE: bissell 37602 roller stopped spinning

If the roller brush as stopped spinneng .and the brush motor still works the brush belt as broken,
you must replace the brush belt, t

Posted on Nov 19, 2007

reddevil6
  • 1673 Answers

SOURCE: Kenmore Progressive 100

Check the brush roll ends, make sure they turn freely, if not then replace it. The belt may look ok, but they stretch after a short time and should be replaced.

Posted on Mar 25, 2008

chrispurs1
  • 372 Answers

SOURCE: Brush roller won't turn

Hi.

Your Dyson will have A clutch unit this engages the brush roller when you pull the handle back to vacuum.

Check the clutch control knob which is at the bottom left side of machine looking from the front rotates to drive position when handle is pulled back.

If it doesnt turn the knob by hand to drive.

If you still have no brush rotation after doing all this then either the clutch is faulty or the second belt which goes clutch to motor has snapped & will need replacing.

There are service manuals available for these repairs at this site
http://dysonmanuals.llc.nu/index.htm

Or from Ebay.

Posted on May 18, 2008

  • 1214 Answers

SOURCE: Vacuum has lost suction

Check the throat of the vacuum head where the air is sucked to the filter box. Check that it is not clogged.

Posted on Jan 23, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Model No. 116.39110900


Remove the filter / bag from the compartment, close the cover and briefly turn on the vacuum - is there suction? If so, check that the bag isn't already full / or replace with a new bag. Make sure it the bag is not being pinched / caught under the cover.

If no suction, look closely at the edge of the filter / bag compartment opening of the vacuum. There should be a gasket that the cover presses against to help ensure a good seal. If this gasket is missing, cut, has an object lodged on it or is otherwise damaged - it may be preventing proper sealing of the door; allowing air to be pulled through the gap in the seal - and responsible for the loss of suction at the hose.

Oct 19, 2015 | Kenmore Vacuums

1 Answer

Eureka vaccuum blowing out and not sucking in


Hi There,
I am going to assume you are talking about a Eureka upright vacuum.
The cause for this is generally either
A) Broken Belt - Which you can easily fix by changing belt
or
B) Blockage in the hose somewhere - Basically test the suction with the machine turned on with you attachment hose and see if you have suction. If you do check the belt and make sure you clear out any muck left around the roller.
If you need Eureka vacuum belts go to VacuumSpot.com.au

May 13, 2012 | Vacuums

1 Answer

Does not suction/pick up trash and debris.


we have an eureka 4495 model and it doesnt want to pick up the dirt off the floor but the hoses are clean and the hose it self has suction and the roller and belt are ok and turn

Feb 02, 2011 | Eureka True Clean Upright Vacuum (Yellow)...

1 Answer

HIGH PITCHED SOUNDS WHEN VACCUUM IS ON


Remove all filters and turn on the vacuum cleaner and check the hose for suction.If it has good suction turn it off and remove the belt.Turn it back on and if the noise is still there you have a motor bearing squealing.It's probably time to replace the vacuum cleaner if you have a motor problem.www.sewvac.com .Most of these box store models are designed for replacement if a major component fails.

Jan 28, 2011 | Bissell Vacuums

1 Answer

Ive changed the filter and checked the hoses but vacuum doesnt pick up ...when its on the dust is being blown out the bottom of the vacuum....i took the canister off to test the suction its fine...also...


have you check the roller brush and drive belt? It may be your belt has broke or is slipping and therefore not turning the brush.
Turn on machine and power head see if brush is turning if it is put a small amount of pressure on the roller. If it stops turning replace the belt

Nov 18, 2009 | Kenmore Vacuums

1 Answer

My vacuum has good suction but i can hardly push it across my carpet. any answers????


is your brush roller turning,that would cause it to be hard to push .the brush roller helps it walk across the floor.if your brush roller isn't turning then your belt is broke or the brush itself siezed up.unplug the vacuum and try to turn the brush roller .if it turns real free then your belt is broke.before you replace the belt always clean the motor shaft ,the old rubber from the old belt melts onto the motor shaft .if you don't clean it your new belt won't last very long.please leave feedback

May 04, 2009 | Kenmore Vacuums

1 Answer

Hoover U5468-900 WindTunnel Supreme suction is suddenly poor


The other possibility is there is a blockage in the foot. these models have dual channel air flow (windtunnel) and become blocked when not cleaned depending on use. under the roller there is a cavity that can be removed for cleaning. a hot motor can be caused by poor air flow.

Mar 15, 2009 | Hoover U5453-900 WindTunnel Supreme Bagged...

1 Answer

Kenmore vacuum- no suction, brush wont turn


Sounds to me like you have a plugged vacuum. Check all the way through.

Jan 29, 2009 | Kenmore 22812 Bagged Canister Vacuum

1 Answer

Main vacuum suction won't turn off


try cleaning out hoses,if that dont work turn it on its side if the roller doesnt spin u need to change belt if it does take the bottom cover and try cleaning out the hole under roller

Nov 22, 2007 | Eureka Altima Upright Vacuum Model 2996AVS...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...