Question about Epiphone Performer ME Guitar Acoustic

1 Answer

Not sure how to put batteries in the tuner. - Epiphone Performer ME Guitar Acoustic

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Epiphone Master
  • 5,603 Answers

Expect to find the battery box under the Esonic logo. Try to find a release for that little panel.

Posted on Apr 05, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I use the built-in tuner (Alvarez System 500) on my Alvarez guitar? I put a new battery in, but nothing happens.


is the battery in correctly? All Volumes up? If yes to both of those and you still get nothing, Then the tuner is not wired into the pick-up or is defective

Jul 07, 2015 | Alvarez Music

1 Answer

Don't know how to turn on tuner


put a battery in your guitar. It goes in the space at the bottom, usually where you connect your cable to your amp.
Then hold the guitar as you usually would.
Look for a little board with buttons on the side of the guitar to turn on the tuner: )

Mar 27, 2014 | Ibanez Talman Acoustic/Electric Guitar

1 Answer

I've changed battery in isys+ pre amp on vintage vec500 and now tuner doesn't work (it is blinking green on note tuner no matter of tune and no note letters showing - blank screen)


Is the battery installed in correct polarity? If so- try rotate it in position to rub through potential corrosion.

Since it has a remote battery, it would not hurt to look at the installation to make sure no wires are broken. Especially the ground wire to the pickup.

It might also be a good idea to apply some contact cleaner to the output plug since it is in the power circuit. Cycle the plug in and out a few times to clean the contacts. Also some contact cleaner to the preamp controls would be useful.

Be aware some lubricants may contain silicone and that can interfere with wood finishes or repairs to the finish in the future.

Apr 06, 2012 | Music

1 Answer

Litlle Martin LXME Tuner not working properly!!!


the only other solution would be an electrical short in the wires running from the tuning box to the input cable hole. take the tunner all the way out and make sure there are no loose wires. Make sure nothing is preventing the wires from making good contact.

Jan 23, 2012 | Martin Lxme Little AcousticElectric...

1 Answer

My profile PT-2900 digital tuner does not operate anymore. It lights up and everything but when I hit the guitar string it does not register. I checked the battery's power andit is at 2.8 v and the...


Definetly put a new battery in. Especially if you checked the battery out of the unit without any load on it. It would probably drop to around 2.5 when the load is there.

Sep 18, 2011 | Profile PT2900 ClipOn Chromatic Digital...

1 Answer

My ibanez Ael20 works for 2 seconds when plugged in and than stops working. I have replaced the batteries.


Make sure you are using a TS type cable (standard guitar cable, not balanced). Make sure the tuner is off as there are modes for tuning that kill the outgoing audio during tuning.

Jun 23, 2011 | Ibanez Ael20e AcousticElectric Guitar with...

2 Answers

Hi i recently bought a Takamine EG 260c G Series acoustic electric Guitar with TP-4T preamp installed in it. Now the problem is when i connect my guitar to an amplifier, the sound comes through it only...


That is working backwards from what it should be. I suspect a wiring error. Since this is a recent purchase, do NOT risk voiding your warranty. There isn't any real good documentation on the tuner.
I am not sure which tuner you have HOWEVER with one type, the FIRST press will turn on the tuner with the sound going out as well till the tuner goes off. The SECOND press silences the sound and is tuner only, the THIRD press turns off tuner and passes the sound. This is different than a lot of tuners and you will need to do three presses to restore sound instead of the usual two.

May 02, 2011 | Takamine 1 NEW Takamine EG350SC G-Series...

1 Answer

No signal, or in and out ,not battery or preamp


This appears to have a built in tuner. When you press the tuner button, that kills all output. Make sure the tuner is OFF to get output.

Feb 26, 2011 | Applause AE148RRB Super Shallow Deluxe...

1 Answer

I bought my Taylor acoustic/electric brand new. It sounds great, but when i plug it into my amp no sound comes out. I replaced the battery, but it still failed to work. When i plug it in to the amp and...


IF YOUR GUITAR has a built in tuner, make sure the tuner is off as it disables output while tuning... The other thing is to check if you have a volume control on the guitar that might be set too low.. Make sure if you are using 1/4 inch plug guitar cable that it is NOT a TRS balanced cable, as that will turn off the power in the guitar.

Dec 27, 2010 | Taylor Guitars 816ce Acoustic Electric...

1 Answer

Tuner for my acoustic guitar no longer works


Change the battery again and make sure you get a fresh name brand battery.

SOME batteries that are off brand or old or just plain defective will cause your symptoms.

ALSO check that it is securely contacting the battery contacts.

Things thaat come on for a second MAY just be residual charge on the filter capacitors that a breif contact was made to the battery.

Oct 26, 2009 | Alvarez Music

Not finding what you are looking for?
Epiphone Performer ME Guitar Acoustic Logo

Related Topics:

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Epiphone Music Experts

Michial Gueffroy

Level 3 Expert

1138 Answers

Vito Vacirca Jr.

Level 2 Expert

140 Answers

Robert Graf

Level 2 Expert

238 Answers

Are you an Epiphone Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...