Question about Pyle Car Audio & Video

1 Answer

I have a sony xplode radio,with a pyle pla1200 amp,and diamond speakers. Everything has worked fine until the fuse in the amp blew,now everytime i put the same size fuse in,it blows the fuse as soon as the switch is turned on,any idea as to why?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 81 Answers

Fault is in your sony. The fuse blows because of high power consumption. I think the final audio amplifier are burned( maybe only one channel)

Posted on Apr 04, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Amp on but no sound


Double check all of your fuses and make sure they are the corrects AMP. Other than that it sounds like the speaker wires came loose somewhere along the line. check on the subs and behind the deck. hope this helps

Apr 22, 2013 | Pyle PLA2678 POWER SERIES BRIDGED MOSFET...

1 Answer

Installed a Sony Xplode into a 99 Blazer and everything on the radio works but will not play through the speakers


The Bose system is complex - it has an amplifier separate from the Bose compatible radio. This amplifier takes low level audio signals from the radio, not full driver outputs from a replacement radio, and by trying to use the replacement radio you may have blown the amplifier. If that is the case, you may not be able to go back to the original radio.
The only option you may have with the replacement will be to find the Bose amplifier and bypass the connections to feed the replacement radio outputs directly to the speakers. This may not be as simple as it sounds, as distribution to the various speakers comes from the amplifier, not the radio, and the wiring from the amplifier to the radio may not have all the wires you need. Before going on, you had better get a wiring diagram for the Bose system (service manual or Alldatadiy.com).

Jun 11, 2017 | 1999 Chevrolet Blazer

1 Answer

What watt amp would be best for my 1100 watt 10 inch xplod?


I have a 1100 watt sony xplode the silver one 4 ohm rms 3 00 with a 3000 watt 400 rms pyle amp? 8 ohm

Sep 16, 2011 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

1 Answer

Is the pyle pla-1200 bridgable?


This appears to be the manual for several amps, including the pla1200
http://www.pyleaudio.com/manuals/PYLEChopperamps.pdf

If your amp is the same as in this manual, it is a mono amp (or one channel) amp. There is no need to bridge with a mono amp as it has only one channel. The diagram specific to pla-1200 is on page 20 of the manual.

Feb 27, 2011 | Pyle PLA1200 Car Audio Amplifier

1 Answer

I have 2 10' sony xplodes connected to a 2


If your radio is still playing and the subs are giving you music, you most likely have the amp remote wire hooked to a constant power source on the radio. Generally, this is a solid blue wire on both the radio and the wiring harness. It allows the radio to turn the amp on and off when the radio is on or, subsequently, off.

Apr 21, 2010 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

2 Answers

Amp blows fuses


Are you using the correct fuse? if so,
more then likely, you don't have a good ground. Try grounding to something else that has more direct connection to your frame. If that doesnt work, try getting larger power cables.
I had the same problem with my 2500w xplodes all I had to do was get a thicker cable for the ground and battery connection. What was happening, was it was needing more power then the wire and fuse could handle, so it would blow the fuse, since the higher you have it, the more power it needs to feed the watts.
I would try grounding it directly to the frame on a good part of the frame before spending another $70 on new power cables though.

Mar 09, 2010 | Car Audio & Video

1 Answer

Speakers cut off when bass goes up...


sounds like you hava a load problem.if your'e running your woofers at 1ohm,make shure your amp is 1ohm stable.....

Jul 03, 2008 | Car Audio & Video

1 Answer

Wiring 2 diamond crossovers into a sony xplode amp & cd player


The crossover wires have absolutely nothing to do with your cd player, all you do is wire your crossovers into the speaker slots on the amp and then wire your mid-range speakers and tweaters into the crossovers. All a crossover does is it splits the power from the amp to your mid-range speakers and your tweaters.

Aug 13, 2007 | Sony XM-2150GSX Car Audio Amplifier

6 Answers

Speakers cut off when bass goes up...


it might be that your wires from your amp to your subs are too thin. since they were relatively new the first three months, they were probably undamaged, but after pushing them too much, they probably have broken wires, and can't get enough power to the subs when turned up, i suggest getting thicker wires before investing in a capacitor, it could save you money.

Mar 21, 2007 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyle Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

The Knight
The Knight

Level 3 Expert

74473 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8575 Answers

Are you a Pyle Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...