Question about Kustom Double Barrel 30-watt 2x12 Hybrid Guitar Combo Amplifier

2 Answers

I have a Kustom HV 100 hybrid tube amp. When I power it up, It will play normal for about 5 seconds and then the volume drops off. The preamp tube is only about 2 months old and this amp only gets played once a week. Any help would be greatly appreciated.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Sounds like a bad 6l6 tube that made a bad day for me also

Posted on May 16, 2015

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kustom Master
  • 5,603 Answers

After the volume drops off, let the unit sit idle for a minute and then try it again. If the volume has restored for another brief period, suspect the filter caps are weak and voltage drops when you start driving the unit. In any case you need to have it serviced. Unless you can see the heater in a tube going out with vibration this may not be a DIY repair. If you see purple glow in a tube, replace it.

Posted on Apr 04, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to an Expert (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Kustom KPM8420 PA mixer and the monitor channel comes through both the monitor and main speakers and vice versa. The two channels are not separate.How do I fix that?


On the back panel there is a section labelled Patch Bay
There are 2 small switches which assign each Power Amp to either Monitor or Main Output.
It would seem you have them both set the same at present. Set one to Monitor and one to Main, and use the corresponding Power Amp outputs direct to speakers.

Note you can send signal to external amps or powered speakers from the preamp outputs. This is really handy.
Download and print the manual from https://www.manualslib.com/manual/90516/Kustom-Kpm-8420t.html
and keep it with the mixer.

( Of course don't send speaker outputs to other amps or powered speakers )

Sep 11, 2017 | Kustom Music

1 Answer

Peavey problems


cracked solder joints, how old is it, they have 5 year warranties..

Aug 02, 2014 | Peavey ValveKing 100w All Tube 212 Combo...

1 Answer

Having some negative issues while playing guitar through my amplifier.....


Have you checked all the other amp tubes? You may have a bad 12AX7 or 12AT7 tube.

Aug 02, 2014 | Peavey ValveKing 100w All Tube 212 Combo...

1 Answer

My Kustom HV100 amplifier turns on but takes forever to make sound. When it finally works it stays on the rest of the night. How do I fix this?


if you have replaced the preamp tube than try looking at the capictor. i had just bought one and i thought the tube was out turned out i was worng

Jun 07, 2011 | Kustom High Voltage Hybrid HV100 Guitar...

1 Answer

On the kb 100 channel 1-3 will play for a hot sec. then the volume will go out. but it will play in one of the plugs on the back. tell me why is that. need help thank you.


If we knew what brand this was it might help us to help you. USUALLY the plugs on the back are direct connection to the power amps... One common thing that can happen is the switch on the back plugs of some amps pass the preamp output to the power amp when nothing is plugged in. SOMETIMES those contacts on those back jacks make poor contact and disconnect the preamp. Also bad solder joints can cause the behavior you are seeing...

Apr 14, 2011 | Music

1 Answer

I have a Kustom KPM 4100 amp head that's cutting out. It works OK for 5-10 mins then crak snap crakle then nothing. After a cooling off period I can repeat the process. I have pulled the power amp and...


Have you tried connecting a single speaker to each output and cutting the volume down to see if you have a load or impedance problem? The amp may be perfectly fine except it's trying to play to a 2 ohm or less load :-)

Carl

Mar 16, 2011 | Kustom KPM4100 PA Amplifier/Mixer

2 Answers

I have a Marshall TSL 601. I recently re-tubed my the amp with new Tung Sol tubes and biased per factory specs. With the new tubes installed in both the preamp (12AX7/ECC83's in V1, V2, V3, and V4) and...


First thing is that if you bought MATCHED pairs of the EL34's a COMMON mistake is to install the pairs wrong. Correctely install a pair as the OUTSIDE tubes of the line and then the remaining pair as the middle two tubes of the line of tubes before biasing.

Funny thing, I just ran across this problem you have with a Bedrock brand amp that uses the same configuration as your V3 tube does. This is really a stupid configuration engineering wise as they tie a plate at high voltage to the grid of the second stage in the tube as a cathode follower, This means that the second section has the cathode at a reasonably high voltage relative to the heater with wide audio swings on it as well... Tubes are NOT designed to work that way and result in noisy behavior, One would have to select tubes that have very low heater to cathode leakage in the second section of the tube... What you are seeing is the result of very poor engineering practice. Marshall is probably testing tubes for the leakage and branding them as such...

I think that designers of this circuit have NOT had experience with tubes and have applied transistor type designing to this use... it is plain stupid and myself I would re-engineer the circuit if it was mine or build a tube tester capable of measuring the heater cathode properties to select a suitable tube to use.

Jan 29, 2011 | Music

2 Answers

Marshall amp goes quiet


Often this is a broken input connector or an electronic failure such as a tube or semiconductor device.

On some units a failed switch on a jack for direct input to the power amp can cause this. Oxidation at the contacts causes this problem.

Apr 27, 2010 | Marshall Mg100dfx 100-Watt Combo Guitar...

2 Answers

Marshall DSL 100 - volume fades away and gradually comes back on


IF this is a vacuum tube unit, these symptoms are that of a tube that the heater is intermittent, that is it cools off due to a break and then liights again.

Open the back and observe the heaters in the tubes. DO NOT be fooled by some that have TWO heaters in them. (use a mirror if necessary) A single one that comes and goes can cause the problem and the voiration can make it come and go. This behavior in a tube is NOT somthing readily spotted in a tube checker. The delay in fading and coming back would be the delay in warm up following a heater going out and cooling.

Feb 14, 2010 | Marshall Amplification Marshall MG250DFX...

1 Answer

No volume.


Are the tubes bad? Do they light up? Check the tubes and install replacements if necessary. If it's a preamp tube that went bad, just replace that one tube. If a power tube went bad then replace the set of power tubes. Be sure to get a matched set when replacing power tubes, and to bias them.

Aug 08, 2009 | Fender Hot Rod Deluxe Guitar Combo...

Not finding what you are looking for?
Kustom Double Barrel 30-watt 2x12 Hybrid Guitar Combo Amplifier Logo

Related Topics:

206 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kustom Music Experts

Brad Brown

Level 3 Expert

16376 Answers

Michial Gueffroy

Level 3 Expert

1138 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Kustom Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...