Question about Yamaha YST-SW150 Speaker

Open Question

Yamaha yst-sw150 I had a power surge that damaged the transformer. Looking for replacement part number or output voltage.

Posted by on

1 Suggested Answer

  • 238 Answers

SOURCE: Yamaha YST-SW150 Subwoofer

hi, is it a humming noise ??? check if the connector is plugged in properly,check the earthing, if its a three pin mains plug, if its a two pin, then the CPU SMPShave a proper eathing. let me know

Posted on Jan 12, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Which is the output voltage of transformer (the part number is SY-76D30085B 150e7630085)? Thanks if you could help me. Regards Jean-Louis


If you are looking for the specifications for this transformer to replace it, then don't bother. Makers like transformers replaced with exact parts by them, for safety reasons. You have the part number just find out who has it, or contact the maker for a supplier.
If you just want to know the voltage a multi-meter will tell you that.

Jan 21, 2016 | Mordaunt Short MS-308 Subwoofer

1 Answer

Yamaha yst-sw012 power but no sound


The problem is the Ic or transistor use a tester

Jan 14, 2013 | Yamaha YST-SW012 Subwoofer

1 Answer

How do I connect the YST-SW45 sub to a different system


It's a standard non-proprietary standalone self-powered sub that accepts any input one could want. Your unnamed electronics will be the determining factor. Manuals spell it all out.

http://www.retrevo.com/support/Yamaha-YST-SW45-Subwoofers-manual/id/320bh343/t/2/

Aug 05, 2011 | Yamaha YST-SW45 Subwoofer

1 Answer

I have a YST-SW150 speaker that turns it self off after 7 minutes , turn it back on and it'll go again for 7 minutes, (sounds good those 7 min) music sensor auto on/off is off


I just fixed one of these with the same symptom.
In between the power supply board and the amplifier board are a number of rather fine interconnect wires. One of these is the shutdown/startup control line for the auto on/off function.
In my case the wire had been pinched where they are cable tied together. Causeing the power supply to think there was no music input and should shut down.
rejoing the broken wire rectified the problem.
In my case more than one wire had been damaged.
the shut down line is labled SO on the amplifier board connector.
7_19_2012_1_10_37_pm.jpg

Aug 10, 2010 | Yamaha YST-SW150 Speaker

1 Answer

YST-SW215


Do you have the input voltage switch set to 120V 60hz. There is a switch that should change from 120v/60hz to 220v/50hz. In the US this should be on 120v/ 60hz

Jul 02, 2008 | Yamaha YST-SW215 Subwoofer

1 Answer

Yamaha YST-SW150 Subwoofer


hi, is it a humming noise ??? check if the connector is plugged in properly,check the earthing, if its a three pin mains plug, if its a two pin, then the CPU SMPShave a proper eathing. let me know

Jan 10, 2008 | Yamaha YST-SW150 Speaker

Not finding what you are looking for?
Yamaha YST-SW150 Speaker Logo

Related Topics:

163 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Speakers & Subwoofers Experts

 Grubhead
Grubhead

Level 3 Expert

4576 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68157 Answers

Are you a Yamaha Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...