Question about Alpine Car Audio & Video

2 Answers

Hi, I have an Alpine IVA D310RB unit which worked once but I've had to put it in a different car. The touch screen works i.e. it 'buzzes' and clicks but no picture. There is no lighting on the buttons surrounding the screen - the bottom panel is fine all blue etc. I've taken the unit apart because i think it's a lighting fuse? but can't see one - i'm hoping its not the circuit board! Matthew

Posted by on

  • Matthew Cooke Aug 05, 2008

    All wiring is correct

    Matthew


×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 848 Answers

Replace the fuse it will work properly .......

also check whether the connections are proper .......

Posted on Aug 05, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,028 Answers

Have you check to be sure the wiring is correct?

Posted on Aug 05, 2008

  • Ryan Rogers
    Ryan Rogers Aug 05, 2008

    If there is no internal/inline fuse for the screen, then check for an inlineresisistor or capacitor that may have blown. I know that in some JVC stereos they put this funky little capacitor thing that blows when overloaded, all you have to do is clip the wire at each end and soldier in a new one. These are generally about twice the size of the lead wire, are wrapped in a heat shrink, and almost look like a splice in the wire, so they are easily overlooked. If the Alpine doesn't have one, then check the connection for the screen, it could have come loose. I really think that, if all else fails, you'll get away with just a screen replacement versus a system board. Try this and let me know.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Alpline iva-w505 touch screen broken. what can I do?


There is not much that can be done to a broken screen pad but to replace the whole unit . Please get help from the service dealership or post yourr problem to the link: Alpine official site.

Nov 05, 2010 | Alpine IVA-W505 Car DVD Player

1 Answer

Screen is blank on my Alpine IVA-D106 and menus, video etc only appear when I touch the screen. A few seconds after touching the display goes blank again.


check the screen configuration using the visual button on the top right side of the screen, you should disable the "OFF" button

Apr 16, 2010 | Alpine IVA-D106 Car DVD Player

1 Answer

I have a Alpine IVA-D310. It works but my touch screen is black


i had the same problem. the ribbon cable that connects the tilt screen may have pulled out of the monitor

Apr 24, 2009 | Alpine IVA-D310 Car DVD Player

1 Answer

I think the amplifier is bad on the alpine iva-d300.


What kind of setup do you have in your car? Stock sound system with just this aftermarket head unit?

Jan 01, 2009 | Alpine IVA-D300 Car DVD Player

1 Answer

Alpine IVA D310RB Backlight issue


If there is no internal/inline fuse for the screen, then check for an inlineresisistor or capacitor that may have blown. I know that in some JVC stereos they put this funky little capacitor thing that blows when overloaded, all you have to do is clip the wire at each end and soldier in a new one. These are generally about twice the size of the lead wire, are wrapped in a heat shrink, and almost look like a splice in the wire, so they are easily overlooked. If the Alpine doesn't have one, then check the connection for the screen, it could have come loose. I really think that, if all else fails, you'll get away with just a screen replacement versus a system board. Try this and let me know.

Aug 05, 2008 | Car Audio & Video

1 Answer

Alpine IVA-W205 XM not displaying in source menu


Alpine IVA W205, Red light on the bottom left of the screen and the radio & cd player does not work?

Jan 06, 2008 | Car Audio & Video

1 Answer

Bottom row of touch screen won't work


may have a sollution for ya. i cant spell. try to reset the alignment on the screen. i had the same problem once and somewhere in settings you can RESET the screen alignment. good luck

Dec 29, 2007 | Alpine IVA-D300 Car DVD Player

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

250 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jaime Hernandez

Level 3 Expert

2296 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...