Question about Balboa Instruments Duplex Digital Panel 2 Pump

1 Answer

I have a balboa spa that is six months old and has been working fine. Went out to check it and it was cold and no readout on the display. Flipped the breaker and it went through its cycle and shut off again. After turning the breaker on and off a few times I just get alot of clicks coming from the control box and can see the display coming on and off. Allready replaced the heater, has the circut board gone bad?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 46 Answers

It is possible that the board is bad. A loose connection orlow voltage issue may also cause this problem to occur. If the voltages arewithin the acceptable rand and all connection are tight then remove any accessoryequipment and restart the unit to see if the problem continues. If it does thena new board will probably resolve the issue.

You can find answers to common spa problems online at http://www.balboadirect.com/support.aspx
Hope that helps!

Posted on Sep 12, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My balboa spa is not heating everything seems to be working fine what could be wrong


check fuses for heater element if ok see if calling for heat if so check element if not calling for heat bad temp sensor replace

Sep 08, 2015 | Balboa Instruments Pool & Spa

1 Answer

Catalina spa


When the control panel does not light up this means the panel is not working and needs to be replaced.

Rod
US Parts Center

Apr 15, 2014 | Pool & Spa

1 Answer

I need to replace my Weslo Spa Comand Panel, 4 button, ovel. will the Balboa work.


The best suggestion in this case would be to replace the spa pack and upgrade. this is a really old system. You can replace the entire system for around $500.00 and have the latest working technology along with a new topside panel, overlays, heater, system, etc. The Balboa Value Pack Retrofit kit comes with everything you need along with cables. Since you have Weslo with an oval panel, the best suggestion would be the Balboa 54219-Z Value Pack Retrofit Kit. you can get it online by clicking on the link I have provided.

Hope that helps.

Balboa Direct

Sep 10, 2011 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

Error code "OHH" displayed when


OHH code means "Overheat" condition

The spa has shut down -one of the sensors has detected 118 ° at the heater. Check it and replace it if go to bad.

Hope helps.

May 25, 2011 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

My balboa spa says sl and isn't heating up


SLP or SL Message

If the SLP or SL Message is Alternating with the Water Temperature on the Display, the Spa is Operating in the Sleep Heating Mode.

If the SLP or SL Message is ON Solid (Not Flashing) on the Display, the Spa is Operating in the Sleep Heating Mode, but there is No current water temperature because the Spa is between Filter Cycles.

You can find answers to common spa panel messages on the following page:

COMMON SPA PANEL MESSAGES

May 19, 2011 | Balboa Instruments BALBOA 30 kW HEATER W...

1 Answer

Spa has been off for about 6 months, due to short in element. and blew breaker. Changed element but pump wont start now and temp on controller keeps flashing and changes temp readouts up and down but pump...


I suspect the motor shaft has rusted in place. Remove the pump and try to free the motor shaft. If there is rust around the shaft spray in some wd-40 and let it sit a while.
At the far end of the pump is small cap which pries off. Inside there is a slot on the motor shaft you can use to turn the shaft with a large screwdriver.
Once the shaft can turn reinstall.

Nov 07, 2010 | Waterway Spa Pump Executive 56 Frame 4hp...

1 Answer

Had a new heater element installed. won't go


You need to put the system into 'ST' mode. 'SL' stands for 'Sleep' and will prevent your spa from heating.

'Regards,
Ian.
http://hottub.synthasite.com

Feb 24, 2010 | Sys BALBOA SUV SYS 5.5kW W/ 120V 1.OHP...

Not finding what you are looking for?
Balboa Instruments Duplex Digital Panel 2 Pump Logo

266 people viewed this question

Ask a Question

Usually answered in minutes!

Top Balboa Instruments Garden Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Paul Stonecypher
Paul Stonecypher

Level 1 Expert

28 Answers

Mister Danger

Level 3 Expert

5631 Answers

Are you a Balboa Instruments Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...