Question about Logitech Z323 2 Speakers

2 Answers

Speakers just quit working after about a week, computer still producing sound. Light will not come on, power going into sub but not out to the speaker with the power switch, looks to be an internal problem. Any fix on my end?

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 356 Answers

Other than checking to make sure all the cables are in firmly, which you've probably already done, the best bet is to contact Logitech support. If you just purchased it within a week it should be under their warranty still, and they are usually great with taking care of issues with their product.
Just have the product name, model number, and part number ready.
Support - Main +1 646-454-3200

Monday - Friday: 6am - 6pm PST
Saturday - Sunday: 7am - 5pm PST

Posted on Apr 01, 2011

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Logitech Master
  • 27,725 Answers

If you are having problems with your sound
if your computer came with a motherboard disc the sound drivers could be on it
click start control panel administrive tools computer management device manager scroll to sound,video and game controllers you might see a yellow question mark? Right click to reinstall drivers
click start control panel sounds and audio,volume,advanced,speakers make sure you have selected the
(((appropriate speakers))) also audio you will find 3 drop down lists make sure you have the correct settings there
also
click start control panel sounds and audio devices you can adjust the volume there also select speaker volume you can change your settings there you can also tick in the box place icon in taskbar
if his does not fix the problem

have you tried this control panel sounds and audio,volume,advanced,speakers select the appropriate speakers from the drop down list or navigate to the device manager scroll to system devices + to expand,system speaker right click properties then select use this device (enable) also you might check
the speakers plug/outlet is usually at the back of the computer you will have to open up the computer to check the lead attached to the rear of the input plug make sure the connection is good
try cleaning your computer of dust using a fine air blower from a compressor making VERY sure that there is no MOISTURE in the air line specifically around the sound card and the CPU central processing unit dust causes static to build up in a computer
hope this helps

Posted on Apr 01, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Klipsch Sub-10 It is NOT working. I am not sure what happened. It was just fine last week. It's powered up and everthing but not throwing any bass. It was also detected during the auto setup.


If you're saying the auto setup produced sound then the sub and its amp are fine.

So we need to examine the source electronics for actual playback settings. Give a hint of what that might be.

Feb 19, 2011 | Klipsch Synergy Sub-10 Subwoofer Speaker

1 Answer

Only the sub anbd one of the four tower speakers


The center one, right? You need to plug in all 3 plugs in the sound card, otherwise they won't work.

Feb 16, 2010 | Dell 5650 Computer Speakers

1 Answer

Lights are on in the small speakers but no sound is produced...there is a short scratchy sound when I juggle the speker wire from sub woofer. I hooked speakers up to a different MAC and now am trying to...


Hi there , the green light just means its getting Power, it doesnt mean that its going to give sound, It could be that you dont have Drivers installed for your Sound card which is causing it too not get sound , but when it makes that static noise , its the Wire just causing Static with the Sub , just means its getting power , The + and - sign is the volume control ...Try see if you can turn it louder with the + . maybe it is low enough not too hear.....Hope this helped Bud
Happy new year.

Jan 03, 2010 | JBL CREATURE II Computer Speakers

1 Answer

The small speakers produce sound but the sub


I have Boston BA745 speakers and want to use them with my new HP Pavillion Elite HPE computer. How do I get them to work?

Dec 27, 2009 | Boston Acoustics BA745 Computer Speakers

6 Answers

Dell MMS-5650 5.1 speakers not working


sounds like they are picking up interference. make sure they are grounded well.

Aug 19, 2009 | Dell 5650 Computer Speakers

1 Answer

Speakers Don't Work Properly


Go to control panel > Sound and Audio Devices > Speaker volume.
If still don't solve the problem check the device.

Feb 20, 2009 | Dell A215 Computer Speakers

1 Answer

Infinity ps-10 powers up but no boom


Try hooking up a different signal input to your powered sub, another stereo or even a dvd players audio output to the sub will work for a test. Just make sure the subs gain is down before starting. If it still not producing sound, the subwoofers amplifier is bad. I hope this helps.

Oct 10, 2008 | Infinity PS-10 Subwoofer

2 Answers

Subwoofer crakling sound when playing anything.


Hello Ronaldlora
Happy Holidays

Hi, this is a particular problem for this speakers, and subwofer, it is a resistor inside the sub, you have to fix it in a repair shop, or ...sadly, change for another model of Creative Speakers, for example one good one is the 7800 Spk. good ones.
but like I say is a problem that creative labs is aware too.

Dec 17, 2007 | Creative Labs Gigaworks S750 Computer...

1 Answer

Klipsh Promedia 2.1


I was face the same problem 2 year's ago.This problem occur when you move the speaker's here and there.at that time speaker's wire diconnected in inside...please check the whole wire by electricians for where exactly it is disconnected...

Sep 10, 2006 | HP ProMedia Computer Speakers

2 Answers

Sub Woofer does not work


hi there are fast checkings for you: Quick Connect Card http://www.alteclansing.com/downloads/641QCC.pdf manual: http://www.alteclansing.com/downloads/641_MAN.pdf is the system working fine exept the sub? my guess: the headphone jack works fine then the speakears are too if soo then the sub amp is bad or some connection is torn try opening the sub and see if everything is hooked right and if soo then the amp is the problem every electronics shop can fix this good luck

Mar 21, 2006 | Altec Lansing 641 Computer Speakers

Not finding what you are looking for?
Logitech Z323 2 Speakers Logo

152 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

JP Services
JP Services

Level 2 Expert

310 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...