Question about Televison & Video

3 Answers

I have a Vizio VP42 HDTV (inside says LG PDP42X3U400). One day I turned on the TV and heard a pop. I took off the back of the TV and inspected the main power supply board (P/N 6709900019A). Capictor C802 had totally blown up. The tv would not power on at all. I removed U801 and when plugging in the AC cord I heard two relays turn on and then back off after 1 to 2 seconds. I gave up troubleshooting that board and bought a new power supply board. When I installed this board and plug in the AC cord I do not hear the relays click. I however have a front amber light and when I press the power button it turns green. However, with the LED green I have no sound or picture (VS and VA not on). I got the board from shopjimmmy.com and they said it was refurbished so I don't know if it is this board that is bad or some other board on my TV. I have a background in electrical engineering/electronics. If you could provide me some info or places to start troubleshooting I would greatly appreciate it. Thanks, Jason

Posted by on

  • 4 more comments 
  • harperj1dman Apr 01, 2011

    No, I didn't say that. This is what I wrote: "When I installed this board and plug in the AC cord I do not hear the relays click. I however have a front amber light and when I press the power button it turns green. However, with the LED green I have no sound or picture (VS and VA not on)." It's from my measuring on the board that I know I have a 5V supply working on the power supply board and I assume that is what is powering the front LED.

  • harperj1dman Apr 01, 2011

    When I refer to VS and VA that is the voltages on the supply board. They are reading zero. Even without any of the connectors hooked to the power supply board (just 120V main), I get not Vcc, VS or VA. I already have the service manual and have read all the forums online. I was hoping someone had direct experience with this exact model of tv/power supply.

  • harperj1dman Apr 01, 2011

    I need an expert with direct experience with this TV and power supply. I have the service manual. When I disconnect all connectors to the power supply board, except the 120V main, I measure 0V at VCC, VS, and VA on the power supply. These voltages should be 5VDC, 186VDC, 60VDC, respectively. I do not even hear the relays click on when I apply 120VAC to this board. From these observations I believe shopjimmy sent me a faulty board. If you can offer any meaningful advice please do so. However, please do not offer any advice unless you have direct experience down to the component level with this board.

  • harperj1dman Apr 01, 2011

    I assumed the board was bad. However, do you know what the normal startup procedure is for this board (2 relay clicks, green light, etc). Also, why when I measure the VCC 5V on the board I measure 0V but the front LED is still lit when I plug in this power board?

  • harperj1dman Apr 01, 2011

    What you just described happens when? When I plug in the 120VAC plug to the TV or when I have alreadly plugged in the 120VAC plug to the TV and hit the power button? Also, with the power supply totally unplugged from any connection to other boards on the TV, if I plug in just the 120VAC plug to this board should I be reading VCC, VS, and VA voltages or do those only turn on if the power button is pushed?

  • harperj1dman Apr 01, 2011

    The power up signal from the processor should be sent if the bottom connectors are still connected to the power supply. What pin is this sent on and on what connector? Also is it a 5V logic signal (I would assume). If you give me this info I will go home and discconect the Ysus and Zsus connectors from the board and keep the bottom two connectors that run to the processor boards and press the power button and measure to see if it is getting the startup signal from the processor. I would consider myself very experienced.

×

Ad

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,800 Answers

If Va and Vs are missing even when the Y-sus board is disconnected from power board then the new board is defective - return it. On the original one the board is shut down (the relays are disconnected) because there is still a short on one of its output lines - replace all the final filtering capacitors, when one has failed the others can't be far behind.
BTW the LG PDP42X3U400 is the brand and model of the plasma screen .

Posted on Apr 01, 2011

  • 1 more comment 
  • Azrael SRL Apr 01, 2011

    It's first relay, then the command to start it up, then the second relay then the green light. There are 2 completely separate 5 V outputs: one that is constantly present (the stand-by one) and one that is activated when the tv gets started - so the section that controls the status lights, the IR receiver and pat of the control processor are always powered (otherwise you couldn't use a remote).

  • Azrael SRL Apr 01, 2011

    After you plug the mains. the first relay shoud kick in and the status light be orange/red. Only after you push the power button the second relay kicks in and the light goes green. With nothing plugged in, the power source will generate only the 5V stand-by - the Vcc, Vs and Va should be 0. They are generated only after the source gets the power up signal from the processor - without it connected the source can't start; it can be forced to start by jumping the start signal directly from the 5Vstd but this should be done only by experienced persons - it's very easy to fry the source this way by accident.

  • Azrael SRL Apr 01, 2011

    I don't have the service manual handy - the correct pins are in there. Yes, it's a 5V logic signal.

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 12,061 Answers

Jason, OK FIRST you MUST get a service manual, (Link supplied below) or you are simply going to waste your time and money. Link below, and then as I tell ALL my students the place to start, the ONLY place to start, is the Power Supply, and here it is simple "Are Your Voltages Correct?" You must examine these voltages and work back along the faulty rail(s) .
You see in any fault we usually have THREE aspects, the fault, the cause, the damage done. ALL these must be solved, or the fault will simply return, at best and still not work at worst.
Use the service manual to guide you especially along the TS flow charts...
Whenever a Cap blows usually there is considerable co-lateral damage, as the enormous current instantaneously draw can damage other parts on the circuit, especially any series components, and stress others, so they may fail soon after & when "put back into service" as it were after the prospective repair.
So you have to find the "Cause" of "Why" the Cap blew? This Cap must be replaced, and any "Other" damage done, this too, must also be found and fixed.
It is always beneficial to understand exactly how the TV, one is servicing, "Boots Up" as it were. Then one can work along the "Path" of powering ON, and find out, either Why, the set itself, is prohibiting the set itself, from powering ON, or, whatever else, is "Stopping" it from doing so.


https://www.samswebsite.com/en/photofact/search/index/page/21/photofactflag/2
Above is where to get a service manual, they are worth their weight in gold. Below is a user manual, and below them are Forums to get info from.

static.tigerdirect.com/.../Vizio-VP42-Refurbished-Plasma-HDTV-Manual.pdf

http://www.avsforum.com/avs-vb/showthread.php?t=756696
http://forum.ecoustics.com/bbs/messages/2/429280.html

Posted on Apr 01, 2011

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,889 Answers

So you say that the set turns on and off but you have no power. Is that correct?

Posted on Apr 01, 2011

  • eagle338
    eagle338 Apr 01, 2011

    If I am not wrong the green LED indicates power is on. Also by Vs do you mean 5V standby voltage? If yes then are you sure you tested correctly? Because if the standby voltage is not there then the LED at the front just keeps blinking.

  • eagle338
    eagle338 Apr 01, 2011

    See the only reason I asked you those questions is because I wanted to be absolutely sure that I get the diagnosis right the first time. If you do not answer these questions, I am afraid no tech would be able to resolve your problem in the first shot. I do not want to go by the trial and error method of replacing the boards. Shopjimmy is a reliable source for boards as they are tested prior to delivery. I am suspecting the main A/V board but I just want to be sure thats all.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a vizio 42 model vp42hdtv and the screen is dark red I have sound


VP42 HDTV Will not power up. Changed power supply board and power cord. Still nothing

Apr 12, 2011 | Vizio 42 in. LCD TV

1 Answer

TV won't stay on! The TV will randomly make a "click/pop" sound and turn off. I will unplug the tv for a bit and then reinsert power cord. The tv will "click" (just like when it is turning on) then a...


Power supply board have problems.It dying.That the board,where the power a/c cord plug into it.Tries websites like Shopjimmy.com,Ebay.com to buy a refurbish power supply board for the replacement.

Sep 14, 2010 | Vizio P50HDTV10A 50 in. Plasma HDTV

1 Answer

I heard a pop and the tv went blank no sound no pic, but the VIZIO light turns white when on and yellow when off. I unplugged and took off mount and heard some part moving around inside the tv. A small...


The odds are one of the capacitors popped. Look around the circuit boards for this bad capacitor. It should be deformed and stick out like a sore thumb. Radio Shack or some local electronic supply place should carry replacements.

Nov 08, 2009 | Vizio L32 32 in. LCD HDTV

1 Answer

Picture went out on TV


you need to change the sustainer boards and TV will be good as new.

Apr 05, 2009 | V, Inc. Vizio P4 Plasma Television

1 Answer

Sound Problems with 32" Vizio HDTV


our brand new Vizio 32 HDTV has poor sound quality, so irritating in it's flat muffled character that I can't watch it. My electrical engineer husband as attempted to change it (he does not hear the difference between the Vizio and our two Sony...there is a BIG difference) by turning off the surround sound. But to me nothing has changed. What do you think? it sounds a little bit like an old radio or a broadcast from inside a closet. Hmmm

Jan 08, 2009 | Vizio L32 32 in. LCD HDTV

1 Answer

Vizio tv first screen had bluish discoloration and than few days later a pop and screen went black .ANY IDEA OR SUGGESTION all of the sudden started experiencing severe discoloration


This is called the pop of death! If you call vizio they will ask you if you heard a pop, this is a common issue and unless your under warrenty your looking at 916$ to fix it. (assuming you have no sound! If you do its 430$ plus tax for parts and repair. You can buy a used one on ebay for that price!

I have the parts numbers if you want them!
Call vizio if you have had this system for under a yr the will fix it free!

As for me my 50 and 42 inch had this issue and well I am out of warrenty.. I hate vizio lol!

May 24, 2008 | Vizio L32 32 in. LCD HDTV

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

409 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74245 Answers

Cindy Wells

Level 3 Expert

5127 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...