Question about Wolfgang Puck Stand Mixer

1 Answer

Broken blender attachment

The blender attachment on my mixer broke and I need to replace the plastic connection that attaches to the top of the mixer. Where do I find the replacement part?

Posted by on

  • Anonymous Mar 18, 2014

    I have KA850 food processor and the soft plastic drive couplings in the bases of the blender jug and mini chopper, Pt No MS-967 8660, have both sheared. Krups say they don't support this part anymore. Any suggestions as these attachments are useless without these coupling. Bests regards

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 150 Answers

Wolfgang Puck Housewares Customer Service
800-275-8273
Monday - Friday
9:00 am - 4:30 pm Eastern Time

I would call the number above they should be able to help you out.

Posted on Aug 04, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I can attach the immersion blender attachment but it does not turn on. The machine works fine with the mini-chopper attachment or the beaters. How can I fix this?


Hi
Make sure you use the pulse function of the power switch. Only this position (forward, away from you) will activate the immersion blender, and then at full speed only.

Feb 09, 2011 | Braun M880 MultiMix Hand Mixer

1 Answer

I seem to have lost the instruction manual for my mixer. I would like to use the immersion blender, but I can't figure out how to attach it to the mixer body. The shaft on the blender is too short to...


Hi
The blender does not attach to any of the two holes for the whisks.
You need to push back the sliding cover in the center, bottom part between and behind where the whiskers attach. This will uncover a third attachment possibility, where you insert the blender and twist it a quarter turn into place.

Dec 13, 2010 | Braun M880 MultiMix Hand Mixer

1 Answer

Blender attachment does not work


It could be the drive belts. There are three. One for the motor to the belt drive. one from belt drive to bowl mixer spindle. one from belt drive to mixer spindle. mine started to do the same thing. I ordered the belts from Bosch.

Jun 08, 2010 | Bosch 700 Watts MEK7000 Concept Series...

1 Answer

Tipped over my blender, broke the black plastic piece that raises and lowers the top, and now it is stuck in lower position. Won't move.


Blender? This is a form about Kitchenaid mixers . . . assuming that's what you have,and it is a stand type mixer, look at this page:

http://shared.whirlpoolcorp.com/assets/pdfs/literature/Repair%20Part%20List%20-%208212369.pdf

And you will see the linkage which was bent/broken. Hopefully you will be able to either straighten the bent part or replace it if it is broken.

Mar 27, 2010 | KitchenAid KSM90 Ultra Power Series Stand...

1 Answer

My DeLonghi DSM800 when running sometimes stop for a second and then starts up again. It also seems to speed up at times and almost sounds like it is skipping a gear or something. Any ideas.


I had the same problem and fixed it.
  1. I took it apart, unplug unit, remove the small black cover inside the stand portion, 1 screw. Underneath you will find four screws with a white plastic wire junction.
  2. Loosen two screws and remove the black and brown wires which connect to the control panel with the dial attached.
  3. Remove rear attachment cover, front top cover, and front delonghi cover.
  4. Remove top three screws where the blender attachment goes. Now remove the aluminum cover that covers the entire top.
  5. Slip belt off. Remove three screws with plastic washers that attach motor to chassis.
  6. Remove 2 torx screws that are located next to metal bar that keeps top half from swinging too far from bottom half.
  7. Now you can pull the motor out and the control panel with the dial. Remove the three slip on electrical connections on the control panel and reinstall. Carefully remove the two slip on electrical connections on the motor and reinstall.
  8. Re-assemble and test unit.
I thought I had a problem with the control panel or the motor, as it turns out the connections were the problem. Carefully removing them and reinstalling them solved the problem.

Jan 03, 2010 | DeLonghi 800 Watts Cucina DSM800 Stand...

1 Answer

Can't get the drive coupling off my Bosch Universal to replace it


I have had my Bosch Universal Mixer with the Blender and Food Processor Attachments since 2005, and I've loved it since the day I got it... that is, until the blender broke while my son was crushing ice to make slushies...

I figured out the "drive coupler" was stripped and needed replacing, but I couldn't figure out how to take apart the "blade assembly" which includes the "drive coupler" part...

My retailer, Pleasant Hill Grain, sent me the following email:

"I am not aware of any printed instructions for removing the old coupling and
replacing with the new. We recommend holding on to the blades with 1 hand and a
towel and using a needle nose pliers to unscrew the old coupling. You would put
the new coupling on in the same manner.
If these instructions do not work, I would suggest contacting the Service
Dept at Kitchen Resources in Utah. Their phone is 800-692-6724."

I still couldn't figure out how to take apart the blade assembly, so I did end up calling the distributor, Kitchen Resources...

Dave, the tech @ Kitchen Resources, answered my call on the first ring...

Once I explained my problem, he started giving me the same instructions Pleasant Hill Grain gave
me... I explained to him that holding the blades tightly wasn't working for me.

As it turned out, holding the blades did not secure the drive shaft because
the drive shaft was broken off INSIDE the blade assembly - which is why I could
not unscrew the old drive coupling part.

Dave's next question revealed the true issue at hand... my Blender Attachment has the blade assembly made of plastic - they switched to plastic
in 2005 because the metal assembly turned black in dishwashers.

Bosch just recently went back to using metal for this part - apparently the
plastic blade assembly didn't hold up.

Kitchen Resources - the U.S. Bosch Distributor - is sending me a new blade
assembly - no charge, he said it's covered under warranty. Woo Hoo!

Best of all, I hadn't yet purchased the replacement drive coupling part, because
I wanted to know how to go about replacing the part before ordering a new part.

With shipping this part would have been a $50+ repair - you have to love
customer service of that caliber!

[Aside: You really don't need to ever put this part in the dishwasher - wash
the inside with by putting hot water and perhaps a little dish detergent inside
the blender and turning it on - rinse the outside under the sink... no
dishwasher needed! ]

Mar 23, 2009 | Bosch MUM6610 Universal Series Stand Mixer

1 Answer

Runs fast for a few seconds , then runs very slow


I had the same problem and fixed it.
  1. I took it apart, unplug unit, remove the small black cover inside the stand portion, 1 screw. Underneath you will find four screws with a white plastic wire junction.
  2. Loosen two screws and remove the black and brown wires which connect to the control panel with the dial attached.
  3. Remove rear attachment cover, front top cover, and front delonghi cover.
  4. Remove top three screws where the blender attachment goes. Now remove the aluminum cover that covers the entire top.
  5. Slip belt off. Remove three screws with plastic washers that attach motor to chassis.
  6. Remove 2 torx screws that are located next to metal bar that keeps top half from swinging too far from bottom half.
  7. Now you can pull the motor out and the control panel with the dial. Remove the three slip on electrical connections on the control panel and reinstall. Carefully remove the two slip on electrical connections on the motor and reinstall.
  8. Re-assemble and test unit.
I thought I had a problem with the control panel or the motor, as it turns out the connections were the problem. Carefully removing them and reinstalling them solved the problem.

Jan 06, 2009 | DeLonghi DSM7 Stand Mixer

2 Answers

KitchenAid KSM90 gear stripped?


I just ran into this problem when the PLASTIC worm gear broke and then the mixer would not power on after I replaced the gear. The problem was due to the was I tried to dissasemble the mixer. I removed the two plastic screws near the top center of the mixer when attempting to disassemble. These do not have anything to do with the assembly it turns out the attached square pieces (attached to these screws by springs) must be in the proper orientation to run. I put them in the way it showed in a diagram but it did not work until I tried all four different combinations that they could be rotated. Two of the rotations on the square could be eliminated by closely looking at the end where it contacts the shaft. The round shaft marking will be evident on the square inserts. I'mnotsure how to better describe them, but the are attached by springs to the plastic screws on both sides of the top of the mixer.

May 31, 2008 | KitchenAid KSM90 Ultra Power Series Stand...

1 Answer

Kenwood chef excel attaching blender


http://www.kitchenmanuals.com/manuals/mfg/kenwood/km300_km400_km600_km800.html

hers the manaul for u rate me as fix ya ok its a pdf file also thx nick use adobe reader to view it 43 pages thx agian for using fix ya

Feb 04, 2008 | Kenwood KM400 / KM410 Chef Classic Stand...

Not finding what you are looking for?
Wolfgang Puck Stand Mixer Logo

418 people viewed this question

Ask a Question

Usually answered in minutes!

Top Wolfgang Puck Food Mixers Experts

xalint1
xalint1

Level 2 Expert

150 Answers

yadayada
yadayada

Level 3 Expert

61037 Answers

Lawrence Oravetz

Level 3 Expert

7686 Answers

Are you a Wolfgang Puck Food Mixer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...