Question about Canon Digital Cameras

1 Answer

I have checked the battery and the back up battery are working properly, and have loaded a tape properly, but when I switch on my camcorder ( Canon MV630i ) I get a dark screen with the time and date e.t.c. showing. My camcorder will not play a tape on the L.C.D. screen either.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 684 Answers

May be u can try to use a Camcorder Tape Cleaner disk and Chk

Posted on Aug 04, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi Donald. not sure how many calls you get from


The fault seems to be in the sensor and the mode switch of the loading system which is connected with the main controller processor and loading driver.
This can be a failure of the tape end detector which is a IR - infra red- emitter which is placed in the center of the tape tray and MUST feed continuous signal to the END IR detectors placed at either ends.
Also the tape seems to load with a false detection of the cassette within when the tray is closed for this reason of the failure along with a possible misplaced mode switch settings. This triggers to make the loading move without a reason and so can be due to failure of the the mode switch or unbalanced settings.You will need some experience to remove the tray unit, then check on the IR sensors and also check the settings of the loading drive and mode switch.

Nov 27, 2011 | Digital Cameras

1 Answer

My Sony DCR-TRV240 camcorder won't eject the tape. The power and all camera features work, but it won't eject a tape.


I'm sorry that the Camcorder is not ejecting tape. Please follow the troubleshooting steps provided below and check the operation:

1. Please make sure that the battery is fully charged. 2. Perform Reset by following steps:

1. Locate the RESET button behind the LCD panel of the camcorder. 2. Use a pointed object (like a ballpoint pen) to press and hold the RESET button for 2-3 seconds. 3. After 2-3 seconds has elapsed, release the RESET button.

3. Perform a manual power reset by following the steps:

1. Turn off the camcorder. 2. Disconnect AC power adapter. 3. Remove the battery pack. 4. Move the POWER switch to the CAMERA position for 15 seconds. 5. Move the POWER switch to the OFF position. 6. Reconnect the AC power adapter or reinsert the battery pack. 7. Turn on the camcorder.

If the issue persists after following all the steps service will be required. You can find repair information and initiate service at:

http://fixya.com/repair

Thank you for using Fixya. Please let me know if you require any clarifications.

Sep 01, 2011 | Digital Cameras

1 Answer

My camcorder does not come on. When I put the battery in the screen comes up, then shuts down. This is with a new battery and charged. Also, when you open the tape holder, it appears that you can see...


Your camcorder might have an internal problem. As long as you know that your battery is charged and working properly. To make sure you can connect your camcorder directly with the power supply and try to turn your camera on. If that still doesn't work i would contact manufacture and hopefully the camera is still under warranty. They will help you further.

Mar 20, 2011 | Digital Cameras

1 Answer

We put a new tape into the cam corder and the screen has turned blue. What can we do?


Hi, first check with old tape that the tape is getting played or not. If its working fine there may be two problems with the new tape:
1. Either the tape not inserted properly.
2. Or the tape is defective.

Also, try to clean the head of the camcorder with cotton bud before inserting the tape. If nothing works from the begining. The head of the camcorder is to be shown to the service centre for checking the correct operation.

Hope ur problem gets solved in the very beginning.

Mar 15, 2011 | Digital Cameras

2 Answers

My canon vixia hv30 camcorder is not reading tapes anymore. It rewinds and forwards and reports the tape position but the tape counter does not roll showing only dashes as if the tape is empty. All this...


Hi,

It sounds like the tape itself is damaged. Get an head cleaner cassett and clean the mechanism. This will clean the wheels and heads that tape runs over. Also try a new tape cassett to see what happens and listen to the camcorder for any crunching sounds as this would suggest that something has broken inside the camcorder.




Good luck.

Jun 29, 2010 | Digital Cameras

1 Answer

How to rewind the tape on a MV600i Cannon mini camcorder,I do not have a manual.


You can get a copy of the user manual from here:-

http://camera.manualsonline.com/manuals/mfg/canon/canon_mv600i_8432a009aa.html

Or you could switch the camcorder to player mode and press the _/<< button just above the screen.






Apr 18, 2010 | Canon Digital Cameras

1 Answer

Ixus75 battery cover out


It's broken already.. Try to use magic tape or what they call it a quick release tape band.

Aug 17, 2007 | Canon PowerShot SD750 / IXUS 75 Digital...

Not finding what you are looking for?
Digital Cameras Logo

Related Topics:

43 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Digital Cameras Experts

Doberman

Level 2 Expert

246 Answers

Tony

Level 3 Expert

2598 Answers

halotheracer
halotheracer

Level 2 Expert

68 Answers

Are you a Canon Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...