Question about Ignition System for Mercedes-Benz B-Class

1 Answer

Hi: my b200 wont start if it has been running for a while, no alert messages, if it's cold it starts up fine, just had oil change, filter etc. Could this be the cause, I know in the MB workshop they will say it's the whole ignition sistem and charge me $2000, but may be something different. Thanks

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,066 Answers

Its your fuel injector system, and it will be expensive. look for a junked model that you can salvage from.

Posted on Mar 26, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 Ford Mustang GT, CAR STARTS UP FINE WHEN COLD. Hard to start when warm No Check Engine lights come on.


Think about how the vehicle is acting. Starts fine when cold, hard to start when warm. In these computer operated systems, the computer runs everything. Starts fine when cold: the computer has the engine in cold start mode putting more fuel in till it warms up. Temperature sending unit in the manifold sends a message to the computer telling it to stop the cold start mode and it stops dumping excess fuel into the cylinders and it runs fine. IF, mind you, IF the temperature sending unit is faulty, it's not telling the computer to stop the cold start mode and is flooding the engine with fuel cause it's sill in cold start mode. This is my take away on your situation and the temp sending unit is something to check to be sure it's functional. Check it out. I hope this WAS the answer to your problem my friend. It's typical. Luck to'ya Bro.

Jun 06, 2017 | Ford Cars & Trucks

1 Answer

What does a loud clicking noise indicate that seems to quiet as the engine warms when cold starting a fuel injected dodge pickup indicate


The oil may be to thick or a partially blocked pick up (check the sump for a big dent) Lack of oil changes will also cause it as the oil starts turning to sludge & partially blocking things. As the oil warms it gets thinner allowing it to pass around the motor easier. I DON'T recomend the oil flushes. The motor may have to be partially disasembled eg: sump off to clean pickup or tappet cover off to replace lifters etc... Start by changeing the oil & filter with the recomended grade.

Jun 27, 2012 | 2005 Dodge Dakota

1 Answer

91 diesel trouble starting chevy suburban


I would be more suspicious of the fuel system. Have you changed the filters lately? Do you have a 6.2 or a 6.5?

Aug 10, 2009 | Chevrolet Suburban 1500 Cars & Trucks

2 Answers

Will start up run for awhile then stall and wont restart


Hello, I would start with a general tune up. Spark plugs and wires, Fuel Filter, Oil Change and Filter Change, Air Filter Change, Some injector cleaner would not hurt eirther. Be sure to lubricate your high mileage car and also use a farily good oil for your motor as well. The run for awhile problem sounds like bad spark plugs. I would change your spark plugs, wires, distributor cap, and rotarty button.

May 20, 2009 | 1993 Honda Accord

1 Answer

No cold start


in cold tems you need to make sure that you use a block wormer it will help alot

Feb 02, 2009 | 1996 Ford F250 Crew Cab

1 Answer

Starts fine when cold, after running dies on idle then wont start


Sounds like the fuel filter is dirty and needing to be changed. It's cheap and easy to swap out.

Jan 12, 2009 | 2002 Land Rover Discovery Series II

Not finding what you are looking for?
Ignition System for Mercedes-Benz B-Class Logo

Related Topics:

453 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Vehicle Parts & Accessories Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Timllfixit

Level 3 Expert

2210 Answers

Are you a Mercedes-Benz Vehicle Part and Accessory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...