Question about Audio Players & Recorders

1 Answer

Technics SU-g75 Amplifier. No longer any volume. Fuse is OK, display is fine, just no volume??

Posted by on

  • Anonymous Nov 24, 2008

    what tayp of fuse does a technics Su-G75 amplifier use

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

ALL speaker jacks must be loaded and closed for any sound to come out of this system. Missing one speaker, or one bad connection and you will get no sound or some will work and some will not. speaker wires need to go deep into speaker jack holes.

Posted on Oct 12, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Technics SU-G75 owners manual download


http://www.manualslib.com/manual/926367/Technics-Su-G75.html?page=2#manual Technics SU G75 Service Manual Page 2

Sep 23, 2015 | Technics SU-G75 Amplifier

1 Answer

Want to download Technics SU-G75 service manual


Technics will not give it to you. Gotta pay the piper!

Did you try to google it - might get lucky - but don't hold your breath.

Sep 21, 2015 | Technics SU-G75 Amplifier

1 Answer

Ok I have a technics integrated receiver su-g75 it


The amplifier power transistors could be bad, the speakers can be muted or a fuse for the speakers could have opened.

Aug 28, 2014 | Audio Players & Recorders

1 Answer

Technics sl-eh790 repairs


No longer supported device. Check with your local RadioShack for repair!

Mar 23, 2014 | Technics SU-G75 Amplifier

1 Answer

Technics SU-G75 has no sound


Hello
when the resistors are burned,means that the transistors are damaged, or the power module is damaged.
and in your case its the power module.
Hope this helps.


23392686-biweyzzz1swyjlxgbbebmoak-5-2.jpg

Feb 07, 2014 | Technics SU-G75 Amplifier

2 Answers

Technics su-g75 amp goes to loud static after a few minutes


Hi Aawpharmd,

system control error.
please go for repair shop.
regards,
nuwan

Jan 13, 2014 | Technics SU-G75 Amplifier

1 Answer

Speakers for Technics SU X933?


check given link for speakers
http://www.fixya.com/myhome.aspx#Answers

Jun 05, 2012 | Technics SU-G75 Amplifier

1 Answer

I have a technics amplifier SU G75


I have a technics too, and faced the same problem. The solution is very simple just ensure the +ve and -ve wires are connected correctly for each speaker to the amp. Eg. red wire to the red knob and black wire to the black on both ends. sometimes this arises because the wires are of just one color however there will be some marking on the wire to indicate which is +ve and -ve. This took care of the overload problem.

Jun 18, 2009 | Technics SA-AX530 Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

554 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

4861 Answers

The Knight
The Knight

Level 3 Expert

72670 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...