Question about Little Giant WGP-65-PW 1/8 HP, 1900 GPH Premium Dual Discharge Pump, 16' power cord

1 Answer

My Little giant wgp-65-pw has been sitting idle in the water garden for a long time, how can i clean the alge from the intake.?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 56 Answers

I would suggest soaking it in a 5 gallon buckets of water with a cup or so of bleach added. This will kill all the algae and release most of it from the pump. Follow with a through rinse with water and you should be good to go.

Posted on Mar 24, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Little giant wgp-65-pw has tripped my gfi repeatedly. any idea why? No shorts in the cord are apparent


if a pump connected to a gfci outlet trips , then the gfci has detected a high resistance "shortage" inside pump and has disconnected power , this "shortage" can be nearly in detectable from human standards(shock) , but gfci picks it up
most likely pump seal has failed and water has gotten inside pump !! it only takes one drop to do this !!

Dec 24, 2012 | Little Giant WGP-65-PW 1/8 HP, 1900 GPH...

1 Answer

Problems priming little giant pw-95 pump


since this is a waterfall pump , id try using a short piece of dish hose and see how it flows water then , if it works there then id say your demand to lift is too great and a larger pump will be needed to lift that high ,

also note on waterfalls id leave out the ck valve on dish pipe , i know it takes longer to reprime itself each time , but that reverse flow action cleans your intake screen each time it shuts off

May 12, 2012 | Little Giant Wgp - 95 - Pw Pond Pump -...

1 Answer

I cleaned the screen, and the impeller is working however the little giant pump WGP is still not pumping water.


You may need to take the bottom of the pump apart and check to see if any thing has gotten through the screen and clogged the impeller.

Nov 27, 2010 | Little Giant WGP-65-PW 1/8 HP, 1900 GPH...

1 Answer

Little Giant pump WGP-90-PW trips GFI circuit


You might have 2 problems. The GFIC might be wired wrong or the pump wirng might be compromised with moisture. The noise issue? Are you running this unit without submersing it? They will burn out if you do. To get a more accurate running sound, submerse it with a flexible pipe so you can run it in a 5 gal bucket without losing the water.
It's possible a bearing is burned out.
Ron

Jun 10, 2010 | Little Giant Plumbing

1 Answer

Pump plugged in to grounded receptacle trips the


If by "trips the breaker" you mean the GFI then you are leaking current to ground, GFI's trip when there is an imbalance between the current going to the motor on the HOT side and returning from the motor on the NEUTRAL side, if it is tripping the GFI it is likely the sign of a failing motor.

May 27, 2010 | Little Giant WGP-65-PW 1/8 HP, 1900 GPH...

1 Answer

Little giant pond pump wgp-65-pw turn it on and it runs for about 1 min. then shuts off for seconds and then back on for a min.


the magneto has gone in the pump,replace the pump as its cheaper than the repair would be.
try a hoselock pump

Dec 20, 2009 | Garden

1 Answer

Anthony filter system faulters after short while of running


If you have alge in your water it builds up in the filter and stopps it up rite away. You will need to take the filter apart again and hand clean it out again. but you will need to super chlorinate the water and kill all the alge before you start the pump or it will plug again. If you run it like this for any amount of time it will crush the grids, so be sure you kill all the alge.

Oct 13, 2009 | A.B.S ALADDIN GO-KIT #7 ANTHONY POOLS 2"...

Not finding what you are looking for?
Little Giant WGP-65-PW 1/8 HP, 1900 GPH Premium Dual Discharge Pump, 16' power cord  Logo

Related Topics:

150 people viewed this question

Ask a Question

Usually answered in minutes!

Top Little Giant Garden Experts

J.D. Browning
J.D. Browning

Level 3 Expert

2760 Answers

Mike Squire

Level 2 Expert

391 Answers

john h

Level 3 Expert

12104 Answers

Are you a Little Giant Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...