Question about Velodyne FSR-12 Speaker

1 Answer

I have 2 velodyne fsr 12 subs. both were taken out by PG&E power surges. One make a white noise that cuts in and out, but will still play bass when fed a signal, the other makes a loud static sound that cuts in and out.

Posted by on

  • Iron
    Iron Mar 24, 2011

    Ouch, how can I help? What is the problem you need solved?

  • edubuu Mar 24, 2011

    In reply to Dunnbiker...I arrived at the conclusion the amps were shot pretty quickly. Both subs make noise with or with out any input. Velodyne does not service these subs any longer. I was hoping to find out if the IC amplifier, PN STK4040 II, could be the culprit. That amp only costs about $20 so maybe I will give it a try. Thanks for the help.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 8,546 Answers

Register and download the manual for free at retrevo.com

http://www.retrevo.com/support/Velodyne-FSR-12-Subwoofers-manual/id/866ag600/t/2/

Not that it would help.

Is the white noise present in the absence of an input connection, free-floating?

The amps in both of them sound like they

Posted on Mar 24, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My radio cuts out when i turn it up and the bass hits on my subwoofer


You are drawing to much power to the amp. I assume that there is no dedicated power fron the battery to the amp. If there is you should look into a capacitor

Feb 13, 2013 | Car Audio & Video

1 Answer

Velodyne SPL8R - same problem...


The first thing to do is unplug it, then pull the sub out of the cabinet, then pull the amp out of the cabinet. If you can take out the amp w/o taking out the sub, great. If there are any exposed printed circuit boards, look for dust buildup. Sounds like you've got alot of static energy built up in the internal electronics. If you have to disassemble the casing to get to the circuitry, do so, just do it carefully. Look at the boards. If there's alot of dust, get some printed circuit board cleaner.(pcb) cleaner found at Radio Shack. Then spray off the boards and the subs volume control as well as the crossover control. This will Not hurt any electronics.Re-assemble and test. If you still have noise: Take a careful look at the input side of the amps circuits and traces, if you have a magnafying glass it helps. What your looking for is a bad solder joint. You will see all the little dimples on the boards from soldering at factory. When you look at the solder point, look for a circular ring generally midpoint on the solder or right at board level. This can take some time, however, it's free and it's more than likely the problem. To fix a cold solder joint you need a fine point solder gun, just touch the point that is bad and it will re-seal, then test. Plug n Play. Hopefully it's just dust and you don't have bad solder joints. Velodyne makes an awesome product!, very rarely do I see problems with them. If you need some more help with this, post a comment and we can dig further. Hope this helps

Jun 08, 2009 | Velodyne DD-10 Subwoofer

1 Answer

SPL8R Velodyne sub - Same probelm


Go to the Velodyne web site and check the service center locations.

They may have one in your area.

It sounds like the amp may be the problem. That may be all you need to send.

Best bet, Contact Velodyne.

Jun 08, 2009 | Velodyne HGS-10 Subwoofer

1 Answer

Crackling coming from Velodyne DD-10 subwoofer


One of 2 things is going on.

First, the servo mounted in the driver may be going bad or is picking up some noise.

Second, Something in the amp section is going bad, hard to pinpoint the exact problem.

you say that it plays, so I tend to think it is the driver mounted servo unit.

If it is within the warranty time, take the unit back to the retailer you purchased it from, if not contact Velodyne for repair.

Mar 18, 2009 | Velodyne HGS-10 Subwoofer

1 Answer

Subwoofer


Yes you do as this is were it gets the information from to play a bass line or effects from a film,if you dont have a amp or receiver you have a coffe table.
hope this helps.
CABLE GUY.

Jul 03, 2008 | Velodyne DPS-12 Subwoofer

1 Answer

AMP FOR SUB SHUTS OFF SOMETIMES


your amp may be overheating, or you have it up too loud and the surge protector is shutting it of in fear of damage to your amp.

Apr 24, 2008 | Kenwood KAC-7202 Car Audio Amplifier

2 Answers

Major buzz/Humming sound coming from my subwoofer


Well there are only a few reasons i can think of that just might be the reason behind said buzzing.

1. It may be connected to another power source ( amplified or powered supply ) or incorrectly connected. It may also be too close to said power supply.Try letting the dog (sub) out on his leash a little Drag out the manual that came with the sub, and check the correct procedure for your type of setup.
**People do read manuals still don't they ?**

2.The only other problem i have heard of is port noise in low registers. Keep the the port area clean, as it may suck up dirt, or even worse, small children!

3. However, if you're considering placing this subwoofer in a cabinet, I'd recommend allowing ample breathing room for the heat sink. This can also be done by drilling smaller holes in the cabinet ( 8-12 mm holes - with the owners permission of course) but please do remember to keep the port area clean.

4. The product ie: Velodyne DPS-12 Subwoofer, came with a bad power supply, presuming it is new, check your warranty.
(not very likely - see also scenarios 1, 2 or 3.)

Velodyne has been making subs forever and do it well.


Jan 17, 2008 | Velodyne DPS-12 Subwoofer

1 Answer

Need help


u should connect at least six 12" subwoofers (preferably 1000W each) to that pioneer amp of yours. Crank it up and enjoy. Your amp shouldn't cut off now. If it does cut off, you should change the fuse on your amp to a higher ampere.

Oct 30, 2007 | Pioneer GM-7200M Car Audio Amplifier

2 Answers

Amp cuts off


You may have a problem with the power source feeding the amp. You need to check the voltage across the amplifier's B+ and ground terminals when the amp is playing/cutting off. If it's dropping below ~11 volts, you need to determine why it's dropping so low.

Sep 18, 2007 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

Not finding what you are looking for?
Audio Players & Recorders Logo

281 people viewed this question

Ask a Question

Usually answered in minutes!

Top Velodyne Audio Players & Recorders Experts

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1667 Answers

Are you a Velodyne Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...