Question about AudioBahn A8000T Car Audio Amplifier

1 Answer

My amp will come on like far as light up but the power light will not come on and nothin is comin out my subs

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 5 Answers

Check your ground and the connection to your fuse blocks.

Posted on Mar 23, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My power acoustik bamf 2200 amp keeps blowing its fuses, why?


another couple of things is a bad ground wire. a sub going bad( causing a different ohm load then before) ive run into a bad fuse link in the amp before as well

Aug 04, 2014 | Power Acoustik BAMF2000/1D Car Amp

1 Answer

Sub system won't play can't find in settings amo hooked up to subs yet still nothin help plz


Is the amp switching on? There are two 12v wires that have to be connected. One from a direct constant 12v supply source, and the other one from the ignition switch 12v source.Find a single 12v. supply which you can take from the lighter connection and then trace a 12v wire that runs from your ignition switch. This is mentioned in the amp manual.Double check. If the amp is coming on but no sound, then your wire connections from the amp are not correct.Or you have also connected the speaker wires incorrectly.Remmember not to connect the earth of the speaker wires to the direct earth(body of the car) but to the earth wires that are shown in the manual as this could blow the amp power IC. The earth wires of the speakers are marked -- and + respectfully and are also colour coded.You should have a RCA female plug connector from your amp to the subs. Check everything double and if still no luck their is a possibility that you could have blown an IC in the amp from wrongly connected wires. Hope this is not the case.

Apr 15, 2013 | Car Audio & Video

2 Answers

Hey i dont know to much about amps, but me and my friend (he knows a decent amount about amps) would plug the power into the amp and the green light would come on. Though when we plug it into the subs, the...


Are you connecting positive to positive and negative to negative from the sub to the amp? If so, try positive to positve (+) in the far left channel and then the negative to negative (-) on the far left channel to. If no luck do the same in the other channel with one sub at a time. Try one sub at a time, Dont try an connect 2 or more subs to one channel as this would cause the amp to go into protect mode (red light you describe). Usually the positive wire has either a line down the wire, writting on it or has a red seperate wire with it when wire end stripped to connect it. Hope this helps and please rate...

Mar 11, 2011 | Bazooka EL1500 Car Audio Amplifier

1 Answer

I got a sony xplod amp 1000 watt everything is connected good the ground wire is on a bare metal surface 12v wire good power fuse ALL wiring is as it should but there is no bass? the green light is on but...


Open your sub-woofer and check the continuity of your bass speaker. Chcek also the fuse of the sub-woofer amp...the fuse might be busted already.

Jun 05, 2010 | Car Audio & Video

2 Answers

00 kawasaki ninja zx6r my bike don have no power, no lights or horn, nothin is comin on whats wrong , i check battery and fuses plus starter relay everythin is ok i just dont have no signs of power, thanks


Hi and welcome to FixYa,

I understand that you have checked the:
  • battery - that it is fully charged and that the cables & terminals / connectors are clean and tight;
  • fuses - including the 30 Amp main fuse;
  • starter relay - there is +12 on the white wire.
Should the above hold true, then the only remaining components to suspect / check would be the always on +12 connectors and/or the ignition switch.

Good luck and thank you for asking FixYa.

Nov 18, 2009 | 2001 kawasaki ZX-6R Ninja

1 Answer

Kac-8152d powers on, but no power output to subs


Well, the sad thing is, it can be a number of things. You will have to do a process of elimination. Try replacing the amp first, borrow one off a friend. Second try replacing the subs. If those don't work, read the manual to your deck. Find the audio settings, and check to see if the sub section is "on".

Jan 29, 2009 | Kenwood KAC-8152D Car Audio Amplifier

1 Answer

Not working


maybe you should use 4 awg wire

Jun 24, 2008 | Rockford Fosgate Punch P5002 Car Audio...

1 Answer

High pitched noise comin out the sub


You may have a ground loop issue. Make sure your ground lead is as short as possible (<1ft, if possible) and that it is mounted to a nice, clean (unpainted) spot on the vehicle. If you have multiple amps, try and ground them to the same point.

Mar 07, 2008 | Fusion FEW12PK Car Subwoofer

1 Answer

Alpine MRP-M650 problem


The built in power supply is probably bad. This supplyds the voltage from the 12volts and inverts it up to 20 to 30 mvolts DC. You will need to get a manual to service this unless you know the inverter circuit really well. good Luck

Jun 30, 2007 | Alpine MRP-M650 Car Audio Amplifier

Not finding what you are looking for?
AudioBahn A8000T Car Audio Amplifier Logo

Related Topics:

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

xxxxxx xxx

Level 3 Expert

4874 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8575 Answers

Are you an AudioBahn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...