Question about Car Audio & Video

Open Question

Where do i plug my phono cables into my xs liberator 600w amp as it only shows a red protected light

Posted by on

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 155 Answers

SOURCE: 2 12" subs + 600W amp. Turn on, goes boom once, then red light

Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

Posted on May 13, 2010

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Red protect light flashes continually. Whats wrong with my xs 600w


Does It blink as soon as you turn system on? First thing i would do is make sure everything is off, then unplug speak wires from amp then turn back on. If it doesnt blink then spk wires or sub(s) have a dead short somewhere. Let me know

Jun 12, 2016 | Car Audio & Video

1 Answer

How do I get sound from TV using headphones.


The red & white phono/RCA sockets are a sound input TO the TV. They are not a sound output FROM the TV.

Sep 06, 2014 | Televison & Video

1 Answer

Acoustic b600h


Relay?? I've never seen a guitar or bass amp with "speaker protection relays"...usually they're either on or off. Check the simple stuff 1st...is speaker cable from head to cabinet and/or the input cable from bass to the amp good? Check the "Direct Out" for a line level signal (must be connected to a PA or other amplifier) as this is your preamp out signal. Also, plug a shielded cable from "Effects Send" to "Effects Return"...this will verify "effects" loop issues if any. Lastly, vibration test...use a clenched fist across the top, sides and bottom of wood cabinet to lightly "jar" the internal circuits. If it starts working even for an instant, I would suspect intermittent connection inside.

Jul 30, 2014 | Acoustic B600h 600W Bass Head And B115neo...

1 Answer

My Pioneer PL-990 Turntable only outputs sound through the white wire. Only a quiet buzz comes through the red wire.


The red wire is the right channel, so going back to your amp, get a single phono plug with with the wire exposed, so you can touch the wire. Then remove the turntable connections. With the amp on plug the the lose wire plug into each channel and check if the sound on the right is still low. If it is then there's a problem with the magnetic cartridge pre-amp inside the amp. They are often located near the phono socket on a seperate PC board, but if not just follow the red wire to the main board. Chances are it will be an IC that's failed.
If it has a strong buzz at the back of the amp. Then I should replace the wire between the turntable and the amp. Or the right phono plug that connects to the amp.

Nov 13, 2010 | Pioneer PL-990 Turntable

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

1 Answer

When i turn it on the green light turns red and it wont play


you should check your cabling and make sure your ground cable is connected properly to the chassis on a part where it makes contact with bare metal. your amp is going into protection mode, but its mostly caused by incorrect cabling or contact

Jul 29, 2009 | Sony Class AB 600W Bridgeable 4-Channel...

3 Answers

My red light on my amp is on and wont go out


Unfortunately I think you need to get it repaired or replaced .When a protection light will not turn off it is generally caused by an internal short and needs one or more replacement parts for it to come alive again.
-Dynami

Apr 03, 2009 | Insignia 600W Bridgeable Amplifier with...

1 Answer

Amp on "protect" mode


Hi, what you need to do is unplug all the connections to the amp. The amp goes into protection when the circuitry over heats.\
First decrease all your gains to minimal volume.
Connect your 12+V, remote, and ground.
See if the protection light comes on then.
Next plug in your RCA cables.
Check protection light.
Then plug in your subwoofer cables.
See if you are still in protect mode.
Hopefully everything works alright again.
Just slowly increase the gain to see what the cut-off is. Make sure you aren't dropping the ohmage too low on the amplifier. Check manual for correct wiring and such.

Feb 08, 2009 | Phoenix Digital PD-394 Car Amp

1 Answer

Amp Issues


1800W peak output at 2 ohms
975W peak output at 4 ohms
600W RMS (continuous) at 2 ohms
325W RMS (continuous) at 4 ohms
Variable LP crossover adjustable 35-250Hz
4 AWG power/ground inputs and RCA pass through
Low-pass filter
Bass boost 0-18dB adjustable remote punch bass EQ
Signal-to-noise ratio: >80dB
Line-level input


It is going into protect mode for a reason.
Disconnect the subs and turn everything on again. If the light comes on, the problem is internal and will need servicing by a technician.

Dec 22, 2008 | Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

Amp Not working!


If the amp goes into protect mode, it's likely due to shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

If the problems are not with the wiring, follow the link at the bottom of the page to the Amplifier Repair Primer page.

Let me know if you have any other questions.

Sep 20, 2008 | Power Acoustik TS620-2 Synchronized...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

73 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4944 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

79865 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...