Question about Dyson DC07 Bagless Upright Cyclonic Vacuum

1 Answer

The flexible hose has very little suction. The filters have been changed and can't find any blockage so don't know what else to try.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 643 Answers

Remove all housing from bottom clear any clogs.

Posted on Mar 21, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Model c87-vc-b lost suction despite on max setting, no blockage.


Yes, if you have not cleaned or replaced the filters, do that. clogged filters will kill the suction.

Apr 25, 2015 | Vacuums

1 Answer

No suction for the hand tools


If your suction is ok for normal cleaning and bad for just the hand tools then you have a blockage in the flexible hose or the "u pipe" at the bottom of the flexible hose. Un-clip the u pipe and check it for blockage. Un-clip the hose from the vacuum and you should be able to look through it when letting it hang straight down.

Hose removal here
http://www.youtube.com/watch?v=NfZlHIFlwJc
.

Feb 23, 2014 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

Suction stopped. Roller and belt working-in fine order. Checked hoses have not found any blockage. Blowing out air or sucking so little can't feel it with hand on hose end. Help!


Either a blockage or the main air filter is blocked , some it can be washed and others it must be replaced

I would check the owner manual and look at the filter, foam ones can and usually have instructions where they install to wash them.

Dec 11, 2012 | Hoover Tempo Widepath Upright Vacuum -...

1 Answer

Miele Callisto keeps turning itself off and has poor suction


Hi there, You don't actually specify how long it takes to turn off but this is normally due to a blockage in the hose or due to excessively dirty filters. Given that you have said the suction is low i would be inclined to think you have a blockage in your hose. Remove the hose and test suction of the machine again. If you have a notable improvement it is telling you something is stuck in the hose which you will need to remove.

May 22, 2012 | Miele Vacuums

1 Answer

Hi, my Bissell 3920 has lost almost all of its suction. I checked the hoses and tubes but did not find any blockages. Filters are clean. Thanks.


Hi, Have you checked and made sure the floor plate is secure and tight without any gaps around the edges? If that's ok then check the suction hose where it bends down to the floor unit,, lots of times dirt,hair and stuff collects there when the filter was plugged up. remove the floor plate ( like you were going to change the belt ) and use a wire coat hanger to run up the suction hose and back out and clean out any debris, also check the entire hose for blockage ( top to bottom ). if this is all clear and you still have little suction - then the problem could be the vacume motor itself

Nov 27, 2011 | Bissell 3920 Bagless Upright Vacuum

2 Answers

I have changed the hepa filter & made sure the washable filter is clean. I checked the brush & it's working fine. The indicator is still red very little green. Not suctioning good at all. What...


check the suction hose where it bends down to the floor unit,, lots of times dirt,hair and stuff collects there when the filter was plugged up. remove the floor plate ( like you were going to change the belt ) and use a wire coat hanger to run up the suction hose and back out and clean out any debris, also check the entire hose for blockage ( top to bottom ). if this is all clear and you still have little suction - then the problem could be the vacume motor itself and you will need to take the unit into the repair shop and have the motor rebuilt or replaced.

c..

Feb 02, 2011 | Bissell 3920 Bagless Upright Vacuum

2 Answers

I have a Hoover Wind Tunnel Self propelled 12amp. There seems to be very little suction. I have cleaned the hoses and filters but still not much suction. any ideas? thanks.


Make sure all filters are cleaned out and entry ways are clear of all debris. Remove hose and check for blockage. Usually the low suction can be remedied when all filters are cleaned. Hope this works for you.

Jul 17, 2010 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

No suction


well, it actually sounds like there is a blockage. Try removing your hose and dropping something through it, like a quqrter. If it comes through, no clog. If it is clogged, I believe that machine has a blower on the upper part of the cleaner (maybe in the bag compartment towards the top. You can take out the filter holder and plug the hose in there and run the unit . Does the blockage come out? If not, Try shaking the hose, or you can put a stiff wire in it to try to free it. Do not run water through it. If there is no blockage at all, then you will probably need to take it to a service center. But I am pretty confident that we are looking at a clog situation. Let me know if this fixesya! Thanks, Rene (vacuum Doctor)

Nov 14, 2009 | Miele S514 Solaris Electro Plus Vacuum

1 Answer

I have little suction when using the hose attachment


Check the hose for a blockage. If you remove the hose, if there is suction at the point where the hose hooks to the back of the vac, then the hose is clogged. If no suction there, check filters, make sure they are clean.

May 31, 2008 | Hoover Company Wind Tunnel U53019 Upright...

2 Answers

Hose has very little suction


ok dont know but if you havent already where the roller sits underneath it where the dirt sucks threw i had a problem a little like yours i did every thing you did same thing happened.but i had a clog in the vacuum i used a pressure with out the dirt canister on i blew out a real nice hairball.after that i tried it and what do you know it worked. hope that helps

Jan 05, 2008 | Bissell 6594 PowerForce Bagless Upright...

Not finding what you are looking for?
Dyson DC07 Bagless Upright Cyclonic Vacuum Logo

Related Topics:

49 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dyson Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

Nick Olsen

Level 2 Expert

183 Answers

Are you a Dyson Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...