Question about Philips Avent® Scd510 Dect Baby Monitor

Open Question

The baby unit seems to work fine, I just have a problem with the parent unit. I leave it plugged in so it is always on charge, although I usually switch it off if he's not in his room. However, when it is on, it will sometimes just switch off. Like, with neither of the lights showing, not the 'link' light OR the 'battery' light (although it's still plugged in). It also doesn't beep or anything before it goes flat if I unplug it... it will flash battery light at me a couple of times, but that's pretty hard to notice if you're doing something. Is this normal?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 12 Answers

SOURCE: Philips Avent SCD520 Baby monitor interference

cold be intefernce from any other electronic device... potentially at a neighbours. even though mifddle of the night, could be microwave, kettle, electric blanmket, heaitng system, etc etc ... any appliance. If on the 2.4ghz wavelength could also be a computer wireless network nearby? good luck with finding and isolating - worst case, take it back and get one on the 1.8ghz ... which is reserved for these devices, and cordless phones, etc

Posted on Sep 01, 2009

Babycare_nl
  • 21 Answers

SOURCE: 1- The baby unit doesn't

Your issue #1 seems like a power adapter issue. Please swap the sender and receiver adapter and see if anything changes. Mark them with a sticker or felt pen before you do this because they probably are identical.
Your issue #2 seems like you have defective batteries, although I don't understand 'doesn't open'. The receiver uses standard NiMH cells that can be reached through the back battery compartment. You could swap them out and test.
If the set is still within warranty I suggest you take it back. Within the warranty period you usually get a replacement.

I hop this helps.

With kind regards,
Babycare.nl
Erwin de Raad

Posted on Sep 16, 2010

  • 1 Answer

SOURCE: battery in parents monitor won't hold a battery

We had the same exact problem, tried replacing the rechargeable batteries but to no effect. We called Phillips directly and they were very nice and are shipping us a replacement unit (they discontinued this model and I suspect this is a known issue).

Posted on Nov 17, 2010

joeguest2
  • 2080 Answers

SOURCE: I own an Avent SCD

First of all, here is the main ONLINE SUPPORT page for your model:

http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?ctn=SCD510/00&scy=gb&slg=en

And here is a direct link to the ONLINE USER"S MANUAL for that model:

http://download.p4c.philips.com/files/s/scd510_00/scd510_00_dfu_eng.pdf

To view the Support Page or the Owner's Manual with Operating Instructions just use your mouse to click on the link, which is the underlined and highlighted text just above. This will open a new web browser page automatically for you and allow you to view the information at the website indicated or the contents of the Owner's Manual.

You may need ADOBE READER installed on your computer to read PDF documents.
You can download this free at WWW.ADOBE.COM if necessary.
Click on the DOWNLOAD ADOBE READER button on right side of the ADOBE home page when you get there.

The baby and parent units may be out of range of each other. Test that the two are still actually connected and functioning, and decrease the distance between them if necessary. See page 9, of the ONLINE USER'S MANUAL under USING THE APPLIANCE for detailed instructions on how to establish a connection the parent unit and the baby unit.

The baby unit's microphone level may be set too low. See page 11 of the User's Manual for instructions on how to adjust the sensitivity of the baby unit microphone.

If your system will still not function properly, you can try a RESET on both units by following the detailed instructions on page 11 of the User's Manual under RESET FUNCTION.

Please comment back here to this page if you have any questions, have difficulty accessing the links, or just require further general assistance and I will respond as soon as I see it.

If this was at all helpful please click on the 4 Thumbs Up helpfulness rating icon you see on this page.

Thank you very much and good luck.

Joe.

Posted on Mar 03, 2011

  • 1833 Answers

SOURCE: I have the Philips Avent

Will reply soon.

Posted on Apr 06, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have tomy classic baby monitor from a year now, from few days parent unit is beeping continiously, have checked connection and evrything and even the green light does goes red


The unit may have a back-up battery installed that is low on charge. Replace the back-up battery. The unit is probably still working because you have it plugged-in.

Sep 17, 2014 | Baby Gear

1 Answer

Why won't my Parent Monitors work on battery power using new batteries, but will work fine on AC power?


Always be sure the batteries are charged and suited for your device.
Check contacts of the batteries and in the battery compartment of your device. Dirty or oxidised contacts can be cleaned with a dry cloth, or a cotton swap. Never use sharp tools to clean contacts or anything in or on electronic equipment.
Always charge batteries before using it for the first time, or if you have not used it for a long period. 3 months is a very long period.
Always charge sets of batteries (2 or 4) together.
Do not use alkaline batteries unless it is absolutely necessary. In some cases, alkaline batteries may have a shorter service life than NiMH. Alkaline battery performance is limited, especially at low temperatures. The use of NiMH batteries is recommended.
Never use manganese (Zinc-Carbon) batteries in electronic devices.
These batteries are only to be used in flash lights.

Jul 27, 2014 | Safety 1st Baby Monitor

1 Answer

Base not charging parent monitor


The rechargeable battery will need to be replaced.

Mar 20, 2012 | Angelcare Ac401 Deluxe Baby Movement Sound...

1 Answer

Although my bt baby monitor 150 units are fully charged and within range they still will not link up. They have worked perfectly until yesterday. I have tried doing a factory reset & taking the...


I had the same problem, have just spoken to BT (helpline is 0808 1006554) and they advised this is how you re-link the base and parent unit.
1. Switch both units off
2. On the base unit press volume up (+) while turning on the unit. The word "registration" should appear on the display.
3. Then on the parent unit, press the power on and then as soon as all the lights come on, take your finger off the power button and press the volume up (^). The word "registration" should appear on the display and then the units should link.
It's a bit of a fiddle getting the parent unit to re-register and they both need to say "registration" at the same time, but we got it after several attempts, and now they are working fine.

Apr 16, 2011 | Toys

2 Answers

My graco monitor has one red light and a row of green, instead of all green, and it is not making any sound anymore


Try pairing the parent and nursery units again. First, turn off all of the units. Place the broken parent unit within 5 feet of the nursery unit. Turn on the parent unit. Turn on the nursery unit. Within a few seconds, the top 4 green LEDs should shut off. Then you'll hear a few beeps and the connection LED should turn from red to green. If this doesn't work, power off and try again using the AC adapters instead of battery power. I did it without plugging in the parent unit but the battery died as soon as the units paired up again. It's working fine from the docking station though.

Dec 15, 2010 | Graco Imonitor Digital Baby Monitor

1 Answer

THE PARENT UNIT DOESNT SEEM TO PICK UP THE BABY UNIT THE PARENT UNIT SEEMS TO KEEP FLASHING WITH 2 LINES IN THE MIDDLE OF THE SCREEN WITH THE BABY UNIT FLASHING TO.


The units are not locking in to the same frequency and if this is new it must be referrred back . However if this was working earlier then there could be a shift in the communicating frequencies between the master and slave.
So remove battery of allthe units and replace after 15 minutes.,Try a reset if desccribed in the manual or the procedure for intial set up once again .

Sep 19, 2010 | Angelcare Deluxe Movement Sound Monitor...

1 Answer

1- The baby unit doesn't work on the mains only 2- The parent unit is on the charger for a day now and still doesn't open


Your issue #1 seems like a power adapter issue. Please swap the sender and receiver adapter and see if anything changes. Mark them with a sticker or felt pen before you do this because they probably are identical.
Your issue #2 seems like you have defective batteries, although I don't understand 'doesn't open'. The receiver uses standard NiMH cells that can be reached through the back battery compartment. You could swap them out and test.
If the set is still within warranty I suggest you take it back. Within the warranty period you usually get a replacement.

I hop this helps.

With kind regards,
Babycare.nl
Erwin de Raad

Sep 16, 2010 | Philips Avent® Scd510 Dect Baby Monitor

1 Answer

Base unit appears to be working, but neither of the charged handsets will work. Both are showing red and beeping, but will occasionally go green for a second before going back to red and beeping.


The units aren't paired. Call Graco at 800-345-4109 to have them walk you through pairing it. I'll try to explain what they just walked me through:

-Turn off all units. Make sure nursery and 1st parent unit is plugged directly into wall.
-Hold negative volume down on 1st parent unit. Keep holding it down.
-Press on button on 1st parent unit and let go.
-When you hear a beep, let go of negative volume button on 1st parent unit and then press it again.
-When you hear the second beep, let go of the negative volume button.
-If you have done it correctly, the 1st parent unit should have one red light at the bottom and the rest of the lights should be green.
-Turn on nursery unit and the 1st parent unit should pair with it.
-Repeat the above with the 2nd parent unit.

Nov 18, 2009 | Graco Imonitor Digital Baby Monitor

Not finding what you are looking for?
Philips Avent® Scd510 Dect Baby Monitor Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Philips Baby Gear Experts

Dorel UK
Dorel UK

Level 3 Expert

1629 Answers

Jennifer Rock
Jennifer Rock

Level 2 Expert

135 Answers

kakima

Level 3 Expert

102366 Answers

Are you a Philips Baby Gear Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...