Question about Jabsco Plumbing

Open Question

I have a Jabsco raw water pump on the front of my 350 Marine Power engine. I removed the pump and changed the #812 Johnson impeller in it and reinstalled the pump on the front of the engine. There isn't enough room to change the impeller on the engine. When I cranked the engine up after I reinstalled it, the pump started dancing rather violently. It was enough to shake the two raw water hoses. The small pipe on the bottom of the pump fits inside a rubber grommet on a "L" shaped bracket that goes out in front of the crank shaft. The engine is a 2001 and the rubber grommet looks worn. Could that be the problem? Thanks, Danny in Virginia 757-871-1432

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 566 Answers

SOURCE: Retro-fit drain hose

hi not seen one of these retro types but having always wiped the seal and door after use as recommended with clean damp cloth prevents seal deteriation i would have thought this drain?on retro type that drains accumulation of any water from seal would be draining inside the outer drum and thro to drain into pump? seems odd?

Posted on Oct 22, 2008

  • 1118 Answers

SOURCE: knocking in the bottom of ford 5.4 liter engine

If you hear it knocking no bearing replacement is going to fix that long term. Its best to pull it, the crank shaft will have to be turned or polished and or replaced, weather its a rod or a maine, and posibly line boared if its a maine thats knocking. Do it right and pull it.

Posted on Apr 10, 2009

  • 1114 Answers

SOURCE: Pressure washer - no water flow

Is there a check valve on the hose inlet that is stuck, and won't let the water in???????

Posted on Jul 08, 2009

john224
  • 1378 Answers

SOURCE: How do you remove the impeller from the pump shaft

Lock the end of the motor opposite the impeller and then turn the impeller off counter-clockwise.

Posted on Oct 26, 2009

Testimonial: "Thanks, It worked. Tom"

motor1258
  • 6674 Answers

SOURCE: My Tsurumi OM2 pump won't start after turning it

As long as your sure it's getting proper voltage, then it most likely has a start capacitor built into pump circuit, that has gone faulty.

Posted on Jan 03, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Jabsco toilet fails to fill


Was the toilet "Winterized" last fall? If so, have you assured that any plug in the clean water intake has been removed? If NOT -- are you sure the pump has not been frozen and internally damaged by ice? The pump is a simple device which rarely fail unless its inlet is blocked, or the pump seals or body are damaged - usually by freezing.

May 10, 2014 | Jabsco 29120 2000 Marine Manual Marine...

2 Answers

Changing impeller on 90hp v4 johnson 2000


Remove Linkage Under Carburetor
Remove Bolts Securing Gear Box Remove Gear Box
Do Not Turn Shift Linkage
Remove Water Pump Housing
Fit New Impeller
Re Fit Gearbox Follow Procedure In Reverse

Mar 16, 2013 | Boating

1 Answer

I have a 5.7 volvo 8 cylinder injected marine engine. where is the impeller


well you did not mention if this marine engine is powering a jet drive or a prop but actually it has one to four impellers on it , one is inside engine cooling circ pump on front of engine and two to three are inside jet drive pump (if equipped)

Sep 12, 2012 | Jacuzzi Impeller, L - 3/4 H.P

1 Answer

Bilge pump switch keeps cutting out when turned on


Check for water leak around pump or wiring. Check ground.

Aug 06, 2012 | Jabsco 18660-0121 Marine Water Puppy...

1 Answer

Toilet backs up after use. even when holding tank is empty. we only use fresh water to flush from shower nozzle. toilet is fairly new replaced by original owner.


The system does not work, as you describe, you MUST use the unit's pump lever as the intake and removal are part of it's function. Use sea water to flush, the system is designed for that.

Jan 30, 2011 | ITT Jabsco Manual Marine Toilet Compact...

2 Answers

1997 Evinrude 50 HP SPL. I have removed all the bolts holding the lower rnd to the engine, it seems to be hanging up on the shify shaft, and I can't find a way to drop the unit. It drops down about...


Okay this is on total memory. The shift shaft for a lot of those engines goes right up through the pilot shaft and exits just in front of the block under the carburetor(s). You will see the **** linkage arm connected to this shaft sometimes it's double nutted. See if you can slide the lower unit back up to the housing and put a bolt in it to hold then undue the shift shaft linkage, Remove the bolt and drop the lower unit. Be careful of the water tubes and check make sure the rubber grommets are in place in the pump housing not on the tubes. Clean up the pump housing and install the new impeller kit.
Put the impeller down the shaft on top of the impeller plate, lightly grease the inside of the housing the impeller plate and impeller. Then lower the pump housing down to the impeller while turning the drive shaft clockwise lightly push down on the impeller housing. This will fold the impeller blades all in the correct position and provide lubrication to the pump until the water gets into the pump. To make life easier re-grease the drive shaft spline and the water tube grommets this will ad ease in reinstalling the lower unit. be careful to make sure you thread the drive shaft, water tubes and shift shaft all in at the same time. After installation you may find you need to adjust the **** linkage.

Dec 11, 2010 | Boating

1 Answer

Johnson 140 1979 wont pump water with muffs on hasnt been run for 10yr but fired up straight away always been fresh water clean out been told either the impellar or maybe thermostat stuck ?


My money is on the impeller since it will stick or just dry out and get brittle. The "fins" have to bend to pump water. I'm surprised the top seal is still intact after 10 years.

Nov 10, 2009 | Boating

Not finding what you are looking for?
Plumbing Logo

Related Topics:

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jabsco Plumbing Experts

Gil Shultz

Level 3 Expert

3368 Answers

ray gallant

Level 3 Expert

41412 Answers

Brad Brown

Level 3 Expert

15441 Answers

Are you a Jabsco Plumbing Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...