Question about Sta Rite Ds3hf 1.50 Hp Self Priming Irrigation Pump

1 Answer

When I turn on my STA-RITE 1.5 HP pump, it makes a humming sound.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 56 Answers

A humming noise is fairly normal if the pump is running and pumping correctly. I am guessing this is not the case. Usually it is just a stuck impeller that is the culprit. Power down the unit and open the pump housing to access the impeller. Then gently turn the impeller feeling for resistance (some resistance is normal from the magnets of the motor). If everything seems ok close and secure the pump housing. Try powering the unit on and see if it starts up correctly. If it is still having issues manually prime the pump. If the pump runs correctly for a few minutes after manually priming but slows or stops you have a leaky seal or fitting to find. Finding the seal is not hard but will take a little time and patience. With your garden hose, very carefully run water over each joint and fitting with the pump running. It will take a minute or so of water running over a leaky seal for the pump to prime so take your time. Make sure not to get water on the motor as it can deliver a very nasty shock and destroy the motor. If none of this gets you up and running the cause may be the motor is bad and needs replacing.

Posted on Mar 19, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sta-rite 1 hp pump sounds like it is on but nothing is happening ? What is the solution?


Is the motor shaft turning??????? If not but you hear a humming sound, try replacing the start/run capacitor located at rear of motor under back cover..

Nov 14, 2015 | Pool & Spa

1 Answer

Sta rite pro jet 3/4 hp seems to be frozen..turn on and it hums then quits ..no water pressure


it sounds like you have a bad starting compositor. If your compositor is a black plastic one look next to the spade connectors in the cap and you'll see a little resest hole with a brown stopper in it. If that stopper is black, burnt or leaking oil it is bad. If you have a metal one you can set it on it's base on a flat surface. If it rocks it is bad. If the compositor is good you may have a problem with the windings and either need to replace the motor or have it rebuilt.


http://www.austinpooolspecialist.com/

Jun 25, 2014 | Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out,...

1 Answer

To purplewg re my Sta-Rite pool pump: I haven't disassembled anything yet, because I'm trying to get an accurate dx before delving. If I take the thing apart, I'll have to replace the seal, and I'd rather...


SOUNDS LIKE BEARINGS .. SEARCH YOUR LOCAL AREA FOR POOL PUMP MOTOR REPAIR GUY, SEE IF THEY OFFER FREE TESTING REMEMBER TO VOTE FOR YOUR FAVORITE FIXIT GUY ! THANKS JAY

Jun 17, 2010 | Sta Rite Max - E - Pro 1 1/2 Hp Dual Speed

1 Answer

Pump hums then breaker flips


Something is binding in the pump try the impeller to see if it runs true when you have it apart. It may be cross threaded on the shaft. This is a common problem if you have a air leak in your system.

Apr 28, 2010 | Sta Rite Max - E - Pro 1 1/2 Hp Dual Speed

1 Answer

Loud buzzing sound began on start up


It could be several things but the most likely are: Something is spinning around with the motor shaft. Unplug the motor and "blast" water through the vent holes to clear debris. Let it dry completely before returning to service. Something could be caught in the impeller. Remove the front end and check. Squeals, loud hums, heat and vibration are indications of bad bearings.

Apr 17, 2010 | Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out,...

1 Answer

The noise sounds like a much louder humming sound; Temperatures were well below freezing here last night


I'm not sure what your humming is much louder than. But if you had a freeze your pump may have froze and you will need to ck for leaks after thawing. You could have cracked your pump or hurt the seals. After you check for this, you can check for a weak start capacitor in your motor, as the cold can affect these also. Good luck.

Dec 06, 2009 | Sta Rite Sta-Rite Super Max In-Ground 1.5...

1 Answer

Spa Motor Hums


if it is a used pump, these have a tendency to have a little rust. just get some pump pliers and rock the shaft gently back and forth. then plug it back in.
David

May 17, 2009 | Sta Rite Sta - Rite Dyna - Glas Pool Pump...

Not finding what you are looking for?
Sta Rite Ds3hf 1.50 Hp Self Priming Irrigation Pump Logo

489 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sta Rite Garden Experts

appman67
appman67

Level 2 Expert

33 Answers

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

steve morris
steve morris

Level 3 Expert

1675 Answers

Are you a Sta Rite Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...