Question about Crown MA-5002VZ 2-Channel Amplifier

1 Answer

Crown IT 4000 from ROMANIA

Hello Sir! My name is Ioan, from Romania.
I have a problem with one of my Crown IT4000. After i switch on the amp, in 10-20 sec. the coolers going very fast. If i send an audio signal to it, the red light for CLIP, on each chanel apears. The sound is ok but after a few minutes, the amp turn off itself. It can be restarted after 15-20 minutes. I have tryed to load other presets or change the input sensitivity but nothing happens.
I have read about troubleshouting in the manual but all i have found is that is a thermal protection (TLC).

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 682 Answers

Make cleaning to your filter by air blower------- keep good ventilation around in the pass of air(in-out)----after you finish try to test your amp by connecting one speaker only at a time until you find the bad one--------------if all above did not pass you will have internal problem of hardware and needs service center.

Posted on Aug 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My crown vid 4000 amplifier doesn't work.after switching power it goes off after maybe 2 sec.no speaker and input during powering. Same thing happen even there is speaker and input connected


Check speaker to power bank protection circuit. The circuit is faulty indicating to the power amp that speakers are disconnected that shuts down the amp to protect the unit

Mar 10, 2015 | Crown Audio Players & Recorders

1 Answer

I need crown iT4000 semantic


Schematics are easy to find, just enter: schematic crown it4000 in the Google search engine. I cannot find any semantic

Nov 04, 2014 | Crown XTi 4000 Amplifier

1 Answer

My amp was blinking while it was working then it went off.Now it doesn't power up..Crown Xti 4000


Power supply likely failed. Electrolytics are the primary culprit.
It should have a switchmode power supply, so it is lmost likely the 5 volt section failed.

Sep 17, 2012 | Crown XTi 4000 Amplifier

1 Answer

I have a crown Itech 4000 and when I plug it in it the green light around the front power button does not light up and when I turn on the power button on the front only the blue "power" light...


Nice amp. There is a breaker/switch on the back that trips to protect the amp. Turn it off, then back on and see if the green indicator comes back. If the breaker trips again, that's probably an indication of a more serious internal problem.

Nov 09, 2010 | Crown I-TECH 6000 Amplifier

3 Answers

Fan don't work when power is turn on crown xti 4000


the fans on these amps are heat sensitive, only when the amp heats up, then they come on

Mar 27, 2010 | Crown XTi 4000 Amplifier

1 Answer

Dsp off


Try here:

http://www.crownaudio.com/express.htm

Mar 22, 2010 | Crown XTi 4000 Amplifier

1 Answer

Crown XTi 4000 brand new digital amp how can i unlock it? i dont know but the screen display short 1


Hiya, to unlock press PREV and NEXT until it says unlocked.

The short 1 sounds a little serious though. Have you tried taking off the speakers?? If still there then suggest contacting crown. They have a pretty good no nonsense 3 year warranty

Best of luck

Jul 13, 2009 | Crown XTi 4000 Amplifier

3 Answers

Crown ce 4000 amp wont work


Crown CE amps have a very decent service manual that give test points to check for faults. In these amps protect mode is a good sign that major components are not burnt out ie, (Transformer).
With a good Digital volt/ohm meter most common circuits can be checked against the service manual specifications. Usually in these amps the Zener Diode or Capacitors are the first to burn out along with cooling fans. That would be a good place to start.
Respectfully, Muzick

Oct 09, 2007 | Crown CE4000 2-Channel Amplifier

Not finding what you are looking for?
Crown MA-5002VZ 2-Channel Amplifier Logo

Related Topics:

152 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crown Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

69654 Answers

Are you a Crown Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...